summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/serialtalk/serialtalk-1.2.ebuild')
-rw-r--r--dev-util/serialtalk/serialtalk-1.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/serialtalk/serialtalk-1.2.ebuild b/dev-util/serialtalk/serialtalk-1.2.ebuild
new file mode 100644
index 000000000000..b083e3feb644
--- /dev/null
+++ b/dev-util/serialtalk/serialtalk-1.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/BGO-OD/serialtalk.git"
+else
+ SRC_URI="https://github.com/BGO-OD/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="simple command-line tool to talk to serial devices"
+HOMEPAGE="https://github.com/BGO-OD/serialtalk"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+src_install() {
+ cmake-utils_src_install
+}