summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/makepp/makepp-2.0-r1.ebuild')
-rw-r--r--dev-util/makepp/makepp-2.0-r1.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-util/makepp/makepp-2.0-r1.ebuild b/dev-util/makepp/makepp-2.0-r1.ebuild
deleted file mode 100644
index a8d44bd7fca1..000000000000
--- a/dev-util/makepp/makepp-2.0-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="4"
-
-inherit eutils
-
-MY_PV=${PV/_}
-MY_P="${PN}-${MY_PV}"
-DESCRIPTION="GNU make replacement"
-HOMEPAGE="http://makepp.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${PV%_*}/${MY_P}.txz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-linux ~ppc-macos"
-IUSE=""
-
-DEPEND=">=dev-lang/perl-5.6.0"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- ln -s "${DISTDIR}/${A}" ${P}.tar.xz
- unpack ./${P}.tar.xz
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.0-destdir.patch
-
- # default "all" rule is to run tests :x
- sed -i '/^all:/s:test::' config.pl || die
-}
-
-src_configure() {
- # not an autoconf configure script
- ./configure \
- --prefix="${EPREFIX}"/usr \
- --bindir="${EPREFIX}"/usr/bin \
- --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
- --mandir="${EPREFIX}"/usr/share/man \
- --datadir="${EPREFIX}"/usr/share/makepp \
- || die "configure failed"
-}
-
-src_test() {
- # work around https://bugzilla.samba.org/show_bug.cgi?id=8728
- export CCACHE_UNIFY=1
- ROOT= default
-}