summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/gencpp/gencpp-0.5.5.ebuild')
-rw-r--r--dev-ros/gencpp/gencpp-0.5.5.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-ros/gencpp/gencpp-0.5.5.ebuild b/dev-ros/gencpp/gencpp-0.5.5.ebuild
new file mode 100644
index 000000000000..b3211b8d4e67
--- /dev/null
+++ b/dev-ros/gencpp/gencpp-0.5.5.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/gencpp"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+inherit ros-catkin
+
+DESCRIPTION="ROS C++ message definition and serialization generators"
+HOMEPAGE="http://wiki.ros.org/gencpp"
+LICENSE="BSD"
+SLOT="0/${PV}"
+IUSE=""
+
+RDEPEND="dev-ros/genmsg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"