summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/txtorcon')
-rw-r--r--dev-python/txtorcon/txtorcon-0.19.3-r1.ebuild (renamed from dev-python/txtorcon/txtorcon-0.19.3.ebuild)7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-python/txtorcon/txtorcon-0.19.3.ebuild b/dev-python/txtorcon/txtorcon-0.19.3-r1.ebuild
index 5155d74c9df7..7a947665ebdf 100644
--- a/dev-python/txtorcon/txtorcon-0.19.3.ebuild
+++ b/dev-python/txtorcon/txtorcon-0.19.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -42,6 +42,11 @@ PATCHES=(
"${FILESDIR}/txtorcon-0.19.3-Removeinstalldocs.patch"
)
+python_prepare_all() {
+ sed -e "s/^ipaddress.*//" -i requirements.txt || die
+
+ distutils-r1_python_prepare_all
+}
python_test() {
pushd "${TEST_DIR}" > /dev/null || die
/usr/bin/trial txtorcon || die "Tests failed with ${EPYTHON}"