summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tenacity')
-rw-r--r--dev-python/tenacity/Manifest1
-rw-r--r--dev-python/tenacity/tenacity-8.3.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/tenacity/Manifest b/dev-python/tenacity/Manifest
index 633938a3c16a..cef9ceb79cfb 100644
--- a/dev-python/tenacity/Manifest
+++ b/dev-python/tenacity/Manifest
@@ -1 +1,2 @@
DIST tenacity-8.2.3.tar.gz 40651 BLAKE2B c79af0a6e0ee0af52fe47579b830ee911b10bd780467eaa22308443830a29cf76583455acbe53c92805abb51686db32696e94cb83ca2ce576a5508272e016fe4 SHA512 c1e82867c0be8a0a38d05ecee04568c3c4eebff85d8c1b90713e3ca953197da7a857d8dc20083afc4fa4b92cc5e43a8aabe8022bc104394acbe6a0aba7602613
+DIST tenacity-8.3.0.tar.gz 43608 BLAKE2B fcf7471110c831cfab20c81bb0bfa2c2895ce33b6cdf22c21dfd0f219eeb674dc4e7f4186e7c9a3366574636becd7391d68acb285069844ccaf358da6afa9c02 SHA512 46152ffacc0a87931cec09bd90eed3d2ad46f89101997c5da2aa510844c814b887a83805b4ec0de6a56759a7f2bcbab0cb2b2f1a4e6c11860ae53f64ff2a4c31
diff --git a/dev-python/tenacity/tenacity-8.3.0.ebuild b/dev-python/tenacity/tenacity-8.3.0.ebuild
new file mode 100644
index 000000000000..74ae0b01468e
--- /dev/null
+++ b/dev-python/tenacity/tenacity-8.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="General-purpose retrying library"
+HOMEPAGE="
+ https://github.com/jd/tenacity/
+ https://pypi.org/project/tenacity/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/tornado[${PYTHON_USEDEP}]
+ dev-python/typeguard[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest