summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycairo')
-rw-r--r--dev-python/pycairo/Manifest1
-rw-r--r--dev-python/pycairo/files/pycairo-1.19.1-py39.patch26
-rw-r--r--dev-python/pycairo/pycairo-1.19.1.ebuild48
3 files changed, 0 insertions, 75 deletions
diff --git a/dev-python/pycairo/Manifest b/dev-python/pycairo/Manifest
index 560251fc7761..567b04530540 100644
--- a/dev-python/pycairo/Manifest
+++ b/dev-python/pycairo/Manifest
@@ -1,2 +1 @@
-DIST pycairo-1.19.1.tar.gz 205196 BLAKE2B 504334628daf75dd9145c97fbd86ea133b4be225ce7fa911b48231ebd5434678ffa7b1f185e0527f96b4b36955e788d0bb4fa4d308843e5ae9b20a41d2126301 SHA512 a7955a2566d5e5586154b62f3aeef824e1e6076cbd3eb86af8288fedcc7d61c4e36a53691298cf9df2e2df7fc96292f96dec92c5d4343e6c1b4c971e97d0650f
DIST pycairo-1.20.0.tar.gz 344370 BLAKE2B b72a3dfd3ad6332f6be2c0fc0650ef87d97a51881bd239421cdb6355016e952093f9fa05b7872d7cce4a50bc4bac27ff0fb4c11e446e51ada9d7c1adc019a175 SHA512 d32d008b741653d02324b206a438f5fd85f2a433201d6f8b98c8f1adc712abea611a4b5ed95c55258efb662dc579eed6b2f752b10d9fc2b6a7c8e5edd19e5266
diff --git a/dev-python/pycairo/files/pycairo-1.19.1-py39.patch b/dev-python/pycairo/files/pycairo-1.19.1-py39.patch
deleted file mode 100644
index 97b20227ce8b..000000000000
--- a/dev-python/pycairo/files/pycairo-1.19.1-py39.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 3ecf0a4060d6de3b92a77a393ece663455cf6add Mon Sep 17 00:00:00 2001
-From: Christoph Reiter <reiter.christoph@gmail.com>
-Date: Sun, 10 May 2020 11:22:40 +0200
-Subject: [PATCH] tests: Fix syntax issue with Python 3.9
-
-https://bugs.python.org/issue40246
-
-I haven't actually tested with 3.9 yet, so this is just what I found
-with grep.
----
- tests/test_enums.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/tests/test_enums.py b/tests/test_enums.py
-index 4bc2e3d..02756d0 100644
---- a/tests/test_enums.py
-+++ b/tests/test_enums.py
-@@ -79,7 +79,7 @@ def get_prefix(t):
- # special case..
- if name == "PathDataType":
- name = "Path"
-- return"_".join([s.upper() for s in re.findall('[A-Z][^A-Z]*', name)])
-+ return "_".join([s.upper() for s in re.findall('[A-Z][^A-Z]*', name)])
-
- for t in types_:
- for name in dir(t):
diff --git a/dev-python/pycairo/pycairo-1.19.1.ebuild b/dev-python/pycairo/pycairo-1.19.1.ebuild
deleted file mode 100644
index 8891e2387526..000000000000
--- a/dev-python/pycairo/pycairo-1.19.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PYTHON_COMPAT=( python3_{6..9} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Python bindings for the cairo library"
-HOMEPAGE="https://www.cairographics.org/pycairo/ https://github.com/pygobject/pycairo"
-SRC_URI="https://github.com/pygobject/${PN}/releases/download/v${PV}/${P}.tar.gz"
-
-LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="examples"
-
-BDEPEND="
- test? (
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="
- >=x11-libs/cairo-1.13.1[svg]
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=( "${FILESDIR}/${P}-py39.patch" )
-
-distutils_enable_sphinx docs \
- dev-python/sphinx_rtd_theme
-distutils_enable_tests setup.py
-
-python_install() {
- distutils-r1_python_install \
- install_pkgconfig --pkgconfigdir="${EPREFIX}/usr/$(get_libdir)/pkgconfig"
-}
-
-python_install_all() {
- if use examples; then
- dodoc -r examples
- fi
-
- distutils-r1_python_install_all
-}