summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nspektr')
-rw-r--r--dev-python/nspektr/Manifest1
-rw-r--r--dev-python/nspektr/nspektr-0.3.0.ebuild67
2 files changed, 0 insertions, 68 deletions
diff --git a/dev-python/nspektr/Manifest b/dev-python/nspektr/Manifest
index 4078f92f3a3a..e4f0722f3031 100644
--- a/dev-python/nspektr/Manifest
+++ b/dev-python/nspektr/Manifest
@@ -1,2 +1 @@
-DIST nspektr-0.3.0.tar.gz 6314 BLAKE2B cb7b9b5b35a455d4e72e78d93db49b4f8e274c7d7a6c8bf7ccca52cce2598a937d31b76f1a30c4aa6d673e4ce52c4645ce7392965df35b0888d1c69226e08f00 SHA512 6fc22ad7858858f3b956ba5918ca92468f13d4b7db0e4861b836e63153f7e4319c6468e4f73969ce3fb7845ca8d97808b9db2eb2705a47fe1a8c4c19b9c2ef33
DIST nspektr-0.4.0.gh.tar.gz 6763 BLAKE2B 6393a2d16825cbd580758ba09a7f2277417fc0eb4e7c6f23d49ff1af89a7c6947d4c0bae7158424b96f8f0e3e3aab6ac3f5bb624a8d7edf61eb571b28e690d70 SHA512 c106091e949ce8236c1cf54543bebd2b63484dff95e161fb57668bd6bcb4b17ddf0ecc440c15a0df36cc8c4398ccc439b642eab49b528ba2cbedc75ff009179d
diff --git a/dev-python/nspektr/nspektr-0.3.0.ebuild b/dev-python/nspektr/nspektr-0.3.0.ebuild
deleted file mode 100644
index e263862fc659..000000000000
--- a/dev-python/nspektr/nspektr-0.3.0.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
-EAPI=7
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Distribution package dependency inspector"
-HOMEPAGE="
- https://github.com/jaraco/nspektr/
- https://pypi.org/project/nspektr/
-"
-SRC_URI="
- https://github.com/jaraco/nspektr/archive/v${PV}.tar.gz
- -> ${P}.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-RDEPEND="
- >=dev-python/jaraco-context-4.1.1-r2[${PYTHON_USEDEP}]
- >=dev-python/jaraco-functools-3.5.0-r2[${PYTHON_USEDEP}]
- >=dev-python/more-itertools-8.12.0-r1[${PYTHON_USEDEP}]
- >=dev-python/packaging-21.3-r2[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/importlib_metadata-4.11.2[${PYTHON_USEDEP}]
- ' 3.8 3.9)
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # avoid unnecessary test dep on pip
- sed -i -e 's:pip:pytest:' nspektr/__init__.py || die
- distutils-r1_src_prepare
-}
-
-src_configure() {
- grep -q 'build-backend = "setuptools' pyproject.toml ||
- die "Upstream changed build-backend, recheck"
- # write a custom pyproject.toml to ease setuptools bootstrap
- cat > pyproject.toml <<-EOF || die
- [build-system]
- requires = ["flit_core >=3.2,<4"]
- build-backend = "flit_core.buildapi"
-
- [project]
- name = "nspektr"
- version = "${PV}"
- description = "package inspector"
-
- # tests inspect itself
- [project.optional-dependencies]
- docs = [
- "fake-nonexisting",
- ]
- testing = [
- "pytest",
- ]
- EOF
-}