summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mrcfile')
-rw-r--r--dev-python/mrcfile/Manifest1
-rw-r--r--dev-python/mrcfile/mrcfile-1.5.2.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/mrcfile/Manifest b/dev-python/mrcfile/Manifest
index 4ce041412a38..89662f4a99b4 100644
--- a/dev-python/mrcfile/Manifest
+++ b/dev-python/mrcfile/Manifest
@@ -1 +1,2 @@
DIST mrcfile-1.5.1.gh.tar.gz 148148989 BLAKE2B 335a30b5e69bb4bb0348da421c721d27dcf6d1b1d1ab37bd2038e57c5c7499348e9bd183aa5b21280a8009b68e64cec03b08bde4ff3509084873ebffa2fd3b1a SHA512 8553c435c640d814b26f14253ea8954ddd54fab737879e53714cee0be77b9a929e870d2c49a5244c49b9261e2946fbfb0ac1294af6cd3888c6884d476af3ad7a
+DIST mrcfile-1.5.2.gh.tar.gz 148149005 BLAKE2B 6ea599aad553f9a1e8b794a133502f440432e6cdb65aa8c906148dad5c10c63d4905f52665b4b1875be474e32d08a761c3faebec38f124b9a20862adf66ceb52 SHA512 0db3c0a0e641166e0fcea52202b9435212c1ddc0e0b3040f0830b61da86c1d51ac102fbd08039d0ae74724723122156f2db9f68fbab095eb365a7de68b8acd11
diff --git a/dev-python/mrcfile/mrcfile-1.5.2.ebuild b/dev-python/mrcfile/mrcfile-1.5.2.ebuild
new file mode 100644
index 000000000000..e90cfd6c8d47
--- /dev/null
+++ b/dev-python/mrcfile/mrcfile-1.5.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="MRC2014 file format I/O library"
+HOMEPAGE="
+ https://pypi.org/project/mrcfile/
+ https://github.com/ccpem/mrcfile/
+"
+SRC_URI="
+ https://github.com/ccpem/mrcfile/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ >=dev-python/numpy-1.16.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest