summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/clang-python/clang-python-9.0.0.ebuild')
-rw-r--r--dev-python/clang-python/clang-python-9.0.0.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/dev-python/clang-python/clang-python-9.0.0.ebuild b/dev-python/clang-python/clang-python-9.0.0.ebuild
index 6583d35ad131..63f0e576f048 100644
--- a/dev-python/clang-python/clang-python-9.0.0.ebuild
+++ b/dev-python/clang-python/clang-python-9.0.0.ebuild
@@ -10,13 +10,14 @@ MY_P=cfe-${PV/_/}.src
DESCRIPTION="Python bindings for sys-devel/clang"
HOMEPAGE="https://llvm.org/"
SRC_URI="https://releases.llvm.org/${PV}/${MY_P}.tar.xz"
+S=${WORKDIR}/${MY_P}/bindings/python
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-fbsd"
IUSE="test"
-RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
# The module is opening libclang.so directly, and doing some blasphemy
# on top of it.
@@ -27,8 +28,6 @@ RDEPEND="
${PYTHON_DEPS}"
DEPEND="${RDEPEND}"
-S=${WORKDIR}/${MY_P}/bindings/python
-
src_unpack() {
einfo "Unpacking parts of ${MY_P}.tar.xz ..."
tar -xJf "${DISTDIR}/${MY_P}.tar.xz" "${MY_P}/bindings/python" || die