summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/aniso8601/aniso8601-10.0.0.ebuild')
-rw-r--r--dev-python/aniso8601/aniso8601-10.0.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/aniso8601/aniso8601-10.0.0.ebuild b/dev-python/aniso8601/aniso8601-10.0.0.ebuild
new file mode 100644
index 000000000000..774aebc86616
--- /dev/null
+++ b/dev-python/aniso8601/aniso8601-10.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A library for parsing ISO 8601 strings"
+HOMEPAGE="
+ https://bitbucket.org/nielsenb/aniso8601/
+ https://pypi.org/project/aniso8601/
+"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.7.3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest