summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Exception-Class')
-rw-r--r--dev-perl/Exception-Class/Exception-Class-1.370.0-r1.ebuild26
-rw-r--r--dev-perl/Exception-Class/Exception-Class-1.390.0.ebuild30
-rw-r--r--dev-perl/Exception-Class/Manifest2
-rw-r--r--dev-perl/Exception-Class/metadata.xml10
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-perl/Exception-Class/Exception-Class-1.370.0-r1.ebuild b/dev-perl/Exception-Class/Exception-Class-1.370.0-r1.ebuild
new file mode 100644
index 000000000000..fae2702f8256
--- /dev/null
+++ b/dev-perl/Exception-Class/Exception-Class-1.370.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DROLSKY
+MODULE_VERSION=1.37
+inherit perl-module
+
+DESCRIPTION="A module that allows you to declare real exception classes in Perl"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ~ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+RDEPEND="
+ >=dev-perl/Class-Data-Inheritable-0.20.0
+ >=dev-perl/Devel-StackTrace-1.200.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.310.0
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/Exception-Class/Exception-Class-1.390.0.ebuild b/dev-perl/Exception-Class/Exception-Class-1.390.0.ebuild
new file mode 100644
index 000000000000..1ffe91d9d457
--- /dev/null
+++ b/dev-perl/Exception-Class/Exception-Class-1.390.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DROLSKY
+MODULE_VERSION=1.39
+inherit perl-module
+
+DESCRIPTION="A module that allows you to declare real exception classes in Perl"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Class-Data-Inheritable-0.20.0
+ >=dev-perl/Devel-StackTrace-2.0.0
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/Exception-Class/Manifest b/dev-perl/Exception-Class/Manifest
new file mode 100644
index 000000000000..c1659ee71a10
--- /dev/null
+++ b/dev-perl/Exception-Class/Manifest
@@ -0,0 +1,2 @@
+DIST Exception-Class-1.37.tar.gz 26457 SHA256 838b93c90a0bbd73d819dc7d3d854559880120b6878976fe2ab90a141d10cedc SHA512 611895065102e4dfb40667841af0aaec436128deba8b52627b50320ddfcc191ca1c83a5084f7c4de582137790b1527791bbcfea93b24bc5095f1150a9d6bae3e WHIRLPOOL a7ee68032f1f691053cc1eb5d7b710f4e528b1f3ba994fdd5cf3e8a3bd958bbb39fdd1ad2de7924c2a85e3a08044e1df43fca009d8297af578b4c649a9e46afe
+DIST Exception-Class-1.39.tar.gz 38936 SHA256 819c756a69a6d1e31f396eca6a508b07b0a522a035b904cd1d432353cc362083 SHA512 c290a0b87b7a5e288c6c954f7ab834204184edc81089f871f1eb994d1445e3938170c1e87119fd952177dd43a3a228522188282fb0151ae33ba3a55b29a28b50 WHIRLPOOL 35bdb9adbb2565703b42d91897d5c698b1d1d378fa7ae11547cccfa844a251644667947403994158b02bdc6e32b830d7d02c4b7d6f154e7fb0125b8030bd3d52
diff --git a/dev-perl/Exception-Class/metadata.xml b/dev-perl/Exception-Class/metadata.xml
new file mode 100644
index 000000000000..654c23483a25
--- /dev/null
+++ b/dev-perl/Exception-Class/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Exception-Class</remote-id>
+ <remote-id type="cpan-module">Exception::Class</remote-id>
+ <remote-id type="cpan-module">Exception::Class::Base</remote-id>
+ </upstream>
+</pkgmetadata>