summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/llvm-ocaml/llvm-ocaml-9.0.0.ebuild')
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-9.0.0.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-9.0.0.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-9.0.0.ebuild
index bca23552f288..79b9b550b232 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-9.0.0.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-9.0.0.ebuild
@@ -4,13 +4,12 @@
EAPI=7
PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
-inherit cmake-utils llvm multiprocessing python-any-r1
+inherit cmake-utils llvm llvm.org multiprocessing python-any-r1
-MY_P=llvm-${PV/_/}.src
DESCRIPTION="OCaml bindings for LLVM"
HOMEPAGE="https://llvm.org/"
-SRC_URI="https://releases.llvm.org/${PV}/${MY_P}.tar.xz"
-S=${WORKDIR}/${MY_P}
+LLVM_COMPONENTS=( llvm )
+llvm.org_set_globals
# Keep in sync with sys-devel/llvm
ALL_LLVM_TARGETS=( AArch64 AMDGPU ARM BPF Hexagon Lanai Mips MSP430