summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/plasma-wayland-protocols/plasma-wayland-protocols-1.16.0.ebuild')
-rw-r--r--dev-libs/plasma-wayland-protocols/plasma-wayland-protocols-1.16.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/plasma-wayland-protocols/plasma-wayland-protocols-1.16.0.ebuild b/dev-libs/plasma-wayland-protocols/plasma-wayland-protocols-1.16.0.ebuild
new file mode 100644
index 000000000000..d9df14c50669
--- /dev/null
+++ b/dev-libs/plasma-wayland-protocols/plasma-wayland-protocols-1.16.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake kde.org
+
+DESCRIPTION="Plasma Specific Protocols for Wayland"
+HOMEPAGE="https://invent.kde.org/libraries/plasma-wayland-protocols"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-libs/wayland )"
+BDEPEND="
+ dev-libs/libpcre2:*
+ dev-qt/qtbase:6
+ >=kde-frameworks/extra-cmake-modules-6.0:*
+ test? ( dev-util/wayland-scanner )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DQT_MAJOR_VERSION=6
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON # ecm.eclass
+ -DKDE_INSTALL_DOCBUNDLEDIR="${EPREFIX}/usr/share/help" # ecm.eclass
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ cmake_src_configure
+}