summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/cfortran/cfortran-20210827.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-lang/cfortran/cfortran-20210827.ebuild b/dev-lang/cfortran/cfortran-20210827.ebuild
index 59c7cf784e70..14f0115b8030 100644
--- a/dev-lang/cfortran/cfortran-20210827.ebuild
+++ b/dev-lang/cfortran/cfortran-20210827.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -40,8 +40,11 @@ src_prepare() {
}
src_configure() {
- use sparc && append-fflags $(test-flags-FC -fno-store-merging -fno-tree-slp-vectorize) # bug 818400
- append-cflags $(test-flags-CC -fcommon) # bug 899452
+ use sparc && append-fflags $(test-flags-FC -fno-store-merging -fno-tree-slp-vectorize) # bug #818400
+ # bug #866560
+ filter-lto
+ append-flags -fno-strict-aliasing
+ append-cflags $(test-flags-CC -fcommon) # bug #899452
default
}