summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/pango/pango-0.12.3.ebuild')
-rw-r--r--dev-haskell/pango/pango-0.12.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-haskell/pango/pango-0.12.3.ebuild b/dev-haskell/pango/pango-0.12.3.ebuild
new file mode 100644
index 000000000000..19b88690b375
--- /dev/null
+++ b/dev-haskell/pango/pango-0.12.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+#nocabaldep is for the fancy cabal-detection feature at build-time
+CABAL_FEATURES="lib profile haddock hscolour hoogle nocabaldep"
+inherit haskell-cabal
+
+DESCRIPTION="Binding to the Pango text rendering engine"
+HOMEPAGE="http://projects.haskell.org/gtk2hs/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="=dev-haskell/cairo-0.12*:0[profile?]
+ =dev-haskell/glib-0.12*:0[profile?]
+ dev-haskell/mtl[profile?]
+ >=dev-lang/ghc-6.10.1
+ x11-libs/cairo
+ x11-libs/pango"
+DEPEND="${RDEPEND}
+ >=dev-haskell/gtk2hs-buildtools-0.12.3-r3:0"