summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/http-attoparsec')
-rw-r--r--dev-haskell/http-attoparsec/Manifest2
-rw-r--r--dev-haskell/http-attoparsec/http-attoparsec-0.1.0.ebuild27
-rw-r--r--dev-haskell/http-attoparsec/http-attoparsec-0.1.1-r1.ebuild32
-rw-r--r--dev-haskell/http-attoparsec/http-attoparsec-0.1.1-r2.ebuild32
-rw-r--r--dev-haskell/http-attoparsec/http-attoparsec-0.1.1.ebuild27
-rw-r--r--dev-haskell/http-attoparsec/metadata.xml11
6 files changed, 131 insertions, 0 deletions
diff --git a/dev-haskell/http-attoparsec/Manifest b/dev-haskell/http-attoparsec/Manifest
new file mode 100644
index 000000000000..bfc7542cd55c
--- /dev/null
+++ b/dev-haskell/http-attoparsec/Manifest
@@ -0,0 +1,2 @@
+DIST http-attoparsec-0.1.0.tar.gz 2500 SHA256 0973869e82686f348c8ba294976874162bbe365796e83b930762cfb2de978dd9 SHA512 e4769e3e6890fed12d5c685521b04d3d7fb018230f21f399abe1200a552aeb17f1d88e097683f16179201db7d9303b340d55e43f649a839e2a0e0cb758f15b70 WHIRLPOOL 6faef2458137a8826b3621874a257a1d81525743ca4be687c2421816a94644147e70a130039e74cfe5fd95b064ffc0776cc9afaa757146eeaf47d1905e31635a
+DIST http-attoparsec-0.1.1.tar.gz 2501 SHA256 43e16753f5e4126aaec41aac67562e38151fc6de9c2b10eace35841e9d48888a SHA512 7be64a4f8df874b392b3d75ecb16bb4e4f689e2c9e65eb406c7287bd637eced2c2580d27be3cfa164aac9cdfdd89cb8aaa8d9ab708e44542a478ec76a9b5955d WHIRLPOOL 52fc1ac584f481706888109951848c11f6eefcf587cb12c7bf15fadaa569db2c65b0c44e2a006609c3208e6205ac753d18b5af83abb5f27fa24a51946d49bb59
diff --git a/dev-haskell/http-attoparsec/http-attoparsec-0.1.0.ebuild b/dev-haskell/http-attoparsec/http-attoparsec-0.1.0.ebuild
new file mode 100644
index 000000000000..09fac9e90111
--- /dev/null
+++ b/dev-haskell/http-attoparsec/http-attoparsec-0.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Attoparsec parsers for http-types"
+HOMEPAGE="https://github.com/tlaitinen/http-attoparsec"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/attoparsec-0.10.4.0:=[profile?]
+ <dev-haskell/attoparsec-0.11:=[profile?]
+ >=dev-haskell/http-types-0.8.0:=[profile?]
+ <dev-haskell/http-types-0.9:=[profile?]
+ >=dev-lang/ghc-6.12.1:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8"
diff --git a/dev-haskell/http-attoparsec/http-attoparsec-0.1.1-r1.ebuild b/dev-haskell/http-attoparsec/http-attoparsec-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..9ad0fd1b27b4
--- /dev/null
+++ b/dev-haskell/http-attoparsec/http-attoparsec-0.1.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Attoparsec parsers for http-types"
+HOMEPAGE="https://github.com/tlaitinen/http-attoparsec"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/attoparsec-0.10.4.0:=[profile?] <dev-haskell/attoparsec-0.13:=[profile?]
+ >=dev-haskell/http-types-0.8.0:=[profile?] <dev-haskell/http-types-0.9:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'attoparsec >= 0.10.4.0 && < 0.12' 'attoparsec >= 0.10.4.0 && < 0.13'
+}
diff --git a/dev-haskell/http-attoparsec/http-attoparsec-0.1.1-r2.ebuild b/dev-haskell/http-attoparsec/http-attoparsec-0.1.1-r2.ebuild
new file mode 100644
index 000000000000..e95f6c9f749c
--- /dev/null
+++ b/dev-haskell/http-attoparsec/http-attoparsec-0.1.1-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Attoparsec parsers for http-types"
+HOMEPAGE="https://github.com/tlaitinen/http-attoparsec"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/attoparsec-0.10.4.0:=[profile?]
+ >=dev-haskell/http-types-0.8.0:=[profile?] <dev-haskell/http-types-0.9:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'attoparsec >= 0.10.4.0 && < 0.12' 'attoparsec >= 0.10.4.0'
+}
diff --git a/dev-haskell/http-attoparsec/http-attoparsec-0.1.1.ebuild b/dev-haskell/http-attoparsec/http-attoparsec-0.1.1.ebuild
new file mode 100644
index 000000000000..1ec22688f19e
--- /dev/null
+++ b/dev-haskell/http-attoparsec/http-attoparsec-0.1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Attoparsec parsers for http-types"
+HOMEPAGE="https://github.com/tlaitinen/http-attoparsec"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/attoparsec-0.10.4.0:=[profile?] <dev-haskell/attoparsec-0.12:=[profile?]
+ >=dev-haskell/http-types-0.8.0:=[profile?] <dev-haskell/http-types-0.9:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+"
diff --git a/dev-haskell/http-attoparsec/metadata.xml b/dev-haskell/http-attoparsec/metadata.xml
new file mode 100644
index 000000000000..8da91581407b
--- /dev/null
+++ b/dev-haskell/http-attoparsec/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Attoparsec parsers for http-types.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">tlaitinen/http-attoparsec</remote-id>
+ </upstream>
+</pkgmetadata>