summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/json')
-rw-r--r--app-vim/json/Manifest3
-rw-r--r--app-vim/json/json-20130830.ebuild16
-rw-r--r--app-vim/json/json-20140625.ebuild16
-rw-r--r--app-vim/json/json-20150511.ebuild16
-rw-r--r--app-vim/json/metadata.xml8
5 files changed, 59 insertions, 0 deletions
diff --git a/app-vim/json/Manifest b/app-vim/json/Manifest
new file mode 100644
index 000000000000..c5a9acc399d9
--- /dev/null
+++ b/app-vim/json/Manifest
@@ -0,0 +1,3 @@
+DIST json-20130830.tar.bz2 7039 SHA256 c2e3769dab296c5128ec00470d0b56f6ed5a1c2d81aef31f9a1b4c7b711916c3 SHA512 0b282d4180feff9f719c6da901d5ca55acb7aa86bd903faa6771e685efffeb0c2a603798e224354b0316109e177e0319c647e4f402123230842f60d6fb733019 WHIRLPOOL 393544cbbe1548cd8ef93ec3dd026dccd534d2ef0df9aef6e02de53350eeea6a46d8dd0941954621e72f7fe42c68ccb71270ae8d8b9c205db4661a1e08be6792
+DIST json-20140625.tar.bz2 7990 SHA256 d700986adca4d5d9d75e0d4c00771b55a4a092756c4269d52538f0d180daabb8 SHA512 c5eaee9f5a8b72559112b5feb7a721f583bf0f09cc4fbea9b6b0389ea4a07a5f14556c3f55104fe8d3521715d546ed05f99a81d8d0aeab76701a480a1466efc6 WHIRLPOOL 03d929083824e8ebdb3c611303001709e4b380857c37b9aa627a4600e46b1f247b3165ada16b42185729154c89923545c3ab911e11ee2e4f6f327e3a763ed59b
+DIST json-20150511.tar.bz2 8620 SHA256 9975f164569224a242c17392f94ad7b7e4768f56b0f7cd44979ca9319ed3b581 SHA512 357ea8ea298c6e2758db75e54334ccdfcd43d3146f032c816756688f35ff163dea99df42b9f1168aaac63e50e6ccedb85ff6f37f234e9faf72c53fb9e05c9b9c WHIRLPOOL a473798595830d8aad2de1190ba0d66abbdd1dfdad2e4dc5271340444e976fd2a24166a70b34e361ce290a0ab3d0b348281419b41bac2aab37c15fb7e44bd720
diff --git a/app-vim/json/json-20130830.ebuild b/app-vim/json/json-20130830.ebuild
new file mode 100644
index 000000000000..41bf8d4c08e0
--- /dev/null
+++ b/app-vim/json/json-20130830.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: a better JSON for Vim"
+HOMEPAGE="https://github.com/elzr/vim-json/"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ rm *-test.* || die
+}
diff --git a/app-vim/json/json-20140625.ebuild b/app-vim/json/json-20140625.ebuild
new file mode 100644
index 000000000000..bf70f83484b3
--- /dev/null
+++ b/app-vim/json/json-20140625.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: a better JSON for Vim"
+HOMEPAGE="https://github.com/elzr/vim-json/"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ rm *-test.* license.md || die
+}
diff --git a/app-vim/json/json-20150511.ebuild b/app-vim/json/json-20150511.ebuild
new file mode 100644
index 000000000000..896c647281e0
--- /dev/null
+++ b/app-vim/json/json-20150511.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: a better JSON for Vim"
+HOMEPAGE="https://github.com/elzr/vim-json/"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ rm *-test.* license.md || die
+}
diff --git a/app-vim/json/metadata.xml b/app-vim/json/metadata.xml
new file mode 100644
index 000000000000..8c75be499238
--- /dev/null
+++ b/app-vim/json/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+ <upstream>
+ <remote-id type="github">elzr/vim-json</remote-id>
+ </upstream>
+</pkgmetadata>