summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/mode-compile')
-rw-r--r--app-emacs/mode-compile/Manifest1
-rw-r--r--app-emacs/mode-compile/files/50mode-compile-gentoo.el5
-rw-r--r--app-emacs/mode-compile/metadata.xml8
-rw-r--r--app-emacs/mode-compile/mode-compile-2.29.1.ebuild18
4 files changed, 32 insertions, 0 deletions
diff --git a/app-emacs/mode-compile/Manifest b/app-emacs/mode-compile/Manifest
new file mode 100644
index 000000000000..35f72a72a54c
--- /dev/null
+++ b/app-emacs/mode-compile/Manifest
@@ -0,0 +1 @@
+DIST mode-compile-2.29.1.tar.gz 22924 SHA256 9c7dafa3a5c5706316a01071a2769beeecf228d0831fceb53d27d4e47c9d0421 SHA512 bc43d9cae411f5177ce70c736041db74c6db1dc5b766b22b92227e9e1324d304276bd104d8e3cac9ff5a877fc48b6da5b904e1acdb6cca7396fc7c26cc572815 WHIRLPOOL 3980e43e28438f5eefbd1d8e689cc18d9cc922857ec3e32b58c6aa6d056cc6798c2094b65de28705db6dfc95e493a06858a208c536f2c9d217027d47c4b311a9
diff --git a/app-emacs/mode-compile/files/50mode-compile-gentoo.el b/app-emacs/mode-compile/files/50mode-compile-gentoo.el
new file mode 100644
index 000000000000..d8dc2734d77a
--- /dev/null
+++ b/app-emacs/mode-compile/files/50mode-compile-gentoo.el
@@ -0,0 +1,5 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'mode-compile "mode-compile"
+ "Command to compile current buffer file based on the major mode" t)
+(autoload 'mode-compile-kill "mode-compile"
+ "Command to kill a compilation launched by `mode-compile'" t)
diff --git a/app-emacs/mode-compile/metadata.xml b/app-emacs/mode-compile/metadata.xml
new file mode 100644
index 000000000000..fd0567d9ae89
--- /dev/null
+++ b/app-emacs/mode-compile/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<upstream>
+ <remote-id type="github">emacsmirror/mode-compile</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-emacs/mode-compile/mode-compile-2.29.1.ebuild b/app-emacs/mode-compile/mode-compile-2.29.1.ebuild
new file mode 100644
index 000000000000..3ac3d8ab0220
--- /dev/null
+++ b/app-emacs/mode-compile/mode-compile-2.29.1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Smart command for compiling files according to major-mode"
+HOMEPAGE="https://github.com/emacsmirror/mode-compile
+ http://www.emacswiki.org/emacs/ModeCompile"
+SRC_URI="https://github.com/emacsmirror/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"