summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility/at-spi2-atk')
-rw-r--r--app-accessibility/at-spi2-atk/Manifest3
-rw-r--r--app-accessibility/at-spi2-atk/at-spi2-atk-2.12.1-r1.ebuild47
-rw-r--r--app-accessibility/at-spi2-atk/at-spi2-atk-2.12.1.ebuild39
-rw-r--r--app-accessibility/at-spi2-atk/at-spi2-atk-2.14.1.ebuild47
-rw-r--r--app-accessibility/at-spi2-atk/at-spi2-atk-2.16.0-r1.ebuild63
-rw-r--r--app-accessibility/at-spi2-atk/at-spi2-atk-2.16.0.ebuild48
-rw-r--r--app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-atk_suite.h36
-rw-r--r--app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-null-gobject.patch26
-rw-r--r--app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-out-of-source.patch55
-rw-r--r--app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test-accessible.xml16
-rw-r--r--app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test-action.xml11
-rw-r--r--app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test-component.xml13
-rw-r--r--app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test.xml16
-rw-r--r--app-accessibility/at-spi2-atk/metadata.xml5
14 files changed, 425 insertions, 0 deletions
diff --git a/app-accessibility/at-spi2-atk/Manifest b/app-accessibility/at-spi2-atk/Manifest
new file mode 100644
index 000000000000..881c14eadea9
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/Manifest
@@ -0,0 +1,3 @@
+DIST at-spi2-atk-2.12.1.tar.xz 280568 SHA256 5fa9c527bdec028e06797563cd52d49bcf06f638549df983424d88db89bb1336 SHA512 a7fc3cbc3665741ea6cee716cc68467ed110c0f6425fe418ea0f1b702931e4a07306e48264e9cd160d98c5bf762f076cad66ff2e46690af226ce33146d11aee2 WHIRLPOOL dc84563059d24ae56029989853d9e5a9a8cca5eecbed1227c4e36cd760aed4035beefbb71668221646cbd03057f1e30e44128081e2a6b32cfe48baabf4a631e5
+DIST at-spi2-atk-2.14.1.tar.xz 280952 SHA256 058f34ea60edf0a5f831c9f2bdd280fe95c1bcafb76e466e44aa0fb356d17bcb SHA512 1daee942d3c477444aaa42fb6ede6d821ff9b613f0686dd4a545406c97ceb819a3544419e0cb5d2e661f3a1b6fc92af9394801f3c51377db0ab77620e5c3d437 WHIRLPOOL 75d7e4569eed83df842e363c6203571b7bc26dbfdd71555ead0c1656eb61923817673ce18f8042c4a989a45af956ad9fd85aee5386c8aafb121bf71de99c04c6
+DIST at-spi2-atk-2.16.0.tar.xz 286668 SHA256 78efc45ec36383bf785f8636e64a8d866defeb020e00a08f92978f1fc3772ff9 SHA512 fcd40693e5ef55c640a52158996dc8bc66f53ef211c343cd5401c4bcd1669110ea836e0550eb41caee9c9f3a4f9670095a7dd8252600af943ddcb374bf50f011 WHIRLPOOL 0865cb8bfd62449bf345938a382c2a7d8efd425154e7e674c8097702e6873d98b8d2be8ac841858ba7dce166c2be4e18be1b1daf4fed43f667430ac3eeccebe2
diff --git a/app-accessibility/at-spi2-atk/at-spi2-atk-2.12.1-r1.ebuild b/app-accessibility/at-spi2-atk/at-spi2-atk-2.12.1-r1.ebuild
new file mode 100644
index 000000000000..3b9ad24a813f
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/at-spi2-atk-2.12.1-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 multilib-minimal virtualx
+
+DESCRIPTION="Gtk module for bridging AT-SPI to Atk"
+HOMEPAGE="http://live.gnome.org/Accessibility"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 arm hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+COMMON_DEPEND="
+ >=app-accessibility/at-spi2-core-2.11.2[${MULTILIB_USEDEP}]
+ >=dev-libs/atk-2.11.90[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.32:2[${MULTILIB_USEDEP}]
+ >=sys-apps/dbus-1.5[${MULTILIB_USEDEP}]
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-extra/at-spi-1.32.0-r1
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-gtklibs-20140508-r3
+ !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure --enable-p2p
+}
+
+multilib_src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ Xemake check
+}
+
+multilib_src_compile() { gnome2_src_compile; }
+multilib_src_install() { gnome2_src_install; }
diff --git a/app-accessibility/at-spi2-atk/at-spi2-atk-2.12.1.ebuild b/app-accessibility/at-spi2-atk/at-spi2-atk-2.12.1.ebuild
new file mode 100644
index 000000000000..b122f70e7871
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/at-spi2-atk-2.12.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 virtualx
+
+DESCRIPTION="Gtk module for bridging AT-SPI to Atk"
+HOMEPAGE="http://live.gnome.org/Accessibility"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+COMMON_DEPEND="
+ >=app-accessibility/at-spi2-core-2.11.2
+ >=dev-libs/atk-2.11.90
+ >=dev-libs/glib-2.32:2
+ >=sys-apps/dbus-1.5
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-extra/at-spi-1.32.0-r1
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure --enable-p2p
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ Xemake check
+}
diff --git a/app-accessibility/at-spi2-atk/at-spi2-atk-2.14.1.ebuild b/app-accessibility/at-spi2-atk/at-spi2-atk-2.14.1.ebuild
new file mode 100644
index 000000000000..3440682319d2
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/at-spi2-atk-2.14.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 multilib-minimal virtualx
+
+DESCRIPTION="Gtk module for bridging AT-SPI to Atk"
+HOMEPAGE="http://live.gnome.org/Accessibility"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+COMMON_DEPEND="
+ >=app-accessibility/at-spi2-core-2.11.2[${MULTILIB_USEDEP}]
+ >=dev-libs/atk-2.11.90[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.32:2[${MULTILIB_USEDEP}]
+ >=sys-apps/dbus-1.5[${MULTILIB_USEDEP}]
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-extra/at-spi-1.32.0-r1
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-gtklibs-20140508-r3
+ !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure --enable-p2p
+}
+
+multilib_src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ Xemake check
+}
+
+multilib_src_compile() { gnome2_src_compile; }
+multilib_src_install() { gnome2_src_install; }
diff --git a/app-accessibility/at-spi2-atk/at-spi2-atk-2.16.0-r1.ebuild b/app-accessibility/at-spi2-atk/at-spi2-atk-2.16.0-r1.ebuild
new file mode 100644
index 000000000000..045bd50ab913
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/at-spi2-atk-2.16.0-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2 multilib-minimal
+
+DESCRIPTION="Gtk module for bridging AT-SPI to Atk"
+HOMEPAGE="http://live.gnome.org/Accessibility"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="test"
+
+COMMON_DEPEND="
+ >=app-accessibility/at-spi2-core-2.15.5[${MULTILIB_USEDEP}]
+ >=dev-libs/atk-2.15.4[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.32:2[${MULTILIB_USEDEP}]
+ >=sys-apps/dbus-1.5[${MULTILIB_USEDEP}]
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-extra/at-spi-1.32.0-r1
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-gtklibs-20140508-r3
+ !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+ test? ( >=dev-libs/libxml2-2.9.1 )
+"
+
+src_prepare() {
+ # https://bugzilla.gnome.org/show_bug.cgi?id=751137
+ epatch "${FILESDIR}"/${PN}-2.16.0-out-of-source.patch
+ # Fixed in upstream git
+ epatch "${FILESDIR}"/${P}-null-gobject.patch
+ # Upstream forgot to put this in tarball :/
+ # https://bugzilla.gnome.org/show_bug.cgi?id=751138
+ cp -n "${FILESDIR}"/${PN}-2.16.0-atk_suite.h tests/atk_suite.h || die
+ mkdir tests/data/ || die
+ cp -n "${FILESDIR}"/${PN}-2.16.0-tests-data/*.xml tests/data/ || die
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure --enable-p2p $(use_with test tests)
+}
+
+multilib_src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ dbus-run-session -- emake check
+}
+
+multilib_src_compile() { gnome2_src_compile; }
+multilib_src_install() { gnome2_src_install; }
diff --git a/app-accessibility/at-spi2-atk/at-spi2-atk-2.16.0.ebuild b/app-accessibility/at-spi2-atk/at-spi2-atk-2.16.0.ebuild
new file mode 100644
index 000000000000..f5fde6e381fe
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/at-spi2-atk-2.16.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 multilib-minimal virtualx
+
+DESCRIPTION="Gtk module for bridging AT-SPI to Atk"
+HOMEPAGE="http://live.gnome.org/Accessibility"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="test"
+
+COMMON_DEPEND="
+ >=app-accessibility/at-spi2-core-2.15.5[${MULTILIB_USEDEP}]
+ >=dev-libs/atk-2.15.4[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.32:2[${MULTILIB_USEDEP}]
+ >=sys-apps/dbus-1.5[${MULTILIB_USEDEP}]
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-extra/at-spi-1.32.0-r1
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-gtklibs-20140508-r3
+ !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+ test? ( >=dev-libs/libxml2-2.9.1 )
+"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure --enable-p2p $(use_with test tests)
+}
+
+multilib_src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ Xemake check
+}
+
+multilib_src_compile() { gnome2_src_compile; }
+multilib_src_install() { gnome2_src_install; }
diff --git a/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-atk_suite.h b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-atk_suite.h
new file mode 100644
index 000000000000..17aefcdd03d7
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-atk_suite.h
@@ -0,0 +1,36 @@
+/*
+ * AT-SPI - Assistive Technology Service Provider Interface
+ * (Gnome Accessibility Project; https://wiki.gnome.org/Accessibility)
+ *
+ * Copyright (c) 2014 Samsung Electronics Co., Ltd.
+ *
+ * This library is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU Library General Public
+ * License as published by the Free Software Foundation; either
+ * version 2 of the License, or (at your option) any later version.
+ *
+ * This library is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ * Library General Public License for more details.
+ *
+ * You should have received a copy of the GNU Library General Public
+ * License along with this library; if not, write to the
+ * Free Software Foundation, Inc., 59 Temple Place - Suite 330,
+ * Boston, MA 02111-1307, USA.
+ */
+
+#ifndef _ATK_SUITE_H
+#define _ATK_SUITE_H
+
+#include <atspi/atspi.h>
+
+#define ATK_TEST_PATH_ACCESSIBLE (const char *)"/Accessible"
+#define ATK_TEST_PATH_ACTION (const char *)"/Action"
+#define ATK_TEST_PATH_COMP (const char *)"/Component"
+
+void atk_test_accessible (void);
+void atk_test_action (void);
+void atk_test_component (void);
+
+#endif /* _ATK_SUITE_H */
diff --git a/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-null-gobject.patch b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-null-gobject.patch
new file mode 100644
index 000000000000..a8f02a0eae1f
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-null-gobject.patch
@@ -0,0 +1,26 @@
+From 72220192a31df6b297312d82f059e9824e8a4dc3 Mon Sep 17 00:00:00 2001
+From: Christian Hergert <christian@hergert.me>
+Date: Fri, 15 May 2015 13:07:18 -0700
+Subject: [PATCH] atk-adapter: be careful with potential NULL GObjects
+
+I've been seeing warnings in my Gtk application for a while due to this.
+---
+ atk-adaptor/accessible-stateset.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/atk-adaptor/accessible-stateset.c b/atk-adaptor/accessible-stateset.c
+index f82910b..82820de 100644
+--- a/atk-adaptor/accessible-stateset.c
++++ b/atk-adaptor/accessible-stateset.c
+@@ -185,7 +185,7 @@ spi_atk_state_to_dbus_array (AtkObject * object, dbus_uint32_t * array)
+ {
+ AtkStateSet *set = atk_object_ref_state_set (object);
+ spi_atk_state_set_to_dbus_array (set, array);
+- g_object_unref (set);
++ g_clear_object (&set);
+ }
+
+ void
+--
+2.4.3
+
diff --git a/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-out-of-source.patch b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-out-of-source.patch
new file mode 100644
index 000000000000..df9f006350d4
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-out-of-source.patch
@@ -0,0 +1,55 @@
+diff --git a/tests/Makefile.am b/tests/Makefile.am
+index 6d388c9..b05b9bd 100644
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -9,15 +9,15 @@ atk_test_CFLAGS = $(DBUS_CFLAGS) \
+ $(ATSPI_CFLAGS) \
+ -I$(top_builddir)\
+ -I$(top_srcdir)/tests/dummyatk/ \
+- -I$(top_srcdir)/tests/dummyatk/.libs \
+- -I$(top_srcdir)/tests/dummyatk/.deps \
++ -I$(top_builddir)/tests/dummyatk/.libs \
++ -I$(top_builddir)/tests/dummyatk/.deps \
+ -I$(top_srcdir)
+
+-atk_test_LDFLAGS = libxmlloader.la \
+- libtestutils.la \
+- $(GLIB_LIBS) \
+- $(ATSPI_LIBS) \
+- $(top_srcdir)/tests/dummyatk/libdummyatk.la
++atk_test_LDADD = libxmlloader.la \
++ libtestutils.la \
++ $(GLIB_LIBS) \
++ $(ATSPI_LIBS) \
++ $(top_builddir)/tests/dummyatk/libdummyatk.la
+
+ atk_test_CPPFLAGS = -DTESTS_BUILD_DIR=\"$(top_builddir)/tests\" \
+ -DTESTS_SRC_DIR=\"$(top_srcdir)/tests\" \
+@@ -34,12 +34,12 @@ app_test_CFLAGS = -I$(top_builddir) \
+ -I$(top_srcdir)/tests/dummyatk \
+ -I$(top_srcdir)/atk-adaptor
+
+-app_test_LDFLAGS = libxmlloader.la \
+- libtestutils.la \
+- $(GLIB_LIBS) \
+- $(ATK_LIBS) \
+- $(top_srcdir)/tests/dummyatk/libdummyatk.la \
+- $(top_srcdir)/atk-adaptor/libatk-bridge-2.0.la
++app_test_LDADD = libxmlloader.la \
++ libtestutils.la \
++ $(GLIB_LIBS) \
++ $(ATK_LIBS) \
++ $(top_builddir)/tests/dummyatk/libdummyatk.la \
++ $(top_builddir)/atk-adaptor/libatk-bridge-2.0.la
+
+ app_test_SOURCES = test-application.c
+
+@@ -52,7 +52,7 @@ libxmlloader_la_CFLAGS = $(GLIB_CFLAGS) \
+ libxmlloader_la_LIBADD = $(GLIB_LIBS) \
+ $(XML_LIBS) \
+ $(GOBJ_LIBS) \
+- $(top_srcdir)/tests/dummyatk/libdummyatk.la \
++ $(top_builddir)/tests/dummyatk/libdummyatk.la \
+ $(ATK_LIBS)
+
+ libxmlloader_la_SOURCES = atk-object-xml-loader.c\
diff --git a/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test-accessible.xml b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test-accessible.xml
new file mode 100644
index 000000000000..26728ddfd6f2
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test-accessible.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" ?>
+<accessible description="Root of the accessible tree" name="root_object" role="accelerator label">
+ <accessible description="first child" name="obj1" role="alert">
+ <state state_enum="modal"/>
+ <state state_enum="multi-line"/>
+ </accessible>
+ <accessible description="second child" name="obj2" role="animation">
+ <accessible description="first prechild" name="obj2/1" role="arrow">
+ <relation relation_type="2" target_name="obj2"/>
+ </accessible>
+ <accessible description="second prechild" name="obj2/2" role="canvas"/>
+ </accessible>
+ <accessible description="third child" name="obj3" role="check box">
+ <accessible description="first prechild" name="obj3/1" role="check menu item"/>
+ </accessible>
+</accessible>
diff --git a/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test-action.xml b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test-action.xml
new file mode 100644
index 000000000000..41ddf00760e3
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test-action.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" ?>
+<accessible description="Root of the accessible tree" name="root_object" role="accelerator label">
+ <accessible description="first child" name="obj1" role="alert"/>
+ <accessible_action description="second child" name="obj2" role="application">
+ <action action_name="action1" action_description="action1 description" key_binding="action1 key binding"/>
+ <action action_name="action2" action_description="action2 description" key_binding="action2 key binding"/>
+ </accessible_action>
+ <accessible_action description="third child" name="obj3" role="push button">
+ <action action_name="action1" action_description="action1 description" key_binding="action1 key binding"/>
+ </accessible_action>
+</accessible>
diff --git a/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test-component.xml b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test-component.xml
new file mode 100644
index 000000000000..80929b0cf7a0
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test-component.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" ?>
+<accessible description="Root of the accessible tree" name="root_object" role="accelerator label">
+ <accessible_component description="second child" name="obj2" role="application">
+ <component x="350" y="200" width="0" height="0" layer="2" zorder="1" alpha="1.5"/>
+ </accessible_component>
+ <accessible_component description="third child" name="obj3" role="push button">
+ <component x="250" y="250" width="350" height="200" layer="3" zorder="2" alpha="2.5"/>
+ <accessible_component description="third child a" name="aobj3" role="push button">
+ <component x="250" y="250" width="350" height="200" layer="4" zorder="3" alpha="3.5"/>
+ </accessible_component>
+ </accessible_component>
+ <accessible description="second child" name="obj2" role="application" />
+</accessible>
diff --git a/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test.xml b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test.xml
new file mode 100644
index 000000000000..26728ddfd6f2
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" ?>
+<accessible description="Root of the accessible tree" name="root_object" role="accelerator label">
+ <accessible description="first child" name="obj1" role="alert">
+ <state state_enum="modal"/>
+ <state state_enum="multi-line"/>
+ </accessible>
+ <accessible description="second child" name="obj2" role="animation">
+ <accessible description="first prechild" name="obj2/1" role="arrow">
+ <relation relation_type="2" target_name="obj2"/>
+ </accessible>
+ <accessible description="second prechild" name="obj2/2" role="canvas"/>
+ </accessible>
+ <accessible description="third child" name="obj3" role="check box">
+ <accessible description="first prechild" name="obj3/1" role="check menu item"/>
+ </accessible>
+</accessible>
diff --git a/app-accessibility/at-spi2-atk/metadata.xml b/app-accessibility/at-spi2-atk/metadata.xml
new file mode 100644
index 000000000000..d9f21e6a89de
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome-accessibility</herd>
+</pkgmetadata>