summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ros/image_cb_detector/files/boost170.patch13
-rw-r--r--dev-ros/image_cb_detector/image_cb_detector-0.10.14-r1.ebuild4
2 files changed, 15 insertions, 2 deletions
diff --git a/dev-ros/image_cb_detector/files/boost170.patch b/dev-ros/image_cb_detector/files/boost170.patch
new file mode 100644
index 000000000000..f8ae562dadc5
--- /dev/null
+++ b/dev-ros/image_cb_detector/files/boost170.patch
@@ -0,0 +1,13 @@
+Index: image_cb_detector/CMakeLists.txt
+===================================================================
+--- image_cb_detector.orig/CMakeLists.txt
++++ image_cb_detector/CMakeLists.txt
+@@ -1,7 +1,7 @@
+ cmake_minimum_required(VERSION 2.8.3)
+ project(image_cb_detector)
+
+-find_package(Boost REQUIRED thread signals)
++find_package(Boost REQUIRED thread)
+ find_package(catkin REQUIRED actionlib actionlib_msgs calibration_msgs cv_bridge genmsg geometry_msgs image_transport message_filters roscpp sensor_msgs std_msgs)
+ find_package(OpenCV REQUIRED)
+
diff --git a/dev-ros/image_cb_detector/image_cb_detector-0.10.14-r1.ebuild b/dev-ros/image_cb_detector/image_cb_detector-0.10.14-r1.ebuild
index 8b96da0e6b06..2502c78f860a 100644
--- a/dev-ros/image_cb_detector/image_cb_detector-0.10.14-r1.ebuild
+++ b/dev-ros/image_cb_detector/image_cb_detector-0.10.14-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -29,4 +29,4 @@ RDEPEND="
dev-libs/boost:=[threads]
"
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/gcc6.patch" "${FILESDIR}/c11.patch" )
+PATCHES=( "${FILESDIR}/gcc6.patch" "${FILESDIR}/c11.patch" "${FILESDIR}/boost170.patch" )