summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pytest-xvfb/pytest-xvfb-2.0.0.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-python/pytest-xvfb/pytest-xvfb-2.0.0.ebuild b/dev-python/pytest-xvfb/pytest-xvfb-2.0.0.ebuild
index af48d69b6055..ccf3315e933c 100644
--- a/dev-python/pytest-xvfb/pytest-xvfb-2.0.0.ebuild
+++ b/dev-python/pytest-xvfb/pytest-xvfb-2.0.0.ebuild
@@ -24,6 +24,10 @@ DEPEND="
distutils_enable_tests pytest
python_test() {
- distutils_install_for_testing
- pytest -vv || die "Tests failed with ${EPYTHON}"
+ local -x PYTHONPATH="${BUILD_DIR}/install/lib"
+ esetup.py install \
+ --root="${BUILD_DIR}/install" \
+ --install-lib=lib
+
+ pytest -vv || die "Tests fail with ${EPYTHON}"
}