summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/latexrestricted/Manifest2
-rw-r--r--dev-python/latexrestricted/latexrestricted-0.6.0.ebuild29
-rw-r--r--dev-python/latexrestricted/metadata.xml12
-rw-r--r--dev-tex/latex2pydata/Manifest2
-rw-r--r--dev-tex/latex2pydata/latex2pydata-0.4.0.ebuild57
-rw-r--r--dev-tex/latex2pydata/metadata.xml12
-rw-r--r--metadata/stabilization-groups/texlive.group2
7 files changed, 116 insertions, 0 deletions
diff --git a/dev-python/latexrestricted/Manifest b/dev-python/latexrestricted/Manifest
new file mode 100644
index 000000000000..d80917ef4734
--- /dev/null
+++ b/dev-python/latexrestricted/Manifest
@@ -0,0 +1,2 @@
+DIST latexrestricted-0.6.0-explicitly-set-build-backend.patch 1161 BLAKE2B 7472a8b4ccec9dfdee6e994dcdbd2fa48c6dbd528444fd81769d7a8b997c1cf8dff86a66a7b1674bdcb3025022c41f954cc35740f0b8dab57dea0dc02d8e6db1 SHA512 bf1e50688c11a817a1f444f6e7a9dd90c413269fef68f7649b718d45ca458f38b712028f6b01777c65a016e17edd70cc609e605804cb6cec93b05ccbafad309b
+DIST latexrestricted-0.6.0.gh.tar.gz 21319 BLAKE2B f655861032ba38b87987a205def64d69e1602102c0d8e7b7fdb249e91cfd1a3bf506217a42829fb1a98387b0775db696c2d7ecb1e766cd1524766d866819f503 SHA512 99b4ff4818d24878e4eca0610a97b0a84e0f37f9432cf6e79cef352c67c9463d47049dd4b279d45b5869327dea9fae9c24d1a40e8d44d459c21a74b14ed68b68
diff --git a/dev-python/latexrestricted/latexrestricted-0.6.0.ebuild b/dev-python/latexrestricted/latexrestricted-0.6.0.ebuild
new file mode 100644
index 000000000000..796c8ec544fb
--- /dev/null
+++ b/dev-python/latexrestricted/latexrestricted-0.6.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for creating executables compatible with LaTeX restricted shell escape"
+HOMEPAGE="
+ https://github.com/gpoore/latexrestricted
+ https://pypi.org/project/latexrestricted/
+"
+SRC_URI="
+ https://github.com/gpoore/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ https://github.com/gpoore/latexrestricted/commit/ebbb2280db83a859f26a2f2dc0252e4d6e316452.patch
+ -> ${PN}-0.6.0-explicitly-set-build-backend.patch
+"
+
+LICENSE="LPPL-1.3c"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=(
+ "${DISTDIR}"/${PN}-0.6.0-explicitly-set-build-backend.patch
+)
diff --git a/dev-python/latexrestricted/metadata.xml b/dev-python/latexrestricted/metadata.xml
new file mode 100644
index 000000000000..b54d1eb42c74
--- /dev/null
+++ b/dev-python/latexrestricted/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>tex@gentoo.org</email>
+ <name>Gentoo TeX Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">gpoore/latexrestricted</remote-id>
+ <remote-id type="pypi">latexrestricted</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-tex/latex2pydata/Manifest b/dev-tex/latex2pydata/Manifest
new file mode 100644
index 000000000000..19f559486028
--- /dev/null
+++ b/dev-tex/latex2pydata/Manifest
@@ -0,0 +1,2 @@
+DIST latex2pydata-0.4.0-explicitly-set-build-backend.patch 1196 BLAKE2B de64d8aa56137407771c5f49347be1725aed643ab3251aacb3c12d23ad7075f9ba3429d9b6c937bcdfb43a3ae56078866ef6d800291d1c796518610954f4d430 SHA512 72f4180f4e5c4a818fc79c59f0c3cf672c764986896a9ea80dc40c58eb5a5587464127d79c4f87226d476145b05bda5f4e13b25f507bee6485eb657817e84f64
+DIST latex2pydata-0.4.0.gh.tar.gz 346788 BLAKE2B 8ff018857f3b3140b1d21cbdca4ec5c73156d724ea5131aa1235343f8308e95af2ebb0f265a3b8a59a3a10adb926a9c93c210e66cc1238e4b8bfe39a979b3ed9 SHA512 41bf2438230a48c52275a3c3988f2e4024cf5939fae4b7309cbd6ac3ee889fc1f9f00e5e862caaf71c53229bb933ba38c86271ede68848c06fd21073ee26630b
diff --git a/dev-tex/latex2pydata/latex2pydata-0.4.0.ebuild b/dev-tex/latex2pydata/latex2pydata-0.4.0.ebuild
new file mode 100644
index 000000000000..e7476536d8b8
--- /dev/null
+++ b/dev-tex/latex2pydata/latex2pydata-0.4.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 latex-package
+
+DESCRIPTION="Allows LaTeX to save data to files using Python"
+HOMEPAGE="
+ https://github.com/gpoore/latex2pydata
+ https://pypi.org/project/latex2pydata/
+"
+SRC_URI="
+ https://github.com/gpoore/${PN}/archive/refs/tags/latex/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ https://github.com/gpoore/latex2pydata/commit/539ea2c24769a509728ac6ba52a20df588576376.patch
+ -> ${PN}-0.4.0-explicitly-set-build-backend.patch
+"
+
+S="${WORKDIR}/${PN}-latex-v${PV}"
+
+LICENSE="LPPL-1.3c"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=(
+ "${DISTDIR}"/${PN}-0.4.0-explicitly-set-build-backend.patch
+)
+
+# DEPEND=">=dev-texlive/texlive-latexextra-2024"
+
+src_compile() {
+ pushd python &> /dev/null || die
+ distutils-r1_src_compile
+ popd &> /dev/null || die
+
+ pushd latex/latex2pydata &> /dev/null || die
+ latex-package_src_compile
+ popd &> /dev/null || die
+}
+
+src_install() {
+ pushd python &> /dev/null || die
+ distutils-r1_src_install
+ docinto python
+ dodoc *.md
+ popd &> /dev/null || die
+
+ pushd latex/latex2pydata &> /dev/null || die
+ latex-package_src_install
+ docinto latex
+ dodoc *.md
+ popd &> /dev/null || die
+}
diff --git a/dev-tex/latex2pydata/metadata.xml b/dev-tex/latex2pydata/metadata.xml
new file mode 100644
index 000000000000..c52bf1079d3a
--- /dev/null
+++ b/dev-tex/latex2pydata/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>tex@gentoo.org</email>
+ <name>Gentoo TeX Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">gpoore/latex2pydata</remote-id>
+ <remote-id type="pypi">latex2pydata</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/metadata/stabilization-groups/texlive.group b/metadata/stabilization-groups/texlive.group
index 27542c101c0f..f4b755091975 100644
--- a/metadata/stabilization-groups/texlive.group
+++ b/metadata/stabilization-groups/texlive.group
@@ -11,11 +11,13 @@ app-text/ttf2pk2
app-text/xdvik
dev-libs/kpathsea
dev-libs/ptexenc
+dev-python/latexrestricted
dev-tex/biber
dev-tex/biblatex
dev-tex/bibtexu
dev-tex/glossaries
dev-tex/latex-beamer
+dev-tex/latex2pydata
dev-tex/latexdiff
dev-tex/latexmk
dev-tex/minted