summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--profiles/package.mask6
-rw-r--r--www-client/conkeror/Manifest2
-rw-r--r--www-client/conkeror/conkeror-1.0.4.ebuild59
-rw-r--r--www-client/conkeror/files/conkeror.desktop14
-rw-r--r--www-client/conkeror/files/conkeror.sh14
-rw-r--r--www-client/conkeror/metadata.xml16
6 files changed, 0 insertions, 111 deletions
diff --git a/profiles/package.mask b/profiles/package.mask
index 2a3c1e675fe0..602ec425f4b3 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -485,12 +485,6 @@ net-libs/libosip
# Masked for removal on 2018-11-24, bug #669650.
dev-db/pgadmin3
-# Ulrich Müller <ulm@gentoo.org> (23 Oct 2018)
-# Depends on <www-client/firefox-57 which is package masked.
-# Use www-client/surf or www-client/qutebrowser as replacement.
-# Masked for removal in 30 days, bug #667528.
-www-client/conkeror
-
# Lars Wendler <polynomial-c@gentoo.org> (22 Oct 2018)
# Breaks dev-libs/gobject-introspection and its consumers
# See #669278
diff --git a/www-client/conkeror/Manifest b/www-client/conkeror/Manifest
deleted file mode 100644
index 220ef3d55a1a..000000000000
--- a/www-client/conkeror/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST conkeror-1.0.4.tar.xz 243876 BLAKE2B 112a05a8601f67f1a360f8fa947c0d325aac8276f72f02a6162fd3ec886d8b912e75991c94e4ec5bb9ebb44c6762bcbcb7f5a18c89410ba7d2294c38f66aba84 SHA512 4d6f3391b3ddcaedf532b9108cecfea2378c15307a669a46dcdd98ed39bdf25f6facf741aba66be4f683afe951e1c25ca011a94440d98bb0621d9b2cb10adeca
-DIST conkeror.png 5105 BLAKE2B 7d8d455e76987d0db00748ea6d5319793685b2e0061539f9378411245644f46a8e40eadfb59a5d543c17d058e2dc5f85c1cc3d2deabe5b988adb9dd689fa2bcd SHA512 fd44e2732a74ab6a54ef4a946f20619aa74d24d2244b0d6bedfa6d4680bc3247d297565550d8c3a5cc4a8ca608761ccb8f61e71cbe0c2851d400f8fa426e034f
diff --git a/www-client/conkeror/conkeror-1.0.4.ebuild b/www-client/conkeror/conkeror-1.0.4.ebuild
deleted file mode 100644
index 7ad54c59d1c9..000000000000
--- a/www-client/conkeror/conkeror-1.0.4.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs desktop xdg-utils
-
-DESCRIPTION="A Mozilla-based web browser whose design is inspired by GNU Emacs"
-HOMEPAGE="http://conkeror.org/"
-# snapshot from git://repo.or.cz/conkeror.git
-# conkeror.png is derived from http://commons.wikimedia.org/wiki/File:Conker.jpg
-SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz
- https://dev.gentoo.org/~ulm/distfiles/${PN}.png"
-
-# CC-BY-SA-3.0 for conkeror.png
-LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 ) CC-BY-SA-3.0"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="|| ( ( >=www-client/firefox-5.0 <www-client/firefox-57 )
- ( >=www-client/firefox-bin-23.0 <www-client/firefox-bin-57 ) )"
-
-S="${WORKDIR}/${PN}"
-
-src_unpack() {
- unpack ${P}.tar.xz
- cp "${DISTDIR}/${PN}.png" . || die
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
-}
-
-src_install() {
- insinto /usr/share/${PN}
- doins -r branding chrome components content defaults help locale modules \
- search-engines style tests
- doins application.ini *.manifest Info.plist
-
- exeinto /usr/libexec/${PN}
- doexe conkeror-spawn-helper
- dosym ../../libexec/${PN}/conkeror-spawn-helper \
- /usr/share/${PN}/conkeror-spawn-helper
-
- newbin "${FILESDIR}/conkeror.sh" conkeror
- domenu "${FILESDIR}/conkeror.desktop"
- doicon "${WORKDIR}/conkeror.png"
-
- doman contrib/man/conkeror.1
- dodoc CREDITS README
-}
-
-pkg_postinst() {
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
-}
diff --git a/www-client/conkeror/files/conkeror.desktop b/www-client/conkeror/files/conkeror.desktop
deleted file mode 100644
index fcf6123c9d44..000000000000
--- a/www-client/conkeror/files/conkeror.desktop
+++ /dev/null
@@ -1,14 +0,0 @@
-[Desktop Entry]
-Type=Application
-Version=1.0
-Name=Conkeror
-GenericName=Web Browser
-Comment=Conkeror is a Mozilla-based web browser whose design is inspired by GNU Emacs
-Icon=conkeror
-TryExec=/usr/bin/conkeror
-Exec=/usr/bin/conkeror %u
-Terminal=false
-Categories=Network;WebBrowser;
-MimeType=text/html;text/xml;
-StartupNotify=true
-StartupWMClass=Conkeror
diff --git a/www-client/conkeror/files/conkeror.sh b/www-client/conkeror/files/conkeror.sh
deleted file mode 100644
index 9b46d5bb0c07..000000000000
--- a/www-client/conkeror/files/conkeror.sh
+++ /dev/null
@@ -1,14 +0,0 @@
-#!/bin/bash
-# Wrapper script for conkeror
-
-for cmd in firefox firefox-bin; do
- xr=$(type -p ${cmd})
- if [[ -n ${xr} ]]; then
- : ${MOZ_PLUGIN_PATH:=/usr/lib/nsbrowser/plugins} #497070
- export MOZ_PLUGIN_PATH
- exec "${xr}" -app /usr/share/conkeror/application.ini "$@"
- fi
-done
-
-echo "$0: firefox required, but not found." >&2
-exit 1
diff --git a/www-client/conkeror/metadata.xml b/www-client/conkeror/metadata.xml
deleted file mode 100644
index 03e6bc934531..000000000000
--- a/www-client/conkeror/metadata.xml
+++ /dev/null
@@ -1,16 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="person">
- <email>ulm@gentoo.org</email>
- <name>Ulrich Müller</name>
-</maintainer>
-<longdescription>
- Conkeror is a keyboard-oriented, highly-customizable, highly-extensible
- web browser based on Mozilla XULRunner, written mainly in JavaScript, and
- inspired by exceptional software such as Emacs and vi. Conkeror features a
- sophisticated keyboard system, allowing users to run commands and interact
- with content in powerful and novel ways, and it is self-documenting,
- featuring a powerful interactive help system.
-</longdescription>
-</pkgmetadata>