summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/stomp/Manifest1
-rw-r--r--dev-ruby/stomp/stomp-1.4.10.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/stomp/Manifest b/dev-ruby/stomp/Manifest
index f4c87745f652..055b7586488f 100644
--- a/dev-ruby/stomp/Manifest
+++ b/dev-ruby/stomp/Manifest
@@ -1 +1,2 @@
+DIST stomp-1.4.10.gem 99840 BLAKE2B 5dc2b18d7551629dccb599a77934bffcf92d83158b6797a1645f5fd8af6c4738e1d8d97d5a6c6bb6655c19f98accd4ecdee0677096f9a5e89bdf0295532a1087 SHA512 bff1a533e5455cf4540bab3b5d16c63f1e0783b0257b5e0bf2fd26512586670ce5db66f97e098805c7b5fc02913478553409b90a4014bdc883465bc7b474eb7e
DIST stomp-1.4.9.gem 99328 BLAKE2B 9aa50880224cede15be69657ec7ecccf1a075db3e51de55faf3a0ba50335b90b910d1202c646585229cc35c0e2e4cf01fd99774960d9ae90ff82030c4bac6a69 SHA512 e1e3aed86621e2dac199fd7e4ba67fedc3582b5cfe9e4ff2efbdc9c545bb25d2c52391d9403e2fa935f69635e85bd3c1ca29d2d5b3c425aa850d3ccb8f7a5e86
diff --git a/dev-ruby/stomp/stomp-1.4.10.ebuild b/dev-ruby/stomp/stomp-1.4.10.ebuild
new file mode 100644
index 000000000000..d9e26e486d79
--- /dev/null
+++ b/dev-ruby/stomp/stomp-1.4.10.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby bindings for the stomp messaging protocol"
+HOMEPAGE="https://github.com/stompgem/stomp"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # Skip specs that hang the test run indefinitely, most likely
+ # because of rspec-mocks deprecation output
+ rm -f spec/connection_spec.rb || die
+}