summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/nghttp2/nghttp2-9999.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/net-libs/nghttp2/nghttp2-9999.ebuild b/net-libs/nghttp2/nghttp2-9999.ebuild
index 776f0f6311a0..2e6405711fca 100644
--- a/net-libs/nghttp2/nghttp2-9999.ebuild
+++ b/net-libs/nghttp2/nghttp2-9999.ebuild
@@ -4,13 +4,13 @@
# TODO: Add python support.
-EAPI="5"
+EAPI=6
inherit multilib-minimal
if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://github.com/tatsuhiro-t/nghttp2.git"
- inherit git-2
+ inherit autotools git-r3
else
SRC_URI="https://github.com/tatsuhiro-t/nghttp2/releases/download/v${PV}/${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
@@ -38,6 +38,11 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
multilib_src_configure() {
ECONF_SOURCE=${S} \
econf \