summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/cmd2/Manifest1
-rw-r--r--dev-python/cmd2/cmd2-0.9.15.ebuild44
-rw-r--r--dev-ruby/net-http-persistent/Manifest1
-rw-r--r--dev-ruby/net-http-persistent/net-http-persistent-3.1.0.ebuild31
-rw-r--r--dev-ruby/rouge/Manifest1
-rw-r--r--dev-ruby/rouge/rouge-3.7.0.ebuild31
-rw-r--r--eclass/ruby-ng.eclass114
-rw-r--r--sci-mathematics/alt-ergo/alt-ergo-1.30.ebuild4
-rw-r--r--sci-mathematics/cvc4/cvc4-1.7.ebuild4
9 files changed, 198 insertions, 33 deletions
diff --git a/dev-python/cmd2/Manifest b/dev-python/cmd2/Manifest
index cb280f5f8b4a..a25469b04ee5 100644
--- a/dev-python/cmd2/Manifest
+++ b/dev-python/cmd2/Manifest
@@ -2,3 +2,4 @@ DIST cmd2-0.7.5.tar.gz 64939 BLAKE2B 57c8d3f4c7c94e8e2627fb5d2cf8c164da72c531808
DIST cmd2-0.7.9.tar.gz 71298 BLAKE2B d1623e2d6a7ac66058b5a43a9688ba850962fa7b5659c3287a9aef9a7deb16338d71a2c07ef15ec72ee5e62aae0ce3cdf2f202d0d423040b734dee059f1d4876 SHA512 39086794ea57cdfdc7388aaa485770f1a76457bf2b2f58cd4703dc0c082f58a8343aa777304e833133040fdab8ef8451d85bc3c19721432514bb380330823abd
DIST cmd2-0.8.9.tar.gz 112543 BLAKE2B b55edd450abcff863a34252b724919ace9f65b62b8175f28a1bb4fb64692a67723339a887dac45e87f37db71773689cfa213038740a4b3d165bf95f9cdad1d0e SHA512 80c80b67f8a1709156450fa476215a5466cca2853102f6012f1d83867a311d86a68d441dcea9895b62add731b3d00a7c3ecefde939b4f2ccd61d058ef9386a84
DIST cmd2-0.9.14.tar.gz 530199 BLAKE2B a503e71959927e01986028da423c11f971972df0826f95cb06ca0594d9b90c19a5502ec19d741ea7a30b0ab9fb6f9d33fb5c20fc37c01695039b69979b862410 SHA512 4a606fc821f32dccb53b0558645850b383f814ae79f65e491376638960c5951ddff3ff860190d6ffe37b9fd616f44659793c1b1389eb76fbb369726cc1108c77
+DIST cmd2-0.9.15.tar.gz 550232 BLAKE2B b9e57ca150ee94cfc38bf394f9a3a8de06c4e63c8787944491fc5802781c3afc585d075b07b636c673dd20e50cd1222a7cd146a6284abc0f87873ccb915ec2a3 SHA512 6a2405e6b83200fb53cc251a4095fea6dfe0d7edd26875aee5121267d7615599aef4d84592be2b72b9cbd38e22e25f320d4c334b82e360140d517b65f2be25a8
diff --git a/dev-python/cmd2/cmd2-0.9.15.ebuild b/dev-python/cmd2/cmd2-0.9.15.ebuild
new file mode 100644
index 000000000000..715f6032dc28
--- /dev/null
+++ b/dev-python/cmd2/cmd2-0.9.15.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{3_5,3_6,3_7} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Extra features for standard library's cmd module"
+HOMEPAGE="https://github.com/python-cmd2/cmd2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.3.7[${PYTHON_USEDEP}]
+ >=dev-python/pyperclip-1.6[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python3_5)
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ # test rely on very specific text wrapping...
+ local -x COLUMNS=80
+ pytest -vv || die
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
diff --git a/dev-ruby/net-http-persistent/Manifest b/dev-ruby/net-http-persistent/Manifest
index a08beffa0bd4..54d1eedba3f1 100644
--- a/dev-ruby/net-http-persistent/Manifest
+++ b/dev-ruby/net-http-persistent/Manifest
@@ -1,3 +1,4 @@
DIST net-http-persistent-2.9.4.gem 31232 BLAKE2B 54388d26971c3ea3353e0c39acd00fe77befd66e408c54be13f7ecea194517a2e71b8d9bebb1238f4d36d7be96584c0be9e6a7bbc44f81f88004dd118fa56311 SHA512 9251e8422c2f43e7ecd8bc287fa9fff682fac84ed95d143425b0e7e7678a06c9be01db56e6a956588d6c33ddccbd1eff45a6f399f43d452de8e3134e6c50b74e
DIST net-http-persistent-3.0.0.gem 30208 BLAKE2B 2bbd87d66e65081c76bc9cddaeb38f3ffd8a92b5b64f7717f77c7a927e2032fa732c2e82e220a75a63ddc10dfaa6a0f24e4fa7e0964e2ebd3d0729127f1fb452 SHA512 a601d3abde43b196406e3cdd6b704796ed70db67dfb67c9b510e0164ce7355cc925cac37fbf4c5889f41b069890ba2e2c15440fb40294ed21891fd08d9f87894
DIST net-http-persistent-3.0.1.gem 26112 BLAKE2B 987e7c690d1e08e6be490aaecbd42ec8dc95fe5d2dc3609313b5be301453e4a30a66486334419e2ce9af9bd08158c3b78600cd8364fc6f489529ca1657436ee3 SHA512 33f23c6d23a8d2e44c0268e720200e4e19ba50bbfb9268a3c7af653fbfff62e606f1d10b2ff35ea345f4f7c0456892a901753257da87e9a2bb329edd36030761
+DIST net-http-persistent-3.1.0.gem 31744 BLAKE2B fdd9c36ab5216c1cd1fe358207a689276e109845ac374ea16011469b6cb2b165115e78e701cce98c280e7f878c23d8016e75cac4508c7e579209012671b64101 SHA512 65b5afc4ad0729ec14b642e0e36363cecfff3dc25b26308d632866e93fed3eccfb83ce85da78f631553c6a1fe3ee834fcbc9d3681c85db6387463abbc30e60fa
diff --git a/dev-ruby/net-http-persistent/net-http-persistent-3.1.0.ebuild b/dev-ruby/net-http-persistent/net-http-persistent-3.1.0.ebuild
new file mode 100644
index 000000000000..b1b172d1e070
--- /dev/null
+++ b/dev-ruby/net-http-persistent/net-http-persistent-3.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Manages persistent connections using Net::HTTP plus a speed fix for Ruby 1.8"
+HOMEPAGE="https://github.com/drbrain/net-http-persistent"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_rdepend ">=dev-ruby/connection_pool-2.2:0"
+
+ruby_add_bdepend "
+ test? ( dev-ruby/hoe dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ # avoid test with implicit dependency on net-http-pipeline which
+ # fails and is not tested upstream
+ sed -i -e '/net-http-pipeline not installed/ s/unless.*$//' test/test_net_http_persistent.rb || die
+}
diff --git a/dev-ruby/rouge/Manifest b/dev-ruby/rouge/Manifest
index e96624e483d5..3cfe4a5bffe4 100644
--- a/dev-ruby/rouge/Manifest
+++ b/dev-ruby/rouge/Manifest
@@ -3,3 +3,4 @@ DIST rouge-3.1.1.gem 282624 BLAKE2B 07074cda2634330fe26bedc370c85967f892fa239160
DIST rouge-3.3.0.gem 331776 BLAKE2B c258479642d0f89f7aa0ec6366525b43e899056cdc374b2cdaef4949968eff664ba6dd9ff07f33cf9606ba1f759288e665104bfe3b5bca3446f35ec56cb506b6 SHA512 b4d043d1df7c286f7a81c85c770144da3acab946c3c53570f3d530dba9414023641c52a8ee338abddfd178e2037e7390e61f344fa4d88a690e184f180a4da35c
DIST rouge-3.5.1.tar.gz 722730 BLAKE2B 6244eb7cb74354325a4e992464ab25222f2fbe20acac1baee1a9049b5b4c4056160a0a5b7bc71a893439e974a4e58d260e8207d8a7c2f37d649e1c43d2a4ad5b SHA512 e8f6e8dabae41ca374217b3dcb3a1de6b3a46752b4af122a9731083de2e18e04b2f2a173dfa35b845d76c70530457c276b4da2098ed07d451bd2e86c12e17e18
DIST rouge-3.6.0.tar.gz 727487 BLAKE2B d5430e0dec82244c8c5fc0df3de318556f3b6c24579b34a724f20953765ab9fabfd79c5aeab3ff9d16f5f4c7db531b0b9d511938b8836207f4a64050a4bff112 SHA512 b5ec4d6325a752033d8c1e1bbe1618840bf2b5c556391ae8d978971a520f83a49d7244f0386193c947689d84d61d98137b8d8a06ed83e3c1d6769923a1c6c1c1
+DIST rouge-3.7.0.tar.gz 761581 BLAKE2B 681b8447a0f56e774f155ca735fa57b18a58f7ba3a55f995c3b42927392c91891facee557ed85a9faae86a9fa3301aedca995cff9a9b3d729c1be8e0cbdb8b97 SHA512 9360a4e0d564435da1481503222794e4b5649b4ece1b410d079c69f10e89e20bdf08c9d04663919cfbb7ce7b7cf0688604649c42c2442750bb1301d68e78248f
diff --git a/dev-ruby/rouge/rouge-3.7.0.ebuild b/dev-ruby/rouge/rouge-3.7.0.ebuild
new file mode 100644
index 000000000000..ffabec94cfef
--- /dev/null
+++ b/dev-ruby/rouge/rouge-3.7.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Yet-another-markdown-parser using a strict syntax definition in pure Ruby"
+HOMEPAGE="https://github.com/jneen/rouge"
+SRC_URI="https://github.com/jneen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/redcarpet )"
+ruby_add_rdepend "dev-ruby/redcarpet
+ !!<dev-ruby/rouge-1.11.1-r2:0"
+
+all_ruby_prepare() {
+ rm -f tasks/update/changelog.rake || die
+
+ sed -i -e '/bundler/I s:^:#: ; 5irequire "minitest-power_assert"' spec/spec_helper.rb || die
+ sed -i -e '/\(changelog\|bundler\)/ s:^:#: ; 1irequire "pathname"' Rakefile || die
+}
diff --git a/eclass/ruby-ng.eclass b/eclass/ruby-ng.eclass
index 8dc3e1661252..a0c03ab6027e 100644
--- a/eclass/ruby-ng.eclass
+++ b/eclass/ruby-ng.eclass
@@ -8,7 +8,7 @@
# Author: Diego E. Pettenò <flameeyes@gentoo.org>
# Author: Alex Legler <a3li@gentoo.org>
# Author: Hans de Graaff <graaff@gentoo.org>
-# @SUPPORTED_EAPIS: 4 5 6
+# @SUPPORTED_EAPIS: 4 5 6 7
# @BLURB: An eclass for installing Ruby packages with proper support for multiple Ruby slots.
# @DESCRIPTION:
# The Ruby eclass is designed to allow an easier installation of Ruby packages
@@ -43,7 +43,7 @@
# @DESCRIPTION:
# Set the value to "yes" to make the dependency on a Ruby interpreter
# optional and then ruby_implementations_depend() to help populate
-# DEPEND and RDEPEND.
+# BDEPEND, DEPEND and RDEPEND.
# @ECLASS-VARIABLE: RUBY_S
# @DEFAULT_UNSET
@@ -69,21 +69,24 @@
local inherits=""
case ${EAPI} in
4|5)
- inherits="eutils"
+ inherits="eutils toolchain-funcs"
+ ;;
+ 6)
+ inherits="estack toolchain-funcs"
;;
*)
inherits="estack"
;;
esac
-inherit ${inherits} multilib toolchain-funcs ruby-utils
+inherit ${inherits} multilib ruby-utils
EXPORT_FUNCTIONS src_unpack src_prepare src_configure src_compile src_test src_install pkg_setup
case ${EAPI} in
0|1|2|3)
die "Unsupported EAPI=${EAPI} (too old) for ruby-ng.eclass" ;;
- 4|5|6)
+ 4|5|6|7)
# S is no longer automatically assigned when it doesn't exist.
S="${WORKDIR}"
;;
@@ -205,9 +208,16 @@ ruby_add_rdepend() {
case $# in
1) ;;
2)
- [[ "${GENTOO_DEV}" == "yes" ]] && eqawarn "You can now use the usual syntax in ruby_add_rdepend for $CATEGORY/$PF"
- ruby_add_rdepend "$(_ruby_wrap_conditions "$1" "$2")"
- return
+ case ${EAPI} in
+ 4|5|6)
+ [[ "${GENTOO_DEV}" == "yes" ]] && eqawarn "You can now use the usual syntax in ruby_add_rdepend for $CATEGORY/$PF"
+ ruby_add_rdepend "$(_ruby_wrap_conditions "$1" "$2")"
+ return
+ ;;
+ *)
+ die "Use the usual depend syntax with a single argument in ruby_add_rdepend"
+ ;;
+ esac
;;
*)
die "bad number of arguments to $0"
@@ -220,26 +230,36 @@ ruby_add_rdepend() {
# Add the dependency as a test-dependency since we're going to
# execute the code during test phase.
- DEPEND="${DEPEND} test? ( ${dependency} )"
+ case ${EAPI} in
+ 4|5|6) DEPEND="${DEPEND} test? ( ${dependency} )" ;;
+ *) BDEPEND="${BDEPEND} test? ( ${dependency} )" ;;
+ esac
has test "$IUSE" || IUSE="${IUSE} test"
}
# @FUNCTION: ruby_add_bdepend
# @USAGE: dependencies
# @DESCRIPTION:
-# Adds the specified dependencies, with use condition(s) to DEPEND,
-# taking the current set of ruby targets into account. This makes sure
-# that all ruby dependencies of the package are installed for the same
-# ruby targets. Use this function for all ruby dependencies instead of
-# setting DEPEND yourself. The list of atoms uses the same syntax as
-# normal dependencies.
+# Adds the specified dependencies, with use condition(s) to DEPEND (or
+# BDEPEND in EAPI7), taking the current set of ruby targets into
+# account. This makes sure that all ruby dependencies of the package are
+# installed for the same ruby targets. Use this function for all ruby
+# dependencies instead of setting DEPEND or BDEPEND yourself. The list
+# of atoms uses the same syntax as normal dependencies.
ruby_add_bdepend() {
case $# in
1) ;;
2)
- [[ "${GENTOO_DEV}" == "yes" ]] && eqawarn "You can now use the usual syntax in ruby_add_bdepend for $CATEGORY/$PF"
- ruby_add_bdepend "$(_ruby_wrap_conditions "$1" "$2")"
- return
+ case ${EAPI} in
+ 4|5|6)
+ [[ "${GENTOO_DEV}" == "yes" ]] && eqawarn "You can now use the usual syntax in ruby_add_bdepend for $CATEGORY/$PF"
+ ruby_add_bdepend "$(_ruby_wrap_conditions "$1" "$2")"
+ return
+ ;;
+ *)
+ die "Use the usual depend syntax with a single argument in ruby_add_bdepend"
+ ;;
+ esac
;;
*)
die "bad number of arguments to $0"
@@ -248,10 +268,35 @@ ruby_add_bdepend() {
local dependency=$(_ruby_atoms_samelib "$1")
- DEPEND="${DEPEND} $dependency"
+ case ${EAPI} in
+ 4|5|6) DEPEND="${DEPEND} $dependency" ;;
+ *) BDEPEND="${BDEPEND} $dependency" ;;
+ esac
RDEPEND="${RDEPEND}"
}
+# @FUNCTION: ruby_add_depend
+# @USAGE: dependencies
+# @DESCRIPTION:
+
+# Adds the specified dependencies to DEPEND in EAPI7, similar to
+# ruby_add_bdepend.
+ruby_add_depend() {
+ case ${EAPI} in
+ 4|5|6) die "only available in EAPI 7 and newer" ;;
+ *) ;;
+ esac
+
+ case $# in
+ 1) ;;
+ *) die "bad number of arguments to $0" ;;
+ esac
+
+ local dependency=$(_ruby_atoms_samelib "$1")
+
+ DEPEND="${DEPEND} $dependency"
+}
+
# @FUNCTION: ruby_get_use_implementations
# @DESCRIPTION:
# Gets an array of ruby use targets enabled by the user
@@ -283,7 +328,7 @@ ruby_get_use_targets() {
# confuse this function with ruby_implementation_depend().
#
# @EXAMPLE:
-# EAPI=6
+# EAPI=7
# RUBY_OPTIONAL=yes
#
# inherit ruby-ng
@@ -305,6 +350,10 @@ if [[ ${RUBY_OPTIONAL} != yes ]]; then
DEPEND="${DEPEND} $(ruby_implementations_depend)"
RDEPEND="${RDEPEND} $(ruby_implementations_depend)"
REQUIRED_USE+=" || ( $(ruby_get_use_targets) )"
+ case ${EAPI} in
+ 4|5|6) ;;
+ *) BDEPEND="${BDEPEND} $(ruby_implementations_depend)" ;;
+ esac
fi
_ruby_invoke_environment() {
@@ -417,11 +466,16 @@ _ruby_apply_patches() {
fi
done
;;
- *)
+ 6)
if [[ -n ${RUBY_PATCHES[@]} ]]; then
eqawarn "RUBY_PATCHES is no longer supported, use PATCHES instead"
fi
;;
+ *)
+ if [[ -n ${RUBY_PATCHES[@]} ]]; then
+ die "RUBY_PATCHES is no longer supported, use PATCHES instead"
+ fi
+ ;;
esac
# This is a special case: instead of executing just in the special
@@ -507,10 +561,10 @@ _each_ruby_check_install() {
# we have a Mach-O object here
[[ ${CHOST} == *-darwin ]] && scancmd=scanmacho
- local libruby_basename=$(${RUBY} -rrbconfig -e 'puts RbConfig::CONFIG["LIBRUBY_SO"]')
+ local libruby_basename=$(ruby_rbconfig_value 'LIBRUBY_SO')
local libruby_soname=$(basename $(${scancmd} -F "%S#F" -qS "${EPREFIX}/usr/$(get_libdir)/${libruby_basename}") 2>/dev/null)
- local sitedir=$(${RUBY} -rrbconfig -e 'puts RbConfig::CONFIG["sitedir"]')
- local sitelibdir=$(${RUBY} -rrbconfig -e 'puts RbConfig::CONFIG["sitelibdir"]')
+ local sitedir=$(ruby_rbconfig_value 'sitedir')
+ local sitelibdir=$(ruby_rbconfig_value 'sitelibdir')
# The current implementation lacks libruby (i.e.: jruby)
[[ -z ${libruby_soname} ]] && return 0
@@ -626,8 +680,8 @@ ruby-ng_rspec() {
files="spec"
fi
- if [[ ${DEPEND} != *"dev-ruby/rspec"* ]]; then
- ewarn "Missing dev-ruby/rspec in \${DEPEND}"
+ if [[ "${DEPEND}${BDEPEND}" != *"dev-ruby/rspec"* ]]; then
+ ewarn "Missing test dependency dev-ruby/rspec"
fi
local rspec_params=
@@ -657,8 +711,8 @@ ruby-ng_rspec() {
# This is simply a wrapper around the cucumber command (executed by $RUBY})
# which also respects TEST_VERBOSE and NOCOLOR environment variables.
ruby-ng_cucumber() {
- if [[ ${DEPEND} != *"dev-util/cucumber"* ]]; then
- ewarn "Missing dev-util/cucumber in \${DEPEND}"
+ if [[ "${DEPEND}${BDEPEND}" != *"dev-util/cucumber"* ]]; then
+ ewarn "Missing test dependency dev-util/cucumber"
fi
local cucumber_params=
@@ -691,8 +745,8 @@ ruby-ng_cucumber() {
# their script and we installed a broken wrapper for a while.
# This also respects TEST_VERBOSE and NOCOLOR environment variables.
ruby-ng_testrb-2() {
- if [[ ${DEPEND} != *"dev-ruby/test-unit"* ]]; then
- ewarn "Missing dev-ruby/test-unit in \${DEPEND}"
+ if [[ "${DEPEND}${BDEPEND}" != *"dev-ruby/test-unit"* ]]; then
+ ewarn "Missing test dependency dev-ruby/test-unit"
fi
local testrb_params=
diff --git a/sci-mathematics/alt-ergo/alt-ergo-1.30.ebuild b/sci-mathematics/alt-ergo/alt-ergo-1.30.ebuild
index e5229fc89224..80b72760c868 100644
--- a/sci-mathematics/alt-ergo/alt-ergo-1.30.ebuild
+++ b/sci-mathematics/alt-ergo/alt-ergo-1.30.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,7 +16,7 @@ DEPEND=">=dev-lang/ocaml-3.12.1[ocamlopt?]
dev-ml/zarith
gtk? ( >=dev-ml/lablgtk-2.14[sourceview,ocamlopt?] )
dev-ml/camlzip
- dev-ml/ocplib-simplex"
+ <=dev-ml/ocplib-simplex-0.3"
RDEPEND="${DEPEND}"
DOCS=( CHANGES INSTALL.md README.md )
diff --git a/sci-mathematics/cvc4/cvc4-1.7.ebuild b/sci-mathematics/cvc4/cvc4-1.7.ebuild
index cc6e6eb4f4f6..09aab161f76d 100644
--- a/sci-mathematics/cvc4/cvc4-1.7.ebuild
+++ b/sci-mathematics/cvc4/cvc4-1.7.ebuild
@@ -12,11 +12,12 @@ SRC_URI="https://github.com/CVC4/CVC4/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+cln +statistics proofs replay"
+IUSE="+cln proofs readline replay +statistics"
RDEPEND="dev-libs/antlr-c
dev-java/antlr:3
dev-libs/boost
+ readline? ( sys-libs/readline:0= )
cln? ( sci-libs/cln )
!cln? ( dev-libs/gmp:= )"
DEPEND="${RDEPEND}"
@@ -32,6 +33,7 @@ src_configure() {
-DENABLE_GPL=ON
-DENABLE_OPTIMIZED=ON
-DUSE_CLN="$(usex cln ON OFF)"
+ -DUSE_READLINE="$(usex readline ON OFF)"
-DENABLE_STATISTICS="$(usex statistics ON OFF)"
-DENABLE_PROOFS="$(usex proofs ON OFF)"
-DENABLE_REPLAY="$(usex replay ON OFF)"