summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.34.83.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 4e54453a0552..dfc6f11c7efd 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -4,3 +4,4 @@ DIST boto3-1.34.79.gh.tar.gz 792796 BLAKE2B 97a4f8e6fc33bcfe2817ce353df8ff6354bc
DIST boto3-1.34.80.gh.tar.gz 793186 BLAKE2B aa45147344c21291f413580473bdd358d25e69944c16ea43e731465911c5c16fdc1e9fde20d69634debdc7cd0af07a999072ee6ecfb6c0b93a96ecb66dee78b3 SHA512 a43be78c98060a0aeb232dad7bb118768711e375f8137d0b59293397056a360a6a6e7d067651404c4ae43180d9c5e100fd2ee041b8ecc17e9982a30cdfc0e8d4
DIST boto3-1.34.81.gh.tar.gz 793676 BLAKE2B 40e8eccfc1a619c5d542233faa13aa099fad43c6eddf669914cdbcd58c44bb13433ccad44d6aa2ef5162ba4f7725269b60e82d9093b2119b029eb884b0fdb4ef SHA512 a1823dd568f3e46bdea0830cd1a56aecd949d7e5f1e3558f759a672ed10f754faf546a69c8f1489dc203f04dc173de644689b6bdb53c4446f3cf81adbabc9211
DIST boto3-1.34.82.gh.tar.gz 794338 BLAKE2B ea4053423ed712e7ecbaeb749eb1f6a8bc4a2302f71662d10fb9014a2c95a7539943bbffb8175a1fbda9631c931aea2a756f337ccc2f59cd4bf4ae4b5063049b SHA512 d21b91f4f3fee6e91414ce75a39622a09ea7c570c5877fa140e88ea3ab04ce98a34167a973802766c5c654b9a038c536199cc330c1687af9b917ebf4767223a5
+DIST boto3-1.34.83.gh.tar.gz 795426 BLAKE2B 22e43acbea7d09c4b5c682b4783acf6ca136e2b62f826928b91e17a495cc8ab6123aa9518c53bd31f029db792f1436e6d358eae35250de944236629924e6260f SHA512 d194d01c8b73c26e0f7c23f2c5f4eb863777eae59390f4824cb3e316f0ea8efee055584f8d8aa7718833a354ab5a96f8714e5fd9d8ec76dac2b268c92fe464fa
diff --git a/dev-python/boto3/boto3-1.34.83.ebuild b/dev-python/boto3/boto3-1.34.83.ebuild
new file mode 100644
index 000000000000..2c733040b7a3
--- /dev/null
+++ b/dev-python/boto3/boto3-1.34.83.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}