summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-6.1.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index 02bff830b8d7..621f965f6c85 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.27.11.tar.xz 27980 BLAKE2B 4fa35480f0ed7389bf41f56fc8266fccb8a33060c37f6df2c1edc44f49466267dbd45584e0afff6aaa79a3b5ffc1aca916c36a7ad768e36a457c081bfa53f217 SHA512 85c4091faa4ec4a6d068d4a0d464601054b88187ccfa05f4156b146dd3b3900dc15bcb3f9f9b0b057fb9b5687eabf55bb34d06d98a9e26ddb6a0afba1684feee
DIST ksshaskpass-6.0.90.tar.xz 29428 BLAKE2B 0498dd75e2e1bfc3f4b09aefa579d7744a138e72bd8c45905686ef16ee7656975f6f68200adc4ecae311c4596a53e7ce8ebe1108b2fd730a4a7e5a623e8a0048 SHA512 5a92080d11b9fc404a6f65defe7a23c01ecdd70b7903885b3f746c2bee2dbe289a5d01e024d26bd44b5aa20906a7e7fb3ea0b5f22dbe295716b0468e33d4fc7b
+DIST ksshaskpass-6.1.0.tar.xz 29464 BLAKE2B d8b89ee96bed71b60ddbf132ee1ccad60487cd31933f7431b6c070bc6ea1b28f1480875c9f9e2ad858265f0bf475538398298f09ebd4a66f9dbe683af854c394 SHA512 2aa768e759436f51c47a0586085a887c441b564d3ff5fdad8b66214549059a4bf9862ab325a44fdadb5bc33de1c04603cc3642e6aca39566f957acaca7146990
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-6.1.0.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-6.1.0.ebuild
new file mode 100644
index 000000000000..5d41c227a0f6
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-6.1.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=6.3.0
+QTMIN=6.7.1
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Implementation of ssh-askpass with KDE Wallet integration"
+HOMEPAGE+=" https://invent.kde.org/plasma/ksshaskpass"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[widgets]
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kwallet-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ ecm_src_install
+
+ insinto /etc/xdg/plasma-workspace/env/
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ elog "In order to have ssh-agent start with Plasma 6,"
+ elog "edit /etc/xdg/plasma-workspace/env/10-agent-startup.sh"
+ elog "and uncomment the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh"
+ elog "to properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 6 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh"
+}