summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/mimalloc/Manifest2
-rw-r--r--dev-libs/mimalloc/mimalloc-2.0.6.ebuild31
-rw-r--r--dev-libs/mimalloc/mimalloc-2.0.7.ebuild30
3 files changed, 0 insertions, 63 deletions
diff --git a/dev-libs/mimalloc/Manifest b/dev-libs/mimalloc/Manifest
index 3521833c23aa..7e3c24864946 100644
--- a/dev-libs/mimalloc/Manifest
+++ b/dev-libs/mimalloc/Manifest
@@ -1,3 +1 @@
-DIST mimalloc-2.0.6.tar.gz 1127052 BLAKE2B bd8a38cc0eab6ad950a63f494f24e6a91c50d2104335e9ce70963a7baadd26c7a2b7440b2fcabe502d9961549222873d017cb525bf5b32da967cf51aa167603c SHA512 f2fc0fbfb6384e85959897f129e5d5d9acc51bda536d5cabcd7d4177dbda9fb735b8a8c239b961f8bea31d37c9ae10f66da23aa91d497f95393253d4ac792bb3
-DIST mimalloc-2.0.7.tar.gz 1137057 BLAKE2B dc7ca7443507b14967168e4899464d137da425bdbc3863d44faef7adfe62e983cec0a7950937f010d003ff4df3c4368ff2f9753c3fda19641ab12f91fc73055c SHA512 120f89eef50ba83130e8ceb974a6148c84a7f3d975d1efaa094142518afb4ff6d9e24f8e75e9aa0bb02dc80bf497eced4b8ae1f2f5914fdabd773317e1341ea1
DIST mimalloc-2.0.9.tar.gz 1143452 BLAKE2B 55e91d8fc89ef5344078caa5e72efce8c0745e3aab7bfb682587abf806bda1903c1afeaa57660a4dbcf7c19c04c759caf69af9fb62d15ecbdf2ce5bcf6574625 SHA512 bf6945bfb600ade35dab34c7f570ee4f69a77612547ad874bbbd989a4e594a6a219c222a22c90c5e36f205aae4d5cd1a5e4651caed5433db275d414c6769bf49
diff --git a/dev-libs/mimalloc/mimalloc-2.0.6.ebuild b/dev-libs/mimalloc/mimalloc-2.0.6.ebuild
deleted file mode 100644
index f72c408d29ed..000000000000
--- a/dev-libs/mimalloc/mimalloc-2.0.6.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake-multilib
-
-DESCRIPTION="A compact general purpose allocator with excellent performance"
-HOMEPAGE="https://github.com/microsoft/mimalloc"
-SRC_URI="https://github.com/microsoft/mimalloc/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/2"
-KEYWORDS="amd64 ~loong ~riscv ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-src_configure() {
- local mycmakeargs=(
- # TODO: build hardened variant?
- #-DMI_SECURE=$(usex hardened)
-
- -DMI_INSTALL_TOPLEVEL=ON
- -DMI_BUILD_TESTS=$(usex test)
-
- -DMI_BUILD_OBJECT=OFF
- -DMI_BUILD_STATIC=OFF
- )
-
- cmake-multilib_src_configure
-}
diff --git a/dev-libs/mimalloc/mimalloc-2.0.7.ebuild b/dev-libs/mimalloc/mimalloc-2.0.7.ebuild
deleted file mode 100644
index 8f67eb2dad98..000000000000
--- a/dev-libs/mimalloc/mimalloc-2.0.7.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake-multilib
-
-DESCRIPTION="A compact general purpose allocator with excellent performance"
-HOMEPAGE="https://github.com/microsoft/mimalloc"
-SRC_URI="https://github.com/microsoft/mimalloc/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/2"
-KEYWORDS="amd64 ~loong ~riscv ~x86"
-IUSE="hardened test"
-RESTRICT="!test? ( test )"
-
-src_configure() {
- local mycmakeargs=(
- -DMI_SECURE=$(usex hardened)
-
- -DMI_INSTALL_TOPLEVEL=ON
- -DMI_BUILD_TESTS=$(usex test)
-
- -DMI_BUILD_OBJECT=OFF
- -DMI_BUILD_STATIC=OFF
- )
-
- cmake-multilib_src_configure
-}