summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/wine-proton/wine-proton-7.0.6.ebuild19
-rw-r--r--app-emulation/wine-proton/wine-proton-8.0.5c.ebuild19
-rw-r--r--app-emulation/wine-proton/wine-proton-9.0.1.ebuild19
-rw-r--r--app-emulation/wine-proton/wine-proton-9.0.9999.ebuild19
-rw-r--r--app-emulation/wine-staging/wine-staging-9.0.ebuild20
-rw-r--r--app-emulation/wine-staging/wine-staging-9.7.ebuild20
-rw-r--r--app-emulation/wine-staging/wine-staging-9.8.ebuild20
-rw-r--r--app-emulation/wine-staging/wine-staging-9.9.ebuild20
-rw-r--r--app-emulation/wine-staging/wine-staging-9999.ebuild20
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-7.0.2.ebuild20
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-8.0.2.ebuild20
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-9.0.ebuild20
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-9.7.ebuild20
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-9.8.ebuild20
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-9.9.ebuild20
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-9999.ebuild20
-rw-r--r--app-office/unoconv/unoconv-0.9.0-r1.ebuild8
-rw-r--r--dev-ruby/parser/Manifest4
-rw-r--r--dev-ruby/parser/parser-3.2.2.4.ebuild41
-rw-r--r--dev-ruby/parser/parser-3.3.0.4.ebuild40
-rw-r--r--dev-ruby/parser/parser-3.3.2.0.ebuild (renamed from dev-ruby/parser/parser-3.3.0.3.ebuild)2
-rw-r--r--dev-ruby/test-unit-ruby-core/Manifest1
-rw-r--r--dev-ruby/test-unit-ruby-core/test-unit-ruby-core-1.0.6.ebuild16
23 files changed, 248 insertions, 180 deletions
diff --git a/app-emulation/wine-proton/wine-proton-7.0.6.ebuild b/app-emulation/wine-proton/wine-proton-7.0.6.ebuild
index 546bcaf60b4a..cdab45831b77 100644
--- a/app-emulation/wine-proton/wine-proton-7.0.6.ebuild
+++ b/app-emulation/wine-proton/wine-proton-7.0.6.ebuild
@@ -355,11 +355,20 @@ pkg_preinst() {
pkg_postinst() {
[[ -v WINE_HAD_ANY_SLOT ]] || readme.gentoo_print_elog
- if use abi_x86_32 && has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'
- then
- ewarn "x11-drivers/nvidia-drivers is installed but is built without"
- ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
- ewarn "applications under ${PN} will likely not be usable."
+ if use abi_x86_32; then
+ # difficult to tell what is needed from here, but try to warn
+ if has_version 'x11-drivers/nvidia-drivers'; then
+ if has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'; then
+ ewarn "x11-drivers/nvidia-drivers is installed but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ ewarn "Multi-card setups may need this on media-libs/mesa as well."
+ fi
+ elif has_version 'media-libs/mesa[-abi_x86_32]'; then
+ ewarn "media-libs/mesa seems to be in use but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ fi
fi
eselect wine update --if-unset || die
diff --git a/app-emulation/wine-proton/wine-proton-8.0.5c.ebuild b/app-emulation/wine-proton/wine-proton-8.0.5c.ebuild
index e5b25d63323f..83417e7c34f7 100644
--- a/app-emulation/wine-proton/wine-proton-8.0.5c.ebuild
+++ b/app-emulation/wine-proton/wine-proton-8.0.5c.ebuild
@@ -372,11 +372,20 @@ pkg_preinst() {
pkg_postinst() {
[[ -v WINE_HAD_ANY_SLOT ]] || readme.gentoo_print_elog
- if use abi_x86_32 && has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'
- then
- ewarn "x11-drivers/nvidia-drivers is installed but is built without"
- ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
- ewarn "applications under ${PN} will likely not be usable."
+ if use abi_x86_32; then
+ # difficult to tell what is needed from here, but try to warn
+ if has_version 'x11-drivers/nvidia-drivers'; then
+ if has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'; then
+ ewarn "x11-drivers/nvidia-drivers is installed but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ ewarn "Multi-card setups may need this on media-libs/mesa as well."
+ fi
+ elif has_version 'media-libs/mesa[-abi_x86_32]'; then
+ ewarn "media-libs/mesa seems to be in use but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ fi
fi
eselect wine update --if-unset || die
diff --git a/app-emulation/wine-proton/wine-proton-9.0.1.ebuild b/app-emulation/wine-proton/wine-proton-9.0.1.ebuild
index 4558c65461b2..1dd72b877060 100644
--- a/app-emulation/wine-proton/wine-proton-9.0.1.ebuild
+++ b/app-emulation/wine-proton/wine-proton-9.0.1.ebuild
@@ -404,11 +404,20 @@ pkg_postinst() {
ewarn "work, be warned that it is not unusual that installers or other helpers"
ewarn "will attempt to use 32bit and fail. If do not want full USE=abi_x86_32,"
ewarn "note the experimental/WIP USE=wow64 can allow 32bit without multilib."
- elif use abi_x86_32 && has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'
- then
- ewarn "x11-drivers/nvidia-drivers is installed but is built without"
- ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
- ewarn "applications under ${PN} will likely not be usable."
+ elif use abi_x86_32; then
+ # difficult to tell what is needed from here, but try to warn
+ if has_version 'x11-drivers/nvidia-drivers'; then
+ if has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'; then
+ ewarn "x11-drivers/nvidia-drivers is installed but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ ewarn "Multi-card setups may need this on media-libs/mesa as well."
+ fi
+ elif has_version 'media-libs/mesa[-abi_x86_32]'; then
+ ewarn "media-libs/mesa seems to be in use but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ fi
fi
eselect wine update --if-unset || die
diff --git a/app-emulation/wine-proton/wine-proton-9.0.9999.ebuild b/app-emulation/wine-proton/wine-proton-9.0.9999.ebuild
index ceddb4a00eec..f43dad37ae8e 100644
--- a/app-emulation/wine-proton/wine-proton-9.0.9999.ebuild
+++ b/app-emulation/wine-proton/wine-proton-9.0.9999.ebuild
@@ -406,11 +406,20 @@ pkg_postinst() {
ewarn "work, be warned that it is not unusual that installers or other helpers"
ewarn "will attempt to use 32bit and fail. If do not want full USE=abi_x86_32,"
ewarn "note the experimental/WIP USE=wow64 can allow 32bit without multilib."
- elif use abi_x86_32 && has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'
- then
- ewarn "x11-drivers/nvidia-drivers is installed but is built without"
- ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
- ewarn "applications under ${PN} will likely not be usable."
+ elif use abi_x86_32; then
+ # difficult to tell what is needed from here, but try to warn
+ if has_version 'x11-drivers/nvidia-drivers'; then
+ if has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'; then
+ ewarn "x11-drivers/nvidia-drivers is installed but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ ewarn "Multi-card setups may need this on media-libs/mesa as well."
+ fi
+ elif has_version 'media-libs/mesa[-abi_x86_32]'; then
+ ewarn "media-libs/mesa seems to be in use but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ fi
fi
eselect wine update --if-unset || die
diff --git a/app-emulation/wine-staging/wine-staging-9.0.ebuild b/app-emulation/wine-staging/wine-staging-9.0.ebuild
index c7ad9c55076f..f82e62bb333f 100644
--- a/app-emulation/wine-staging/wine-staging-9.0.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9.0.ebuild
@@ -464,12 +464,20 @@ pkg_postinst() {
ewarn "work, be warned that it is not unusual that installers or other helpers"
ewarn "will attempt to use 32bit and fail. If do not want full USE=abi_x86_32,"
ewarn "note the experimental/WIP USE=wow64 can allow 32bit without multilib."
- elif use abi_x86_32 && { use opengl || use vulkan; } &&
- has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'
- then
- ewarn "x11-drivers/nvidia-drivers is installed but is built without"
- ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
- ewarn "applications under ${PN} will likely not be usable."
+ elif use abi_x86_32 && { use opengl || use vulkan; }; then
+ # difficult to tell what is needed from here, but try to warn
+ if has_version 'x11-drivers/nvidia-drivers'; then
+ if has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'; then
+ ewarn "x11-drivers/nvidia-drivers is installed but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ ewarn "Multi-card setups may need this on media-libs/mesa as well."
+ fi
+ elif has_version 'media-libs/mesa[-abi_x86_32]'; then
+ ewarn "media-libs/mesa seems to be in use but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ fi
fi
eselect wine update --if-unset || die
diff --git a/app-emulation/wine-staging/wine-staging-9.7.ebuild b/app-emulation/wine-staging/wine-staging-9.7.ebuild
index 1a169317c27f..24424d0c615d 100644
--- a/app-emulation/wine-staging/wine-staging-9.7.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9.7.ebuild
@@ -459,12 +459,20 @@ pkg_postinst() {
ewarn "work, be warned that it is not unusual that installers or other helpers"
ewarn "will attempt to use 32bit and fail. If do not want full USE=abi_x86_32,"
ewarn "note the experimental/WIP USE=wow64 can allow 32bit without multilib."
- elif use abi_x86_32 && { use opengl || use vulkan; } &&
- has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'
- then
- ewarn "x11-drivers/nvidia-drivers is installed but is built without"
- ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
- ewarn "applications under ${PN} will likely not be usable."
+ elif use abi_x86_32 && { use opengl || use vulkan; }; then
+ # difficult to tell what is needed from here, but try to warn
+ if has_version 'x11-drivers/nvidia-drivers'; then
+ if has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'; then
+ ewarn "x11-drivers/nvidia-drivers is installed but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ ewarn "Multi-card setups may need this on media-libs/mesa as well."
+ fi
+ elif has_version 'media-libs/mesa[-abi_x86_32]'; then
+ ewarn "media-libs/mesa seems to be in use but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ fi
fi
optfeature "/dev/hidraw* access used for *some* controllers (e.g. DualShock4)" \
diff --git a/app-emulation/wine-staging/wine-staging-9.8.ebuild b/app-emulation/wine-staging/wine-staging-9.8.ebuild
index dff82e982ed2..5409f612826e 100644
--- a/app-emulation/wine-staging/wine-staging-9.8.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9.8.ebuild
@@ -460,12 +460,20 @@ pkg_postinst() {
ewarn "work, be warned that it is not unusual that installers or other helpers"
ewarn "will attempt to use 32bit and fail. If do not want full USE=abi_x86_32,"
ewarn "note the experimental/WIP USE=wow64 can allow 32bit without multilib."
- elif use abi_x86_32 && { use opengl || use vulkan; } &&
- has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'
- then
- ewarn "x11-drivers/nvidia-drivers is installed but is built without"
- ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
- ewarn "applications under ${PN} will likely not be usable."
+ elif use abi_x86_32 && { use opengl || use vulkan; }; then
+ # difficult to tell what is needed from here, but try to warn
+ if has_version 'x11-drivers/nvidia-drivers'; then
+ if has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'; then
+ ewarn "x11-drivers/nvidia-drivers is installed but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ ewarn "Multi-card setups may need this on media-libs/mesa as well."
+ fi
+ elif has_version 'media-libs/mesa[-abi_x86_32]'; then
+ ewarn "media-libs/mesa seems to be in use but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ fi
fi
optfeature "/dev/hidraw* access used for *some* controllers (e.g. DualShock4)" \
diff --git a/app-emulation/wine-staging/wine-staging-9.9.ebuild b/app-emulation/wine-staging/wine-staging-9.9.ebuild
index c8f8d0cdc861..087ec27eccec 100644
--- a/app-emulation/wine-staging/wine-staging-9.9.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9.9.ebuild
@@ -459,12 +459,20 @@ pkg_postinst() {
ewarn "work, be warned that it is not unusual that installers or other helpers"
ewarn "will attempt to use 32bit and fail. If do not want full USE=abi_x86_32,"
ewarn "note the experimental/WIP USE=wow64 can allow 32bit without multilib."
- elif use abi_x86_32 && { use opengl || use vulkan; } &&
- has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'
- then
- ewarn "x11-drivers/nvidia-drivers is installed but is built without"
- ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
- ewarn "applications under ${PN} will likely not be usable."
+ elif use abi_x86_32 && { use opengl || use vulkan; }; then
+ # difficult to tell what is needed from here, but try to warn
+ if has_version 'x11-drivers/nvidia-drivers'; then
+ if has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'; then
+ ewarn "x11-drivers/nvidia-drivers is installed but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ ewarn "Multi-card setups may need this on media-libs/mesa as well."
+ fi
+ elif has_version 'media-libs/mesa[-abi_x86_32]'; then
+ ewarn "media-libs/mesa seems to be in use but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ fi
fi
optfeature "/dev/hidraw* access used for *some* controllers (e.g. DualShock4)" \
diff --git a/app-emulation/wine-staging/wine-staging-9999.ebuild b/app-emulation/wine-staging/wine-staging-9999.ebuild
index c8f8d0cdc861..087ec27eccec 100644
--- a/app-emulation/wine-staging/wine-staging-9999.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9999.ebuild
@@ -459,12 +459,20 @@ pkg_postinst() {
ewarn "work, be warned that it is not unusual that installers or other helpers"
ewarn "will attempt to use 32bit and fail. If do not want full USE=abi_x86_32,"
ewarn "note the experimental/WIP USE=wow64 can allow 32bit without multilib."
- elif use abi_x86_32 && { use opengl || use vulkan; } &&
- has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'
- then
- ewarn "x11-drivers/nvidia-drivers is installed but is built without"
- ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
- ewarn "applications under ${PN} will likely not be usable."
+ elif use abi_x86_32 && { use opengl || use vulkan; }; then
+ # difficult to tell what is needed from here, but try to warn
+ if has_version 'x11-drivers/nvidia-drivers'; then
+ if has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'; then
+ ewarn "x11-drivers/nvidia-drivers is installed but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ ewarn "Multi-card setups may need this on media-libs/mesa as well."
+ fi
+ elif has_version 'media-libs/mesa[-abi_x86_32]'; then
+ ewarn "media-libs/mesa seems to be in use but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ fi
fi
optfeature "/dev/hidraw* access used for *some* controllers (e.g. DualShock4)" \
diff --git a/app-emulation/wine-vanilla/wine-vanilla-7.0.2.ebuild b/app-emulation/wine-vanilla/wine-vanilla-7.0.2.ebuild
index 262638ea8d31..bb1d6d125649 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-7.0.2.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-7.0.2.ebuild
@@ -367,12 +367,20 @@ src_install() {
}
pkg_postinst() {
- if use abi_x86_32 && { use opengl || use vulkan; } &&
- has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'
- then
- ewarn "x11-drivers/nvidia-drivers is installed but is built without"
- ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
- ewarn "applications under ${PN} will likely not be usable."
+ if use abi_x86_32 && { use opengl || use vulkan; }; then
+ # difficult to tell what is needed from here, but try to warn
+ if has_version 'x11-drivers/nvidia-drivers'; then
+ if has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'; then
+ ewarn "x11-drivers/nvidia-drivers is installed but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ ewarn "Multi-card setups may need this on media-libs/mesa as well."
+ fi
+ elif has_version 'media-libs/mesa[-abi_x86_32]'; then
+ ewarn "media-libs/mesa seems to be in use but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ fi
fi
eselect wine update --if-unset || die
diff --git a/app-emulation/wine-vanilla/wine-vanilla-8.0.2.ebuild b/app-emulation/wine-vanilla/wine-vanilla-8.0.2.ebuild
index 800c33d6ae95..3402577a7c2d 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-8.0.2.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-8.0.2.ebuild
@@ -373,12 +373,20 @@ src_install() {
}
pkg_postinst() {
- if use abi_x86_32 && { use opengl || use vulkan; } &&
- has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'
- then
- ewarn "x11-drivers/nvidia-drivers is installed but is built without"
- ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
- ewarn "applications under ${PN} will likely not be usable."
+ if use abi_x86_32 && { use opengl || use vulkan; }; then
+ # difficult to tell what is needed from here, but try to warn
+ if has_version 'x11-drivers/nvidia-drivers'; then
+ if has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'; then
+ ewarn "x11-drivers/nvidia-drivers is installed but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ ewarn "Multi-card setups may need this on media-libs/mesa as well."
+ fi
+ elif has_version 'media-libs/mesa[-abi_x86_32]'; then
+ ewarn "media-libs/mesa seems to be in use but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ fi
fi
eselect wine update --if-unset || die
diff --git a/app-emulation/wine-vanilla/wine-vanilla-9.0.ebuild b/app-emulation/wine-vanilla/wine-vanilla-9.0.ebuild
index 0c9ff2f4151d..c8cced499644 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-9.0.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-9.0.ebuild
@@ -412,12 +412,20 @@ pkg_postinst() {
ewarn "work, be warned that it is not unusual that installers or other helpers"
ewarn "will attempt to use 32bit and fail. If do not want full USE=abi_x86_32,"
ewarn "note the experimental/WIP USE=wow64 can allow 32bit without multilib."
- elif use abi_x86_32 && { use opengl || use vulkan; } &&
- has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'
- then
- ewarn "x11-drivers/nvidia-drivers is installed but is built without"
- ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
- ewarn "applications under ${PN} will likely not be usable."
+ elif use abi_x86_32 && { use opengl || use vulkan; }; then
+ # difficult to tell what is needed from here, but try to warn
+ if has_version 'x11-drivers/nvidia-drivers'; then
+ if has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'; then
+ ewarn "x11-drivers/nvidia-drivers is installed but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ ewarn "Multi-card setups may need this on media-libs/mesa as well."
+ fi
+ elif has_version 'media-libs/mesa[-abi_x86_32]'; then
+ ewarn "media-libs/mesa seems to be in use but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ fi
fi
eselect wine update --if-unset || die
diff --git a/app-emulation/wine-vanilla/wine-vanilla-9.7.ebuild b/app-emulation/wine-vanilla/wine-vanilla-9.7.ebuild
index 868d1a000777..0f7e43a70482 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-9.7.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-9.7.ebuild
@@ -412,12 +412,20 @@ pkg_postinst() {
ewarn "work, be warned that it is not unusual that installers or other helpers"
ewarn "will attempt to use 32bit and fail. If do not want full USE=abi_x86_32,"
ewarn "note the experimental/WIP USE=wow64 can allow 32bit without multilib."
- elif use abi_x86_32 && { use opengl || use vulkan; } &&
- has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'
- then
- ewarn "x11-drivers/nvidia-drivers is installed but is built without"
- ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
- ewarn "applications under ${PN} will likely not be usable."
+ elif use abi_x86_32 && { use opengl || use vulkan; }; then
+ # difficult to tell what is needed from here, but try to warn
+ if has_version 'x11-drivers/nvidia-drivers'; then
+ if has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'; then
+ ewarn "x11-drivers/nvidia-drivers is installed but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ ewarn "Multi-card setups may need this on media-libs/mesa as well."
+ fi
+ elif has_version 'media-libs/mesa[-abi_x86_32]'; then
+ ewarn "media-libs/mesa seems to be in use but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ fi
fi
optfeature "/dev/hidraw* access used for *some* controllers (e.g. DualShock4)" \
diff --git a/app-emulation/wine-vanilla/wine-vanilla-9.8.ebuild b/app-emulation/wine-vanilla/wine-vanilla-9.8.ebuild
index 9b130d772adf..aae655db4877 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-9.8.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-9.8.ebuild
@@ -413,12 +413,20 @@ pkg_postinst() {
ewarn "work, be warned that it is not unusual that installers or other helpers"
ewarn "will attempt to use 32bit and fail. If do not want full USE=abi_x86_32,"
ewarn "note the experimental/WIP USE=wow64 can allow 32bit without multilib."
- elif use abi_x86_32 && { use opengl || use vulkan; } &&
- has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'
- then
- ewarn "x11-drivers/nvidia-drivers is installed but is built without"
- ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
- ewarn "applications under ${PN} will likely not be usable."
+ elif use abi_x86_32 && { use opengl || use vulkan; }; then
+ # difficult to tell what is needed from here, but try to warn
+ if has_version 'x11-drivers/nvidia-drivers'; then
+ if has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'; then
+ ewarn "x11-drivers/nvidia-drivers is installed but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ ewarn "Multi-card setups may need this on media-libs/mesa as well."
+ fi
+ elif has_version 'media-libs/mesa[-abi_x86_32]'; then
+ ewarn "media-libs/mesa seems to be in use but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ fi
fi
optfeature "/dev/hidraw* access used for *some* controllers (e.g. DualShock4)" \
diff --git a/app-emulation/wine-vanilla/wine-vanilla-9.9.ebuild b/app-emulation/wine-vanilla/wine-vanilla-9.9.ebuild
index 2685dfbc9d27..ea264050fc99 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-9.9.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-9.9.ebuild
@@ -412,12 +412,20 @@ pkg_postinst() {
ewarn "work, be warned that it is not unusual that installers or other helpers"
ewarn "will attempt to use 32bit and fail. If do not want full USE=abi_x86_32,"
ewarn "note the experimental/WIP USE=wow64 can allow 32bit without multilib."
- elif use abi_x86_32 && { use opengl || use vulkan; } &&
- has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'
- then
- ewarn "x11-drivers/nvidia-drivers is installed but is built without"
- ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
- ewarn "applications under ${PN} will likely not be usable."
+ elif use abi_x86_32 && { use opengl || use vulkan; }; then
+ # difficult to tell what is needed from here, but try to warn
+ if has_version 'x11-drivers/nvidia-drivers'; then
+ if has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'; then
+ ewarn "x11-drivers/nvidia-drivers is installed but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ ewarn "Multi-card setups may need this on media-libs/mesa as well."
+ fi
+ elif has_version 'media-libs/mesa[-abi_x86_32]'; then
+ ewarn "media-libs/mesa seems to be in use but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ fi
fi
optfeature "/dev/hidraw* access used for *some* controllers (e.g. DualShock4)" \
diff --git a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
index 2685dfbc9d27..ea264050fc99 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
@@ -412,12 +412,20 @@ pkg_postinst() {
ewarn "work, be warned that it is not unusual that installers or other helpers"
ewarn "will attempt to use 32bit and fail. If do not want full USE=abi_x86_32,"
ewarn "note the experimental/WIP USE=wow64 can allow 32bit without multilib."
- elif use abi_x86_32 && { use opengl || use vulkan; } &&
- has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'
- then
- ewarn "x11-drivers/nvidia-drivers is installed but is built without"
- ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
- ewarn "applications under ${PN} will likely not be usable."
+ elif use abi_x86_32 && { use opengl || use vulkan; }; then
+ # difficult to tell what is needed from here, but try to warn
+ if has_version 'x11-drivers/nvidia-drivers'; then
+ if has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'; then
+ ewarn "x11-drivers/nvidia-drivers is installed but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ ewarn "Multi-card setups may need this on media-libs/mesa as well."
+ fi
+ elif has_version 'media-libs/mesa[-abi_x86_32]'; then
+ ewarn "media-libs/mesa seems to be in use but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ fi
fi
optfeature "/dev/hidraw* access used for *some* controllers (e.g. DualShock4)" \
diff --git a/app-office/unoconv/unoconv-0.9.0-r1.ebuild b/app-office/unoconv/unoconv-0.9.0-r1.ebuild
index 93082339a752..7f1ff329db0d 100644
--- a/app-office/unoconv/unoconv-0.9.0-r1.ebuild
+++ b/app-office/unoconv/unoconv-0.9.0-r1.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9,10} )
-inherit python-single-r1
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python3_{9..12} )
+inherit distutils-r1
DESCRIPTION="Convert between document formats supported by LibreOffice"
HOMEPAGE="http://dag.wiee.rs/home-made/unoconv/"
diff --git a/dev-ruby/parser/Manifest b/dev-ruby/parser/Manifest
index 7ed44703a914..96f140832899 100644
--- a/dev-ruby/parser/Manifest
+++ b/dev-ruby/parser/Manifest
@@ -1,5 +1,3 @@
-DIST parser-3.2.2.4.tar.gz 315784 BLAKE2B 4dadbc75ef6f3b7598d7e51222bac37cdbcb0ef2c9d156f910080d2f1a77ec568d34f57198f54e261ffc97faf0fffcd0d9f84f0710e1fbb31ac680cf08764608 SHA512 dc755f4acf9bdbe9312e622eaae96e44efd5a4db5e9cb31cc93ca225b5e8f8cb7f9bb408225ceeaa63d543a9f47e89aba00d1b1353a558ab53219f4611d19955
-DIST parser-3.3.0.3.tar.gz 318017 BLAKE2B 3322de46055839d6be751914c4d1cf020ed6a62795432427aac2c267df2a46af5e970e757ee4d7d357660d65fc14fbc143239f33a6f83905f9457c5eda523e13 SHA512 8248009f285b727b029596c931f067b14e5e5811c940dbdce41155ea2489c0a348a4f4a425cc0af7c1bcea5fafbdfa48fd97ef448be3092a879abfcfd2c2438c
-DIST parser-3.3.0.4.tar.gz 329872 BLAKE2B 966c5fc12b2b4ba9fa94b93d2f9b0fd1f18d1f1f5d2fe80299099f04dc28874e0b9a1235bdd2ccc5e2bbb5b4033529a24721337cba9bedf23843109adf19f928 SHA512 c3ffca4978b3f156663a3cac72c9629107a92e2a40dd2dbdea4d14a72d9b48af832b33fad0bc81707f0c8e49e14ac9e3f832c02d94c424db17aee9009fb79386
DIST parser-3.3.0.5.tar.gz 329827 BLAKE2B 6e7872134d6591a378192d12424a9314a3fe580c187db8e1adcf75a377acd4dd12389222d25a044b8fc22df4c3a251796bb8bf073a1ac6f6130f5709c25ef9f4 SHA512 ef6c9eed9ffc42e1cbee662bc1305bd2ce28ba8e7a06d3c77ecdb07fb6244ea65d2b402bd2cd7cf49af3336976e81d288caf0e1da144d837e36b25dc406ee81d
DIST parser-3.3.1.0.tar.gz 330897 BLAKE2B 343c5c6894a76d77a581e9329945f180671ccea5aae0224a24da094a47b84d1997ef997d1d9a42acf522950f2101c8fa89a624c94ccb9fad281ae91c55854892 SHA512 6c25b65c2b291e303c9f6085c2bfcda61e91c280dc3c835f42983ac04e6df5410562382f2e18aa837e03c0ffcf61c686d0503544afed9f9ad258cd1fe3421808
+DIST parser-3.3.2.0.tar.gz 330935 BLAKE2B af75234f18450dec61a7c673eb1e5a958ea9edc38f2e64b6ce94c925f910d91053a885e8af9d085bd0a387d7f809e72038316dedbd50ef3819a1bfcfcb790ecf SHA512 a756eec657aa810e005ba24eebbf7674940237178bdd26d6163c807be5133c275557f3b072579546b14c2f10f65e155defe8c6d0a625affe9dea931e20a23c33
diff --git a/dev-ruby/parser/parser-3.2.2.4.ebuild b/dev-ruby/parser/parser-3.2.2.4.ebuild
deleted file mode 100644
index ae52a5886cef..000000000000
--- a/dev-ruby/parser/parser-3.2.2.4.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby31 ruby32"
-
-RUBY_FAKEGEM_RECIPE_DOC="yard"
-RUBY_FAKEGEM_TASK_TEST="test"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_VERSION="${PV/_pre/.pre.}"
-
-RUBY_FAKEGEM_GEMSPEC="parser.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A production-ready Ruby parser written in pure Ruby"
-HOMEPAGE="https://github.com/whitequark/parser"
-SRC_URI="https://github.com/whitequark/parser/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~sparc"
-IUSE=""
-
-DEPEND+=" =dev-util/ragel-6*"
-
-ruby_add_bdepend "
- test? ( dev-ruby/minitest:5 )
- dev-ruby/cliver
-"
-ruby_add_rdepend "=dev-ruby/ast-2.4* >=dev-ruby/ast-2.4.1 dev-ruby/racc"
-
-all_ruby_prepare() {
- sed -i -e "/[Bb]undler/d" Rakefile || die
- sed -i -e '/simplecov/ s:^:#:' test/helper.rb || die
-}
-
-each_ruby_compile() {
- ${RUBY} -S rake generate || die
-}
diff --git a/dev-ruby/parser/parser-3.3.0.4.ebuild b/dev-ruby/parser/parser-3.3.0.4.ebuild
deleted file mode 100644
index 48b258f91620..000000000000
--- a/dev-ruby/parser/parser-3.3.0.4.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby31 ruby32"
-
-RUBY_FAKEGEM_RECIPE_DOC="yard"
-RUBY_FAKEGEM_TASK_TEST="test"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_VERSION="${PV/_pre/.pre.}"
-
-RUBY_FAKEGEM_GEMSPEC="parser.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A production-ready Ruby parser written in pure Ruby"
-HOMEPAGE="https://github.com/whitequark/parser"
-SRC_URI="https://github.com/whitequark/parser/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~sparc"
-
-DEPEND+=" =dev-util/ragel-6*"
-
-ruby_add_bdepend "
- test? ( dev-ruby/minitest:5 )
- dev-ruby/cliver
-"
-ruby_add_rdepend "=dev-ruby/ast-2.4* >=dev-ruby/ast-2.4.1 dev-ruby/racc"
-
-all_ruby_prepare() {
- sed -i -e "/[Bb]undler/d" Rakefile || die
- sed -i -e '/simplecov/ s:^:#:' test/helper.rb || die
-}
-
-each_ruby_compile() {
- ${RUBY} -S rake generate || die
-}
diff --git a/dev-ruby/parser/parser-3.3.0.3.ebuild b/dev-ruby/parser/parser-3.3.2.0.ebuild
index 48b258f91620..0d50425d80a7 100644
--- a/dev-ruby/parser/parser-3.3.0.3.ebuild
+++ b/dev-ruby/parser/parser-3.3.2.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby31 ruby32"
+USE_RUBY="ruby31 ruby32 ruby33"
RUBY_FAKEGEM_RECIPE_DOC="yard"
RUBY_FAKEGEM_TASK_TEST="test"
diff --git a/dev-ruby/test-unit-ruby-core/Manifest b/dev-ruby/test-unit-ruby-core/Manifest
index 1375d5797a0d..5e73e4f90778 100644
--- a/dev-ruby/test-unit-ruby-core/Manifest
+++ b/dev-ruby/test-unit-ruby-core/Manifest
@@ -1 +1,2 @@
DIST test-unit-ruby-core-1.0.5.gem 15872 BLAKE2B a6f20b5696ad61affc8f508eac804d2816910754a4a6f99105bf7b04bedcac6c3931fc83eb0e77497b94610f31c8242c312e66463d2ebe637596c6ac0db099be SHA512 0fe157b49be30788c14c77e5676065ca3e1150f95b1ea4c0f68552ed331127263c996798ca82bb02e1d0d6afe2de9bc186da4cb89fdc922284d17ab77fe623ed
+DIST test-unit-ruby-core-1.0.6.gem 16384 BLAKE2B f2da08854a09a570bb42b0793e4acbe85b061d11b5bb7b3360caa0feeaedc9e7a04f1b1746401082bf6fe63d8dfe49c993365649de75f4cf2241e5274c3dfa0c SHA512 0fdf7cd9d3154c4c708ff3936bc8200cc3ba3cc169c9dee068634382874615a47f4f866e4f22914bb741f6c00b0401c1911b7758283863787ac1a6c43a96f17e
diff --git a/dev-ruby/test-unit-ruby-core/test-unit-ruby-core-1.0.6.ebuild b/dev-ruby/test-unit-ruby-core/test-unit-ruby-core-1.0.6.ebuild
new file mode 100644
index 000000000000..4d7032c885e2
--- /dev/null
+++ b/dev-ruby/test-unit-ruby-core/test-unit-ruby-core-1.0.6.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Additional test assertions for Ruby standard libraries"
+HOMEPAGE="https://github.com/ruby/test-unit-ruby-core"
+
+LICENSE="|| ( Ruby-BSD BSD-2 ) PSF-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"