summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/slic3r/files/slic3r-1.2.9-c++11.patch38
-rw-r--r--media-gfx/slic3r/slic3r-1.2.9-r2.ebuild3
2 files changed, 40 insertions, 1 deletions
diff --git a/media-gfx/slic3r/files/slic3r-1.2.9-c++11.patch b/media-gfx/slic3r/files/slic3r-1.2.9-c++11.patch
new file mode 100644
index 000000000000..f6b15d70a1ab
--- /dev/null
+++ b/media-gfx/slic3r/files/slic3r-1.2.9-c++11.patch
@@ -0,0 +1,38 @@
+--- a/xs/src/libslic3r/Config.hpp 2015-06-17 04:38:28.000000000 -0400
++++ b/xs/src/libslic3r/Config.hpp 2017-09-27 10:59:26.527103728 -0400
+@@ -65,7 +65,7 @@
+
+ bool deserialize(std::string str) {
+ std::istringstream iss(str);
+- return iss >> this->value;
++ return static_cast<bool>(iss >> this->value);
+ };
+ };
+
+@@ -124,7 +124,7 @@
+
+ bool deserialize(std::string str) {
+ std::istringstream iss(str);
+- return iss >> this->value;
++ return static_cast<bool>(iss >> this->value);
+ };
+ };
+
+@@ -249,7 +249,7 @@
+ bool deserialize(std::string str) {
+ // don't try to parse the trailing % since it's optional
+ std::istringstream iss(str);
+- return iss >> this->value;
++ return static_cast<bool>(iss >> this->value);
+ };
+ };
+
+@@ -279,7 +279,7 @@
+ bool deserialize(std::string str) {
+ this->percent = str.find_first_of("%") != std::string::npos;
+ std::istringstream iss(str);
+- return iss >> this->value;
++ return static_cast<bool>(iss >> this->value);
+ };
+ };
+
diff --git a/media-gfx/slic3r/slic3r-1.2.9-r2.ebuild b/media-gfx/slic3r/slic3r-1.2.9-r2.ebuild
index 541c5bbd7b31..21f227284727 100644
--- a/media-gfx/slic3r/slic3r-1.2.9-r2.ebuild
+++ b/media-gfx/slic3r/slic3r-1.2.9-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -64,6 +64,7 @@ S="${WORKDIR}/Slic3r-${PV}/xs"
src_prepare() {
pushd "${WORKDIR}/Slic3r-${PV}" || die
eapply "${FILESDIR}/${P}-adjust_var_path.patch"
+ eapply "${FILESDIR}/${P}-c++11.patch"
eapply_user
popd || die
}