summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/dropbox-cli/Manifest1
-rw-r--r--net-misc/dropbox-cli/dropbox-cli-2020.03.04.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/net-misc/dropbox-cli/Manifest b/net-misc/dropbox-cli/Manifest
index 5693d547f8a2..68fd320ef496 100644
--- a/net-misc/dropbox-cli/Manifest
+++ b/net-misc/dropbox-cli/Manifest
@@ -1 +1,2 @@
DIST dropbox-cli-19.py.xz 13960 BLAKE2B 16d33155cbe5449434ff9fc5a9fddca9a7cd20bd3ff8fc46f4badcc30d71f6b0b6adde6f6d0ad73702e4dd2957cc00f88f49b2580c289525784f97d4502e008d SHA512 b5ea1632c135232f4705a0e95419d176638e6a830a2a7d32f955c615328097b987887513cf06103b452a7efe2690ffe351a275267451db9d2998d19ac6f8f85f
+DIST dropbox-cli-2020.03.04.py.xz 14304 BLAKE2B 600378cbacd6e96c16e1c8464261b260f2d8919ef5f361c4f337386d3849294cf8557d44f1c5d4f5682eadb2f15885a16b0a8fa162929665e518801d23ec35cc SHA512 c6c8f2f3fb08818388f5ac812821a1530214ad18d58191b08092852aa953e2947871145b46a4df4debeb629a870e1182a47fd5a8bdf8b22144e686e19ede689a
diff --git a/net-misc/dropbox-cli/dropbox-cli-2020.03.04.ebuild b/net-misc/dropbox-cli/dropbox-cli-2020.03.04.ebuild
new file mode 100644
index 000000000000..e9487c000349
--- /dev/null
+++ b/net-misc/dropbox-cli/dropbox-cli-2020.03.04.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit python-r1 bash-completion-r1
+
+DESCRIPTION="Cli interface for dropbox (python), part of nautilus-dropbox"
+HOMEPAGE="https://www.dropbox.com/"
+SRC_URI="https://dev.gentoo.org/~grozin/${P}.py.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="net-misc/dropbox
+ ${PYTHON_DEPS}
+ dev-python/pygpgme[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}
+
+src_install() {
+ newbin ${P}.py ${PN}
+ python_replicate_script "${D}"/usr/bin/${PN}
+ newbashcomp "${FILESDIR}"/${P}-completion ${PN}
+}