summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/mcelog/Manifest1
-rw-r--r--app-admin/mcelog/mcelog-172.ebuild58
-rw-r--r--dev-java/rxtx/files/rxtx-2.1-7r2-lfd.diff14
-rw-r--r--dev-java/rxtx/files/rxtx-2.1-7r2-nouts.diff90
-rw-r--r--eclass/multilib-build.eclass18
-rw-r--r--net-wireless/unifi/Manifest1
-rw-r--r--net-wireless/unifi/unifi-6.0.23.ebuild68
-rw-r--r--profiles/arch/base/use.mask4
-rw-r--r--profiles/arch/riscv/packages3
-rw-r--r--profiles/arch/riscv/rv32imac/ilp32/make.defaults3
-rw-r--r--profiles/arch/riscv/rv32imac/ilp32/package.use.force2
-rw-r--r--profiles/arch/riscv/rv32imac/ilp32/use.force7
-rw-r--r--profiles/arch/riscv/rv32imac/ilp32/use.mask5
-rw-r--r--profiles/arch/riscv/rv32imac/ilp32d/make.defaults3
-rw-r--r--profiles/arch/riscv/rv32imac/ilp32d/package.use.force5
-rw-r--r--profiles/arch/riscv/rv32imac/ilp32d/use.mask7
-rw-r--r--profiles/arch/riscv/rv32imac/make.defaults9
-rw-r--r--profiles/arch/riscv/rv32imac/use.force5
-rw-r--r--profiles/arch/riscv/rv32imac/use.mask6
-rw-r--r--profiles/arch/riscv/rv64gc/lp64/make.defaults3
-rw-r--r--profiles/arch/riscv/rv64gc/lp64/package.use.force5
-rw-r--r--profiles/arch/riscv/rv64gc/lp64/use.force7
-rw-r--r--profiles/arch/riscv/rv64gc/lp64/use.mask7
-rw-r--r--profiles/arch/riscv/rv64gc/lp64d/make.defaults3
-rw-r--r--profiles/arch/riscv/rv64gc/lp64d/package.use.force5
-rw-r--r--profiles/arch/riscv/rv64gc/lp64d/use.mask5
-rw-r--r--profiles/arch/riscv/rv64gc/make.defaults9
-rw-r--r--profiles/arch/riscv/rv64gc/use.force5
-rw-r--r--profiles/arch/riscv/rv64gc/use.mask8
-rw-r--r--profiles/base/make.defaults4
-rw-r--r--profiles/desc/abi_riscv.desc11
-rw-r--r--profiles/embedded/make.defaults4
-rw-r--r--profiles/features/multilib/package.use2
33 files changed, 250 insertions, 137 deletions
diff --git a/app-admin/mcelog/Manifest b/app-admin/mcelog/Manifest
index c3b01525159e..73f1a4893ad7 100644
--- a/app-admin/mcelog/Manifest
+++ b/app-admin/mcelog/Manifest
@@ -1 +1,2 @@
DIST mcelog-170.tar.gz 312911 BLAKE2B bab27c60fca937442a0f07929eaedd392c3e8de3e5f705f717d787652b6c0fa91e42169b835ea2527729c487773c7baabfceeebd3fd58d64a853ff17d8fdd8a8 SHA512 f5d29bde88cd3925c0e629850adce7f1040ecc4703c45427424f5d56f28a0add1fb24538e5c4e0749743c92479d3ea6da583c23bb41eb6a8d899626d818cb6a4
+DIST mcelog-172.tar.gz 313103 BLAKE2B f3acf5a5ebd1db92f7cddfa0e8a848bd6fbd361932ae52400c26f5aeaf7727f6dfd278ab7c1282229d9208474add124401a4665a4febe0debffad7818bcf6223 SHA512 adfde12b9f6f21ec6276c55d3554a3cdbf156e44df2f85c28d9d608418fa57b3f4a0bfcbacd13e92b77eddc1efdaeacfe3c89d203b8cbd3757f35fe419806547
diff --git a/app-admin/mcelog/mcelog-172.ebuild b/app-admin/mcelog/mcelog-172.ebuild
new file mode 100644
index 000000000000..e0b67a2d755e
--- /dev/null
+++ b/app-admin/mcelog/mcelog-172.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info systemd toolchain-funcs
+
+DESCRIPTION="A tool to log and decode Machine Check Exceptions"
+HOMEPAGE="http://mcelog.org/"
+SRC_URI="https://github.com/andikleen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-mcelog )"
+
+# TODO: add mce-inject to the tree to support test phase
+RESTRICT="test"
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != buildonly ]]; then
+ local CONFIG_CHECK="~X86_MCE"
+ kernel_is -ge 4 12 && CONFIG_CHECK+=" ~X86_MCELOG_LEGACY"
+ check_extra_config
+ fi
+}
+
+src_prepare() {
+ eapply "${FILESDIR}"/${PN}-0.8_pre1-timestamp-${PN}.patch \
+ "${FILESDIR}"/${PN}-129-debugflags.patch
+ eapply_user
+ tc-export CC
+}
+
+src_install() {
+ default
+
+ insinto /etc/cron.daily
+ newins ${PN}.cron ${PN}
+
+ insinto /etc/logrotate.d/
+ newins ${PN}.logrotate ${PN}
+
+ newinitd "${FILESDIR}"/${PN}.init-r1 ${PN}
+ systemd_dounit "${FILESDIR}"/${PN}.service
+
+ dodoc *.pdf
+}
+
+pkg_postinst() {
+ einfo "The default configuration set is now installed in /etc/${PN}"
+ einfo "you might want to edit those files."
+ einfo
+ einfo "A sample cronjob is installed into /etc/cron.daily"
+ einfo "without executable bit (system service is the preferred method now)"
+}
diff --git a/dev-java/rxtx/files/rxtx-2.1-7r2-lfd.diff b/dev-java/rxtx/files/rxtx-2.1-7r2-lfd.diff
new file mode 100644
index 000000000000..496d732ae2fa
--- /dev/null
+++ b/dev-java/rxtx/files/rxtx-2.1-7r2-lfd.diff
@@ -0,0 +1,14 @@
+--- src/lfd/lockdaemon.c.orig 2004-10-12 10:59:28.000000000 +0200
++++ src/lfd/lockdaemon.c 2006-10-29 22:46:58.000000000 +0100
+@@ -248,9 +248,8 @@
+
+ if ( check_group_uucp() )
+ {
+- syslog( LOG_INFO, "check_lock_status: No permission to create lock file.
+-
+- please see: How can I use Lock Files with rxtx? in INSTALL\n" );
++ syslog( LOG_INFO, "check_lock_status: No permission to create lock file.\n\n"
++ "please see: How can I use Lock Files with rxtx? in INSTALL\n" );
+ return 1;
+ }
+
diff --git a/dev-java/rxtx/files/rxtx-2.1-7r2-nouts.diff b/dev-java/rxtx/files/rxtx-2.1-7r2-nouts.diff
new file mode 100644
index 000000000000..fb05955c65f1
--- /dev/null
+++ b/dev-java/rxtx/files/rxtx-2.1-7r2-nouts.diff
@@ -0,0 +1,90 @@
+--- src/I2CImp.c.orig 2004-10-17 16:23:02.000000000 +0200
++++ src/I2CImp.c 2006-10-26 21:25:32.000000000 +0200
+@@ -87,6 +87,7 @@
+ if( !handler.sa_handler ) signal( SIGIO, SIG_IGN );
+ #endif /* !__FreeBSD__ */
+ #if defined(__linux__)
++#if 0
+ /* Lets let people who upgraded kernels know they may have problems */
+ if (uname (&name) == -1)
+ {
+@@ -98,6 +99,7 @@
+ fprintf(stderr, "\n\n\nRXTX WARNING: This library was compiled to run with OS release %s and you are currently running OS release %s. In some cases this can be a problem. Try recompiling RXTX if you notice strange behavior. If you just compiled RXTX make sure /usr/include/linux is a symbolic link to the include files that came with the kernel source and not an older copy.\n\n\npress enter to continue\n",UTS_RELEASE,name.release);
+ getchar();
+ }
++#endif
+ #endif /* __linux__ */
+ #endif /* WIN32 */
+ }
+--- src/RawImp.c.orig 2004-10-16 18:20:35.000000000 +0200
++++ src/RawImp.c 2006-10-26 21:25:59.000000000 +0200
+@@ -231,6 +231,7 @@
+ if( !handler.sa_handler ) signal( SIGIO, SIG_IGN );
+ #endif /* !__FreeBSD__ */
+ #if defined(__linux__)
++#if 0
+ /* Lets let people who upgraded kernels know they may have problems */
+ if (uname (&name) == -1)
+ {
+@@ -242,6 +243,7 @@
+ fprintf(stderr, "\n\n\nRXTX WARNING: This library was compiled to run with OS release %s and you are currently running OS release %s. In some cases this can be a problem. Try recompiling RXTX if you notice strange behavior. If you just compiled RXTX make sure /usr/include/linux is a symbolic link to the include files that came with the kernel source and not an older copy.\n\n\npress enter to continue\n",UTS_RELEASE,name.release);
+ getchar();
+ }
++#endif
+ #endif /* __linux__ */
+ #endif /* WIN32 */
+ }
+--- src/RS485Imp.c.orig 2004-10-16 18:20:35.000000000 +0200
++++ src/RS485Imp.c 2006-10-26 21:26:23.000000000 +0200
+@@ -87,6 +87,7 @@
+ if( !handler.sa_handler ) signal( SIGIO, SIG_IGN );
+ #endif /* !__FreeBSD__ */
+ #if defined(__linux__)
++#if 0
+ /* Lets let people who upgraded kernels know they may have problems */
+ if (uname (&name) == -1)
+ {
+@@ -98,6 +99,7 @@
+ fprintf(stderr, "\n\n\nRXTX WARNING: This library was compiled to run with OS release %s and you are currently running OS release %s. In some cases this can be a problem. Try recompiling RXTX if you notice strange behavior. If you just compiled RXTX make sure /usr/include/linux is a symbolic link to the include files that came with the kernel source and not an older copy.\n\n\npress enter to continue\n",UTS_RELEASE,name.release);
+ getchar();
+ }
++#endif
+ #endif /* __linux__ */
+ #endif /* WIN32 */
+ }
+--- src/SerialImp.c.orig 2006-01-29 23:19:04.000000000 +0100
++++ src/SerialImp.c 2006-10-26 21:26:59.000000000 +0200
+@@ -280,6 +280,7 @@
+ gettimeofday(&seloop, NULL);
+ #endif /* DEBUG_TIMING */
+ #if defined(DEBUG) && defined(__linux__)
++#if 0
+ /* Lets let people who upgraded kernels know they may have problems */
+ if (uname (&name) == -1)
+ {
+@@ -295,6 +296,7 @@
+ getchar();
+ }
+ LEAVE( "RXTXPort:Initialize" );
++#endif
+ #endif /* DEBUG && __linux__ */
+ }
+
+--- src/SerialImp.cpp.orig 2004-10-12 10:59:27.000000000 +0200
++++ src/SerialImp.cpp 2006-10-26 21:27:44.000000000 +0200
+@@ -102,6 +102,7 @@
+ if( !handler.sa_handler ) signal( SIGIO, SIG_IGN );
+ #endif /* !__FreeBSD__ */
+ #ifdef DEBUG
++#if 0
+ /* Lets let people who upgraded kernels know they may have problems */
+ if (uname (&name) == -1)
+ {
+@@ -114,6 +115,7 @@
+ name.release);
+ getchar();
+ }
++#endif
+ #endif /* DEBUG */
+ #endif /* __BEOS__ */
+ #endif /* WIN32 */
diff --git a/eclass/multilib-build.eclass b/eclass/multilib-build.eclass
index 21ca275c3c77..585364de6273 100644
--- a/eclass/multilib-build.eclass
+++ b/eclass/multilib-build.eclass
@@ -47,10 +47,6 @@ _MULTILIB_FLAGS=(
abi_mips_o32:o32
# abi_ppc_32:ppc,ppc_aix,ppc_macos
# abi_ppc_64:ppc64
- abi_riscv_lp64d:lp64d
- abi_riscv_lp64:lp64
- abi_riscv_ilp32d:ilp32d
- abi_riscv_ilp32:ilp32
abi_s390_32:s390
abi_s390_64:s390x
)
@@ -493,20 +489,6 @@ multilib_prepare_wrappers() {
# elif(_MIPS_SIM == _ABIO32) /* o32 */
# error "abi_mips_o32 not supported by the package."
# endif
-#elif defined(__riscv)
-# if (__riscv_xlen == 64) && defined(__riscv_float_abi_double)
-# error "abi_riscv_lp64d not supported by the package."
-# elif (__riscv_xlen == 64) && defined(__riscv_float_abi_single)
-# error "abi_riscv_lp64f not supported by the package."
-# elif (__riscv_xlen == 64)
-# error "abi_riscv_lp64 not supported by the package."
-# elif (__riscv_xlen == 32) && defined(__riscv_float_abi_double)
-# error "abi_riscv_ilp32d not supported by the package."
-# elif (__riscv_xlen == 32) && defined(__riscv_float_abi_single)
-# error "abi_riscv_ilp32f not supported by the package."
-# else
-# error "abi_riscv_ilp32 not supported by the package."
-# endif
#elif defined(__sparc__)
# if defined(__arch64__)
# error "abi_sparc_64 not supported by the package."
diff --git a/net-wireless/unifi/Manifest b/net-wireless/unifi/Manifest
index 2a263f837a73..e42c54e8f922 100644
--- a/net-wireless/unifi/Manifest
+++ b/net-wireless/unifi/Manifest
@@ -5,3 +5,4 @@ DIST unifi-5.14.23.zip 195394703 BLAKE2B ba762712b958f4a784f281419edcd9f7622a4df
DIST unifi-5.6.42.zip 63581448 BLAKE2B dc12149acc56587043b9f6c45a43327a9a067dda86127c60ad62a4681a0c8ba873435b60183989332f561fb52f71c7207480766ec23d9c0e892cc20c521a9819 SHA512 467c0ad284a84795537484f371867d851e67c7e396215d539a9705f17f374b50db4051121a6634d1944474a2474bdd75fca860ab00b48634a5d3e8749a122989
DIST unifi-6.0.20.zip 182776288 BLAKE2B 3b9aca0a7b356a1bab2e9f6af8da21ee43b7c4f14392292a0f25803395a12ad726ad7db46f4c4863841bf9c3cdc973ae5bfdd9e7dc48974494807e6ba15658b8 SHA512 926f78c3f9b3035e09a8592bd52239665fb379d9324ceae42494a55d01325028dd0d09f0692cd23466216958fe51153f2093f747fadbaf9aabd49c450233aae3
DIST unifi-6.0.22.zip 183238039 BLAKE2B f76b59087922b46ec8db1869b167aeb62b3047e87e4f80de9ed32caa8e1d8210a384dc3ec1f06a59e2aaf740c5247539c215f821290c6c5f5398d05b37fd2fae SHA512 99e510a2c7f13929b436a73b5cb5d8d8ce48cfa4464bc610dd588c2af30cbb0f4b8c0fd8058a2108f2c3f0850f492445f6b1b9c1b6d84bfdb5e2af7cbe261283
+DIST unifi-6.0.23.zip 183386177 BLAKE2B ee0300c9595bab469e63c8c523f75507e5b4ef88e67947df8948abddb149e6522f4851108191f0f91605cc0168fcaa73170a40a9908fd64b49897f5123dc7a37 SHA512 b21be9cf360bfc6e1f2bff073db431a653a7b53f138cd9249873eaadf93777a3eecde87a8ada2db46f2fe69b2eacf747ed13c78045ba12748469dab3d068c881
diff --git a/net-wireless/unifi/unifi-6.0.23.ebuild b/net-wireless/unifi/unifi-6.0.23.ebuild
new file mode 100644
index 000000000000..3b3f7c9e3fc3
--- /dev/null
+++ b/net-wireless/unifi/unifi-6.0.23.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# Set this var for any releases except stable
+RC_SUFFIX="-20b313f50d"
+
+inherit systemd
+
+DESCRIPTION="A Management Controller for Ubiquiti Networks UniFi APs"
+HOMEPAGE="https://www.ubnt.com"
+SRC_URI="https://dl.ui.com/unifi/${PV}${RC_SUFFIX}/UniFi.unix.zip -> ${P}.zip"
+
+KEYWORDS="~amd64"
+LICENSE="Apache-1.0 Apache-2.0 BSD-1 BSD-2 BSD CDDL EPL-1.0 GPL-2 LGPL-2.1 LGPL-3 MIT ubiquiti"
+SLOT="0/6.0"
+IUSE="systemd"
+
+RDEPEND="
+ acct-group/unifi
+ acct-user/unifi
+ dev-db/mongodb
+ virtual/jre:1.8
+"
+
+DEPEND="app-arch/unzip"
+
+RESTRICT="bindist mirror"
+
+S="${WORKDIR}/UniFi"
+
+DOCS=( "readme.txt" )
+
+QA_PREBUILT="usr/lib/unifi/lib/native/Linux/x86_64/*.so"
+
+src_prepare() {
+ # Remove unneeded files Linux, Mac and Windows
+ rm -r lib/native/Linux/{aarch64,armv7} lib/native/{Mac,Windows} || die
+ if ! use systemd; then
+ rm lib/native/Linux/x86_64/libubnt_sdnotify_jni.so || die
+ fi
+
+ default
+}
+
+src_install() {
+ insinto /usr/lib/unifi
+ doins -r bin dl lib webapps
+
+ diropts -o unifi -g unifi
+ keepdir /var/lib/unifi/{conf,data,run,tmp,work} /var/log/unifi
+
+ for symlink in conf data run tmp work; do
+ dosym ../../../var/lib/unifi/${symlink} /usr/lib/unifi/${symlink}
+ done
+ dosym ../../../var/log/unifi /usr/lib/unifi/logs
+
+ newinitd "${FILESDIR}"/unifi.initd-r1 unifi
+ systemd_dounit "${FILESDIR}"/unifi.service
+
+ newconfd "${FILESDIR}"/unifi.confd unifi
+
+ echo 'CONFIG_PROTECT="/var/lib/unifi"' > "${T}"/99unifi || die
+ doenvd "${T}"/99unifi
+
+ einstalldocs
+}
diff --git a/profiles/arch/base/use.mask b/profiles/arch/base/use.mask
index 1287a5f40973..366da76c51fb 100644
--- a/profiles/arch/base/use.mask
+++ b/profiles/arch/base/use.mask
@@ -195,10 +195,6 @@ abi_mips_n32
abi_mips_n64
abi_ppc_32
abi_ppc_64
-abi_riscv_lp64d
-abi_riscv_lp64
-abi_riscv_ilp32d
-abi_riscv_ilp32
abi_s390_32
abi_s390_64
diff --git a/profiles/arch/riscv/packages b/profiles/arch/riscv/packages
index b089d412189e..9de5ab734497 100644
--- a/profiles/arch/riscv/packages
+++ b/profiles/arch/riscv/packages
@@ -1,5 +1,2 @@
# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-
-# For the initial hot experimentation phase...
-*sys-devel/gdb
diff --git a/profiles/arch/riscv/rv32imac/ilp32/make.defaults b/profiles/arch/riscv/rv32imac/ilp32/make.defaults
index 959de434af0f..1065af43c9a8 100644
--- a/profiles/arch/riscv/rv32imac/ilp32/make.defaults
+++ b/profiles/arch/riscv/rv32imac/ilp32/make.defaults
@@ -7,6 +7,3 @@
MULTILIB_ABIS="ilp32"
DEFAULT_ABI="ilp32"
ABI="ilp32"
-
-# We hide the useflags for the ABIs
-USE_EXPAND_HIDDEN="ABI_RISCV"
diff --git a/profiles/arch/riscv/rv32imac/ilp32/package.use.force b/profiles/arch/riscv/rv32imac/ilp32/package.use.force
index dc5b60c2dd26..aacc29b1d56e 100644
--- a/profiles/arch/riscv/rv32imac/ilp32/package.use.force
+++ b/profiles/arch/riscv/rv32imac/ilp32/package.use.force
@@ -1,5 +1,3 @@
# Copyright 2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# Undo multilib forcing.
-sys-apps/sandbox -abi_riscv_lp64d -abi_riscv_lp64 -abi_riscv_ilp32d
diff --git a/profiles/arch/riscv/rv32imac/ilp32/use.force b/profiles/arch/riscv/rv32imac/ilp32/use.force
index e54ac40ffd20..82bb958a577a 100644
--- a/profiles/arch/riscv/rv32imac/ilp32/use.force
+++ b/profiles/arch/riscv/rv32imac/ilp32/use.force
@@ -1,5 +1,2 @@
-# Un-force the original multilib default-abi flag
--abi_riscv_ilp32d
-
-# Force the abi of this profile here
-abi_riscv_ilp32
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
diff --git a/profiles/arch/riscv/rv32imac/ilp32/use.mask b/profiles/arch/riscv/rv32imac/ilp32/use.mask
index c717be8a4aa4..991c792750ad 100644
--- a/profiles/arch/riscv/rv32imac/ilp32/use.mask
+++ b/profiles/arch/riscv/rv32imac/ilp32/use.mask
@@ -3,8 +3,3 @@
# Mask multilib, since we do not want to use it.
multilib
-
-# Mask the other multilib flags back for non-multilib profile.
-abi_riscv_lp64d
-abi_riscv_lp64
-abi_riscv_ilp32d
diff --git a/profiles/arch/riscv/rv32imac/ilp32d/make.defaults b/profiles/arch/riscv/rv32imac/ilp32d/make.defaults
index bd66a518eab8..a53334741ede 100644
--- a/profiles/arch/riscv/rv32imac/ilp32d/make.defaults
+++ b/profiles/arch/riscv/rv32imac/ilp32d/make.defaults
@@ -10,6 +10,3 @@ FCFLAGS="${CFLAGS}"
# We have only one ABI
MULTILIB_ABIS="ilp32d"
-
-# We hide the useflags for the ABIs
-USE_EXPAND_HIDDEN="ABI_RISCV"
diff --git a/profiles/arch/riscv/rv32imac/ilp32d/package.use.force b/profiles/arch/riscv/rv32imac/ilp32d/package.use.force
index cf764cd54132..9de5ab734497 100644
--- a/profiles/arch/riscv/rv32imac/ilp32d/package.use.force
+++ b/profiles/arch/riscv/rv32imac/ilp32d/package.use.force
@@ -1,5 +1,2 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-
-# Undo multilib forcing.
-sys-apps/sandbox -abi_riscv_lp64d -abi_riscv_lp64 -abi_riscv_ilp32
diff --git a/profiles/arch/riscv/rv32imac/ilp32d/use.mask b/profiles/arch/riscv/rv32imac/ilp32d/use.mask
index b2c900da5041..d8172baa5f5f 100644
--- a/profiles/arch/riscv/rv32imac/ilp32d/use.mask
+++ b/profiles/arch/riscv/rv32imac/ilp32d/use.mask
@@ -1,10 +1,5 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# Mask multilib, since we do not want to use it.
multilib
-
-# Mask the other multilib flags back for non-multilib profile.
-abi_riscv_lp64d
-abi_riscv_lp64
-abi_riscv_ilp32
diff --git a/profiles/arch/riscv/rv32imac/make.defaults b/profiles/arch/riscv/rv32imac/make.defaults
index e23fe63fb251..da381b453f83 100644
--- a/profiles/arch/riscv/rv32imac/make.defaults
+++ b/profiles/arch/riscv/rv32imac/make.defaults
@@ -12,12 +12,3 @@ CHOST="riscv32-unknown-linux-gnu"
MULTILIB_ABIS="ilp32d ilp32"
DEFAULT_ABI="ilp32d"
ABI="ilp32d"
-
-# Enable ilp32d by default
-ABI_RISCV="ilp32d"
-
-# Unhide the riscv/riscv-specific USE_EXPANDs
-USE_EXPAND_HIDDEN="-ABI_RISCV"
-
-# Implicitly enable ilp32d in ebuilds without multilib support
-IUSE_IMPLICIT="abi_riscv_ilp32d"
diff --git a/profiles/arch/riscv/rv32imac/use.force b/profiles/arch/riscv/rv32imac/use.force
index 069813e17719..9de5ab734497 100644
--- a/profiles/arch/riscv/rv32imac/use.force
+++ b/profiles/arch/riscv/rv32imac/use.force
@@ -1,5 +1,2 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-
-# Force the flag corresponding to the default ABI.
-abi_riscv_ilp32d
diff --git a/profiles/arch/riscv/rv32imac/use.mask b/profiles/arch/riscv/rv32imac/use.mask
index d57df4d6abeb..9de5ab734497 100644
--- a/profiles/arch/riscv/rv32imac/use.mask
+++ b/profiles/arch/riscv/rv32imac/use.mask
@@ -1,6 +1,2 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-
-# Unmask the multilib flags for this arch.
--abi_riscv_ilp32d
--abi_riscv_ilp32
diff --git a/profiles/arch/riscv/rv64gc/lp64/make.defaults b/profiles/arch/riscv/rv64gc/lp64/make.defaults
index f4b3042683c5..4aeb573215d2 100644
--- a/profiles/arch/riscv/rv64gc/lp64/make.defaults
+++ b/profiles/arch/riscv/rv64gc/lp64/make.defaults
@@ -12,6 +12,3 @@ FCFLAGS="${CFLAGS}"
MULTILIB_ABIS="lp64"
DEFAULT_ABI="lp64"
ABI="lp64"
-
-# We hide the useflags for the ABIs
-USE_EXPAND_HIDDEN="ABI_RISCV"
diff --git a/profiles/arch/riscv/rv64gc/lp64/package.use.force b/profiles/arch/riscv/rv64gc/lp64/package.use.force
index e25bb13182b5..9de5ab734497 100644
--- a/profiles/arch/riscv/rv64gc/lp64/package.use.force
+++ b/profiles/arch/riscv/rv64gc/lp64/package.use.force
@@ -1,5 +1,2 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-
-# Undo multilib forcing.
-sys-apps/sandbox -abi_riscv_lp64d
diff --git a/profiles/arch/riscv/rv64gc/lp64/use.force b/profiles/arch/riscv/rv64gc/lp64/use.force
index d04bb8b3d835..9de5ab734497 100644
--- a/profiles/arch/riscv/rv64gc/lp64/use.force
+++ b/profiles/arch/riscv/rv64gc/lp64/use.force
@@ -1,5 +1,2 @@
-# Un-force the original multilib default-abi flag
--abi_riscv_lp64d
-
-# Force the abi of this profile here
-abi_riscv_lp64
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
diff --git a/profiles/arch/riscv/rv64gc/lp64/use.mask b/profiles/arch/riscv/rv64gc/lp64/use.mask
index 1e0176b85cb0..d8172baa5f5f 100644
--- a/profiles/arch/riscv/rv64gc/lp64/use.mask
+++ b/profiles/arch/riscv/rv64gc/lp64/use.mask
@@ -1,10 +1,5 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# Mask multilib, since we do not want to use it.
multilib
-
-# Mask the other multilib flags back for non-multilib profile.
-abi_riscv_lp64d
-abi_riscv_ilp32d
-abi_riscv_ilp32
diff --git a/profiles/arch/riscv/rv64gc/lp64d/make.defaults b/profiles/arch/riscv/rv64gc/lp64d/make.defaults
index 85372ab59289..f595f6ac4437 100644
--- a/profiles/arch/riscv/rv64gc/lp64d/make.defaults
+++ b/profiles/arch/riscv/rv64gc/lp64d/make.defaults
@@ -10,6 +10,3 @@ FCFLAGS="${CFLAGS}"
# We have only one ABI
MULTILIB_ABIS="lp64d"
-
-# We hide the useflags for the ABIs
-USE_EXPAND_HIDDEN="ABI_RISCV"
diff --git a/profiles/arch/riscv/rv64gc/lp64d/package.use.force b/profiles/arch/riscv/rv64gc/lp64d/package.use.force
index 73fe93666cc9..9de5ab734497 100644
--- a/profiles/arch/riscv/rv64gc/lp64d/package.use.force
+++ b/profiles/arch/riscv/rv64gc/lp64d/package.use.force
@@ -1,5 +1,2 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-
-# Undo multilib forcing.
-sys-apps/sandbox -abi_riscv_lp64
diff --git a/profiles/arch/riscv/rv64gc/lp64d/use.mask b/profiles/arch/riscv/rv64gc/lp64d/use.mask
index 101528080621..991c792750ad 100644
--- a/profiles/arch/riscv/rv64gc/lp64d/use.mask
+++ b/profiles/arch/riscv/rv64gc/lp64d/use.mask
@@ -3,8 +3,3 @@
# Mask multilib, since we do not want to use it.
multilib
-
-# Mask the other multilib flags back for non-multilib profile.
-abi_riscv_lp64
-abi_riscv_ilp32d
-abi_riscv_ilp32
diff --git a/profiles/arch/riscv/rv64gc/make.defaults b/profiles/arch/riscv/rv64gc/make.defaults
index a5963cb2fcba..e35f63c8d1e1 100644
--- a/profiles/arch/riscv/rv64gc/make.defaults
+++ b/profiles/arch/riscv/rv64gc/make.defaults
@@ -12,12 +12,3 @@ CHOST="riscv64-unknown-linux-gnu"
MULTILIB_ABIS="lp64d lp64 ilp32d ilp32"
DEFAULT_ABI="lp64d"
ABI="lp64d"
-
-# Enable lp64d by default
-ABI_RISCV="lp64d"
-
-# Unhide the riscv/rv64gc-specific USE_EXPANDs
-USE_EXPAND_HIDDEN="-ABI_RISCV"
-
-# Implicitly enable lp64d in ebuilds without multilib support
-IUSE_IMPLICIT="abi_riscv_lp64d"
diff --git a/profiles/arch/riscv/rv64gc/use.force b/profiles/arch/riscv/rv64gc/use.force
index eb2add7ba6b7..9de5ab734497 100644
--- a/profiles/arch/riscv/rv64gc/use.force
+++ b/profiles/arch/riscv/rv64gc/use.force
@@ -1,5 +1,2 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-
-# Force the flag corresponding to the default ABI.
-abi_riscv_lp64d
diff --git a/profiles/arch/riscv/rv64gc/use.mask b/profiles/arch/riscv/rv64gc/use.mask
index b38fe8be382f..9de5ab734497 100644
--- a/profiles/arch/riscv/rv64gc/use.mask
+++ b/profiles/arch/riscv/rv64gc/use.mask
@@ -1,8 +1,2 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-
-# Unmask the multilib flags for this arch.
--abi_riscv_lp64d
--abi_riscv_lp64
--abi_riscv_ilp32d
--abi_riscv_ilp32
diff --git a/profiles/base/make.defaults b/profiles/base/make.defaults
index f2b15dd9a7eb..b3d8b951d41c 100644
--- a/profiles/base/make.defaults
+++ b/profiles/base/make.defaults
@@ -13,11 +13,11 @@ USE_EXPAND_VALUES_USERLAND="BSD GNU"
# Env vars to expand into USE vars. Modifying this requires prior
# discussion on gentoo-dev@lists.gentoo.org.
-USE_EXPAND="ABI_MIPS ABI_PPC ABI_RISCV ABI_S390 ABI_X86 ADA_TARGET ALSA_CARDS APACHE2_MODULES APACHE2_MPMS CALLIGRA_FEATURES CAMERAS COLLECTD_PLUGINS CPU_FLAGS_ARM CPU_FLAGS_PPC CPU_FLAGS_X86 CURL_SSL ELIBC ENLIGHTENMENT_MODULES FFTOOLS GPSD_PROTOCOLS GRUB_PLATFORMS INPUT_DEVICES KERNEL L10N LCD_DEVICES LIBREOFFICE_EXTENSIONS LIRC_DEVICES LLVM_TARGETS MONKEYD_PLUGINS NGINX_MODULES_HTTP NGINX_MODULES_MAIL NGINX_MODULES_STREAM OFED_DRIVERS OFFICE_IMPLEMENTATION OPENMPI_FABRICS OPENMPI_OFED_FEATURES OPENMPI_RM PHP_TARGETS POSTGRES_TARGETS PYTHON_SINGLE_TARGET PYTHON_TARGETS QEMU_SOFTMMU_TARGETS QEMU_USER_TARGETS ROS_MESSAGES RUBY_TARGETS SANE_BACKENDS USERLAND UWSGI_PLUGINS VIDEO_CARDS VOICEMAIL_STORAGE XFCE_PLUGINS XTABLES_ADDONS"
+USE_EXPAND="ABI_MIPS ABI_PPC ABI_S390 ABI_X86 ADA_TARGET ALSA_CARDS APACHE2_MODULES APACHE2_MPMS CALLIGRA_FEATURES CAMERAS COLLECTD_PLUGINS CPU_FLAGS_ARM CPU_FLAGS_PPC CPU_FLAGS_X86 CURL_SSL ELIBC ENLIGHTENMENT_MODULES FFTOOLS GPSD_PROTOCOLS GRUB_PLATFORMS INPUT_DEVICES KERNEL L10N LCD_DEVICES LIBREOFFICE_EXTENSIONS LIRC_DEVICES LLVM_TARGETS MONKEYD_PLUGINS NGINX_MODULES_HTTP NGINX_MODULES_MAIL NGINX_MODULES_STREAM OFED_DRIVERS OFFICE_IMPLEMENTATION OPENMPI_FABRICS OPENMPI_OFED_FEATURES OPENMPI_RM PHP_TARGETS POSTGRES_TARGETS PYTHON_SINGLE_TARGET PYTHON_TARGETS QEMU_SOFTMMU_TARGETS QEMU_USER_TARGETS ROS_MESSAGES RUBY_TARGETS SANE_BACKENDS USERLAND UWSGI_PLUGINS VIDEO_CARDS VOICEMAIL_STORAGE XFCE_PLUGINS XTABLES_ADDONS"
# USE_EXPAND variables whose contents are not shown in package manager
# output. Changes need discussion on gentoo-dev.
-USE_EXPAND_HIDDEN="USERLAND KERNEL ELIBC ABI_MIPS ABI_PPC ABI_RISCV ABI_S390 ABI_X86 CPU_FLAGS_ARM CPU_FLAGS_PPC CPU_FLAGS_X86"
+USE_EXPAND_HIDDEN="USERLAND KERNEL ELIBC ABI_MIPS ABI_PPC ABI_S390 ABI_X86 CPU_FLAGS_ARM CPU_FLAGS_PPC CPU_FLAGS_X86"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf"
diff --git a/profiles/desc/abi_riscv.desc b/profiles/desc/abi_riscv.desc
deleted file mode 100644
index f11a1dad60b4..000000000000
--- a/profiles/desc/abi_riscv.desc
+++ /dev/null
@@ -1,11 +0,0 @@
-# Copyright 2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# This file contains descriptions of ABI_RISCV USE_EXPAND flags.
-
-# Keep it sorted. Please do not add anything without prior discussion
-# on gentoo-dev.
-lp64d - 64-bit (rv64) double hard-float libraries
-lp64 - 64-bit (rv64) soft-float libraries
-ilp32d - 32-bit (rv32) double hard-float libraries
-ilp32 - 32-bit (rv32) soft-float libraries
diff --git a/profiles/embedded/make.defaults b/profiles/embedded/make.defaults
index cc003fd8857d..97be65cd4cb3 100644
--- a/profiles/embedded/make.defaults
+++ b/profiles/embedded/make.defaults
@@ -30,11 +30,11 @@ USE_EXPAND_VALUES_USERLAND="BSD GNU"
# Env vars to expand into USE vars. Modifying this requires prior
# discussion on gentoo-dev@lists.gentoo.org.
-USE_EXPAND="ABI_MIPS ABI_PPC ABI_RISCV ABI_S390 ABI_X86 ALSA_CARDS APACHE2_MODULES APACHE2_MPMS CALLIGRA_FEATURES CAMERAS COLLECTD_PLUGINS CPU_FLAGS_ARM CPU_FLAGS_X86 CURL_SSL ELIBC ENLIGHTENMENT_MODULES FFTOOLS GPSD_PROTOCOLS GRUB_PLATFORMS INPUT_DEVICES KERNEL L10N LCD_DEVICES LIBREOFFICE_EXTENSIONS LIRC_DEVICES LLVM_TARGETS MONKEYD_PLUGINS NGINX_MODULES_HTTP NGINX_MODULES_MAIL NGINX_MODULES_STREAM OFED_DRIVERS OFFICE_IMPLEMENTATION OPENMPI_FABRICS OPENMPI_OFED_FEATURES OPENMPI_RM PHP_TARGETS POSTGRES_TARGETS PYTHON_SINGLE_TARGET PYTHON_TARGETS QEMU_SOFTMMU_TARGETS QEMU_USER_TARGETS ROS_MESSAGES RUBY_TARGETS SANE_BACKENDS USERLAND UWSGI_PLUGINS VIDEO_CARDS VOICEMAIL_STORAGE XFCE_PLUGINS XTABLES_ADDONS"
+USE_EXPAND="ABI_MIPS ABI_PPC ABI_S390 ABI_X86 ALSA_CARDS APACHE2_MODULES APACHE2_MPMS CALLIGRA_FEATURES CAMERAS COLLECTD_PLUGINS CPU_FLAGS_ARM CPU_FLAGS_X86 CURL_SSL ELIBC ENLIGHTENMENT_MODULES FFTOOLS GPSD_PROTOCOLS GRUB_PLATFORMS INPUT_DEVICES KERNEL L10N LCD_DEVICES LIBREOFFICE_EXTENSIONS LIRC_DEVICES LLVM_TARGETS MONKEYD_PLUGINS NGINX_MODULES_HTTP NGINX_MODULES_MAIL NGINX_MODULES_STREAM OFED_DRIVERS OFFICE_IMPLEMENTATION OPENMPI_FABRICS OPENMPI_OFED_FEATURES OPENMPI_RM PHP_TARGETS POSTGRES_TARGETS PYTHON_SINGLE_TARGET PYTHON_TARGETS QEMU_SOFTMMU_TARGETS QEMU_USER_TARGETS ROS_MESSAGES RUBY_TARGETS SANE_BACKENDS USERLAND UWSGI_PLUGINS VIDEO_CARDS VOICEMAIL_STORAGE XFCE_PLUGINS XTABLES_ADDONS"
# USE_EXPAND variables whose contents are not shown in package manager
# output. Changes need discussion on gentoo-dev.
-USE_EXPAND_HIDDEN="USERLAND KERNEL ELIBC ABI_MIPS ABI_PPC ABI_RISCV ABI_S390 ABI_X86 CPU_FLAGS_ARM CPU_FLAGS_X86"
+USE_EXPAND_HIDDEN="USERLAND KERNEL ELIBC ABI_MIPS ABI_PPC ABI_S390 ABI_X86 CPU_FLAGS_ARM CPU_FLAGS_X86"
# Variables that are set exclusively by the profile
# and not by user configuration files.
diff --git a/profiles/features/multilib/package.use b/profiles/features/multilib/package.use
index 33f47dfe41ab..2e331dfb04f3 100644
--- a/profiles/features/multilib/package.use
+++ b/profiles/features/multilib/package.use
@@ -3,4 +3,4 @@
# Enable all ABIs by default so we can protect any non-native binaries that
# might be executed.
-sys-apps/sandbox abi_x86_32 abi_x86_64 abi_x86_x32 abi_mips_o32 abi_mips_n32 abi_mips_n64 abi_riscv_lp64d abi_riscv_lp64 abi_riscv_ilp32d abi_riscv_ilp32 abi_s390_32 abi_s390_64
+sys-apps/sandbox abi_x86_32 abi_x86_64 abi_x86_x32 abi_mips_o32 abi_mips_n32 abi_mips_n64 abi_s390_32 abi_s390_64