summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/ocplib-endian/Manifest1
-rw-r--r--dev-ml/ocplib-endian/ocplib-endian-1.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-ml/ocplib-endian/Manifest b/dev-ml/ocplib-endian/Manifest
index 57464cb670bf..ff871c2e9249 100644
--- a/dev-ml/ocplib-endian/Manifest
+++ b/dev-ml/ocplib-endian/Manifest
@@ -1 +1,2 @@
DIST ocplib-endian-0.8.tar.gz 56733 SHA256 34a9ffda92459ae0ccd0b6e97cd947ed59f565f5a5776f51e18f5fec27c8ea44 SHA512 6978e9e306faf115d1b732e221dad8a1eea1c2eae12b5ca6f5462ee8b603900fcc585dc5a20e0a35fa793cf3d9fe50833b284a4385bc3d251e86457bf54a8697 WHIRLPOOL 9f595128d0c1281c56c70ef76522afa721d5b7e81199218b6509d9aa4b8a7c32b5f64b1d6b3dd65c9c7dc5a638233f3e46ef7ed1de88614f62d2a6a6c70e3be6
+DIST ocplib-endian-1.0.tar.gz 62753 SHA256 76f268e1aff8dbac8b6a0ca9473f90255da35f15b0fcaf26a840cb6f73029243 SHA512 a08fd58ec5e72510c40e8b75e0ee8327ee658f479e45dd4632bc04e3907d04aaa3684df3b993ab63fc2a6c1f1a4fb32784e9b5258730d3b89a716300522d8d7f WHIRLPOOL 6ae457809630e459fb928b0be6ccd5eeb36f88130ad47f4805bea2613f7ecca82bdf2c2ad8cea067c7e721bb9a29bd76d6016660a4c4d9b8e3edd946ad11ef59
diff --git a/dev-ml/ocplib-endian/ocplib-endian-1.0.ebuild b/dev-ml/ocplib-endian/ocplib-endian-1.0.ebuild
new file mode 100644
index 000000000000..8c8e22af4455
--- /dev/null
+++ b/dev-ml/ocplib-endian/ocplib-endian-1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Optimised functions to read and write int16/32/64 from strings, bytes and bigarrays"
+HOMEPAGE="https://github.com/OCamlPro/ocplib-endian"
+SRC_URI="https://github.com/OCamlPro/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=dev-lang/ocaml-4.01
+ >=dev-ml/cppo-1.1.0
+"
+RDEPEND=""
+
+DOCS=( CHANGES.md COPYING.txt README.md )