summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ros/rosbridge_server/rosbridge_server-9999.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/dev-ros/rosbridge_server/rosbridge_server-9999.ebuild b/dev-ros/rosbridge_server/rosbridge_server-9999.ebuild
index cf540ab83cad..b3100bf069fd 100644
--- a/dev-ros/rosbridge_server/rosbridge_server-9999.ebuild
+++ b/dev-ros/rosbridge_server/rosbridge_server-9999.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/RobotWebTools/rosbridge_suite"
KEYWORDS="~amd64"
-PYTHON_COMPAT=( python2_7 )
ROS_SUBDIR=${PN}
inherit ros-catkin
@@ -15,10 +14,16 @@ SLOT="0"
IUSE=""
RDEPEND="
+ dev-ros/rosbridge_library[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosbridge_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
dev-ros/rosapi[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
dev-ros/rospy[${PYTHON_USEDEP}]
- dev-ros/rosbridge_library[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
dev-ros/rosauth[${PYTHON_USEDEP}]
+
www-servers/tornado[${PYTHON_USEDEP}]
+ dev-python/autobahn[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )
+"