summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-24 20:32:28 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-25 07:52:25 +0100
commit4a9d75eba74849519d4aee4dadce7e376b0aae50 (patch)
tree3a206c6bec16aaa9a49d413dd93e120358ecdd5f /xfce-extra
parentdev-java/commons-io: Stabilize 2.18.0 amd64, #946875 (diff)
downloadgentoo-4a9d75eba74849519d4aee4dadce7e376b0aae50.tar.gz
gentoo-4a9d75eba74849519d4aee4dadce7e376b0aae50.tar.bz2
gentoo-4a9d75eba74849519d4aee4dadce7e376b0aae50.zip
xfce-extra/xfce4-diskperf-plugin: Bump to 2.7.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-diskperf-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-diskperf-plugin/xfce4-diskperf-plugin-2.7.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-diskperf-plugin/Manifest b/xfce-extra/xfce4-diskperf-plugin/Manifest
index 16cc35f92fd6..9682c1acc870 100644
--- a/xfce-extra/xfce4-diskperf-plugin/Manifest
+++ b/xfce-extra/xfce4-diskperf-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-diskperf-plugin-2.7.0.tar.bz2 342471 BLAKE2B c70d3468d1274632414064ae7709717c3e75fe4b9583007b85b66f711d86ff85cbe6819d9b6f606da3994deea190f4f2b4a932e48245a636a2706ee7caededb3 SHA512 8d9dde5534ff2ff99955e7d19b9fd1a0ca6e481f978462578c246c30febc9c2d16c97362014c05b53bd2e895199dbfaa2bdee459b84de3df94f86791d9b07b4f
+DIST xfce4-diskperf-plugin-2.7.1.tar.bz2 457061 BLAKE2B 16965962be291c6916de1147f4744e235a916566bd80e89fc4f41058d421122af4724552765a3701756115de7d5752da5c4e8e433722c1e74cd8398c95c92b74 SHA512 020efe8408a9ef0e598fcb7e37769880a0330347d0e1d0b7d7e5e4731bd05ac71f687be4a5a3bda6aba4c9b20d7d1491ca068a468c5a0f284ab2fa261f351f2f
diff --git a/xfce-extra/xfce4-diskperf-plugin/xfce4-diskperf-plugin-2.7.1.ebuild b/xfce-extra/xfce4-diskperf-plugin/xfce4-diskperf-plugin-2.7.1.ebuild
new file mode 100644
index 000000000000..bc3444ae904a
--- /dev/null
+++ b/xfce-extra/xfce4-diskperf-plugin/xfce4-diskperf-plugin-2.7.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A panel plug-in for disk usage and performance statistics"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-diskperf-plugin
+ https://gitlab.xfce.org/panel-plugins/xfce4-diskperf-plugin/
+"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0
+ >=x11-libs/gtk+-3.22.0:3
+ >=xfce-base/libxfce4ui-4.16.0:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.16.0:=[gtk3(+)]
+ >=xfce-base/xfce4-panel-4.16.0:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}