summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHolger Hoffstätte <holger@applied-asynchrony.com>2023-07-24 16:21:44 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-24 20:41:11 +0200
commit5d4b482354e12221ed685a99f93c79b3de7735bf (patch)
tree580507571798b91c9c75eb7f980cebcee6204d4a /xfce-extra/xfce4-cpugraph-plugin
parentdev-python/jellyfish: Remove old (diff)
downloadgentoo-5d4b482354e12221ed685a99f93c79b3de7735bf.tar.gz
gentoo-5d4b482354e12221ed685a99f93c79b3de7735bf.tar.bz2
gentoo-5d4b482354e12221ed685a99f93c79b3de7735bf.zip
xfce-extra/xfce4-cpugraph-plugin: add fix for gcc-13 (missing cstdint)
Closes: https://bugs.gentoo.org/910712 Signed-off-by: Holger Hoffstätte <holger@applied-asynchrony.com> Closes: https://github.com/gentoo/gentoo/pull/32022 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfce4-cpugraph-plugin')
-rw-r--r--xfce-extra/xfce4-cpugraph-plugin/files/gcc13.patch16
-rw-r--r--xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.7.ebuild2
-rw-r--r--xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.8.ebuild2
3 files changed, 20 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-cpugraph-plugin/files/gcc13.patch b/xfce-extra/xfce4-cpugraph-plugin/files/gcc13.patch
new file mode 100644
index 000000000000..7b5ef2791520
--- /dev/null
+++ b/xfce-extra/xfce4-cpugraph-plugin/files/gcc13.patch
@@ -0,0 +1,16 @@
+
+Bug: https://bugs.gentoo.org/910712
+Bug: https://gitlab.xfce.org/panel-plugins/xfce4-cpugraph-plugin/-/issues/37
+
+Signed-off-by: Holger Hoffstätte <holger@applied-asynchrony.com>
+
+--- a/xfce4++/util/gtk.cc~ 2023-07-22 22:44:01.000000000 +0200
++++ b/xfce4++/util/gtk.cc 2023-07-23 10:01:32.508675676 +0200
+@@ -19,6 +19,7 @@
+ */
+
+ #include "gtk.h"
++#include <cstdint>
+
+ namespace xfce4 {
+
diff --git a/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.7.ebuild b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.7.ebuild
index eb4cc5e6675f..68925fb6ac2e 100644
--- a/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.7.ebuild
+++ b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.7.ebuild
@@ -31,6 +31,8 @@ BDEPEND="
virtual/pkgconfig
"
+PATCHES=( "${FILESDIR}"/gcc13.patch )
+
src_install() {
default
find "${ED}" -name '*.la' -delete || die
diff --git a/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.8.ebuild b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.8.ebuild
index 894630719613..952e3decb840 100644
--- a/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.8.ebuild
+++ b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.8.ebuild
@@ -33,6 +33,8 @@ BDEPEND="
virtual/pkgconfig
"
+PATCHES=( "${FILESDIR}"/gcc13.patch )
+
src_install() {
default
find "${ED}" -name '*.la' -delete || die