summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorjuippis <juippis@gmail.com>2018-03-23 16:49:53 +0200
committerMichał Górny <mgorny@gentoo.org>2018-03-25 12:28:09 +0200
commit79e90bd4d746a4afcd73edd8ec19c184eb4192ab (patch)
tree0308df4ff236e34e973b63fb0ffc44a6e2d155b3 /x11-wm
parentdev-perl/XML-DOM: Fix tests for '.' in @INC removal bug #623186 (diff)
downloadgentoo-79e90bd4d746a4afcd73edd8ec19c184eb4192ab.tar.gz
gentoo-79e90bd4d746a4afcd73edd8ec19c184eb4192ab.tar.bz2
gentoo-79e90bd4d746a4afcd73edd8ec19c184eb4192ab.zip
x11-wm/enlightenment-0.21.7: Disable module_check
Closes: https://bugs.gentoo.org/648896 Closes: https://github.com/gentoo/gentoo/pull/7566
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/enlightenment/enlightenment-0.21.7.ebuild23
1 files changed, 19 insertions, 4 deletions
diff --git a/x11-wm/enlightenment/enlightenment-0.21.7.ebuild b/x11-wm/enlightenment/enlightenment-0.21.7.ebuild
index 1b788a54f596..d84967f414fd 100644
--- a/x11-wm/enlightenment/enlightenment-0.21.7.ebuild
+++ b/x11-wm/enlightenment/enlightenment-0.21.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -13,7 +13,7 @@ else
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
fi
-inherit enlightenment
+inherit enlightenment xdg-utils
DESCRIPTION="Enlightenment DR17 window manager"
@@ -55,7 +55,10 @@ RDEPEND="
)
>=dev-libs/efl-1.18[X]
x11-libs/xcb-util-keysyms"
-DEPEND="${RDEPEND}"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/automake:1.15
+"
S=${WORKDIR}/${MY_P}
@@ -89,7 +92,9 @@ check_modules() {
}
src_configure() {
- check_modules
+ # sanity check fails after commit e25cf18ca19463a7d05519aa843cc76a189ab75c
+ # see #648896. Can be restored with future release
+ # check_modules
E_ECONF=(
--disable-install-sysactions
@@ -123,3 +128,13 @@ src_install() {
insinto /etc/enlightenment
newins "${FILESDIR}"/gentoo-sysactions.conf sysactions.conf
}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}