summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-01-31 13:19:32 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2019-01-31 13:20:06 -0600
commite9291c1436d80538f0434ad5a7a4f91971e45e38 (patch)
treee95d554caef65e02feca249e12d30862ad4f3588 /x11-wm/awesome
parentapp-dicts/myspell-nl-2.10g-r1: alpha stable (diff)
downloadgentoo-e9291c1436d80538f0434ad5a7a4f91971e45e38.tar.gz
gentoo-e9291c1436d80538f0434ad5a7a4f91971e45e38.tar.bz2
gentoo-e9291c1436d80538f0434ad5a7a4f91971e45e38.zip
x11-wm/awesome: 4.3 bump, restrict tests in awesome-4 as well
Fixes: https://bugs.gentoo.org/654084 Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'x11-wm/awesome')
-rw-r--r--x11-wm/awesome/Manifest1
-rw-r--r--x11-wm/awesome/awesome-4.2-r2.ebuild3
-rw-r--r--x11-wm/awesome/awesome-4.3.ebuild134
3 files changed, 137 insertions, 1 deletions
diff --git a/x11-wm/awesome/Manifest b/x11-wm/awesome/Manifest
index 2854b9d5c075..d48e1e46b469 100644
--- a/x11-wm/awesome/Manifest
+++ b/x11-wm/awesome/Manifest
@@ -1,2 +1,3 @@
DIST awesome-3.5.9.tar.xz 723084 BLAKE2B 96f4c5df98147399f28d1b1455ac53800f2222969599486c2f79b73ba36cfa237270cd5972d4e10e0a4f774a54dfa92948bba5d2e0438687d36739e12c3f5ecc SHA512 6a4c679b293e8cd85d1f7e13f6dea704cbb267e42b9260496a54b657a66d6148aae51521d802d61baaeb23df0d4a8ad0b28d9dc922ea5da2a347b4251cce5e25
DIST awesome-4.2.tar.xz 987024 BLAKE2B b2aaa993bafa83121d165d21083dfcac825e373be9547490f8b93b8e8b0f90470395a0238affaf9990f719b8bd2f36a255f6468b6422406787a3c96946c4e831 SHA512 134dd3625c86243861b3d0701cc8bfd8c00986d7027f0832016c3f5e59e6b9a1ef2f677bb0d1d66ece63449533e4b13d8d7388e96e6f9014212030a79f163e09
+DIST awesome-4.3.tar.xz 1037816 BLAKE2B b4afc5e7bfb01ddc16b67776cc00dd7b0bcbefc9d17f9bec9c04256953858aef2bf0e4b15a525909029b7da771ade0d749758aba2878832f356d7b2c4f0363b7 SHA512 c5ef1e8dc593e7783b895d22143154aea8f211beeda24672a7ee4ed5112b4f4284043f848a151f3d3c4f569e91308670367a4353f705b20511b36495b22fa3f5
diff --git a/x11-wm/awesome/awesome-4.2-r2.ebuild b/x11-wm/awesome/awesome-4.2-r2.ebuild
index 3642f6c5a127..230313463011 100644
--- a/x11-wm/awesome/awesome-4.2-r2.ebuild
+++ b/x11-wm/awesome/awesome-4.2-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -13,6 +13,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
IUSE="dbus doc elibc_FreeBSD gnome luajit test"
+RESTRICT="test"
RDEPEND="
>=dev-lang/lua-5.1:0
diff --git a/x11-wm/awesome/awesome-4.3.ebuild b/x11-wm/awesome/awesome-4.3.ebuild
new file mode 100644
index 000000000000..c56912ae9fa2
--- /dev/null
+++ b/x11-wm/awesome/awesome-4.3.ebuild
@@ -0,0 +1,134 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils desktop pax-utils
+
+DESCRIPTION="A dynamic floating and tiling window manager"
+HOMEPAGE="https://awesomewm.org/"
+SRC_URI="https://github.com/awesomeWM/awesome-releases/raw/master/${P}.tar.xz"
+RESTRICT="test"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="dbus doc elibc_FreeBSD gnome luajit test"
+
+RDEPEND="
+ >=dev-lang/lua-5.1:0
+ luajit? ( dev-lang/luajit:2 )
+ dev-libs/glib:2
+ >=dev-libs/libxdg-basedir-1
+ >=dev-lua/lgi-0.8
+ x11-libs/cairo[xcb]
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/libxcb-1.6[xkb]
+ >=x11-libs/pango-1.19.3[introspection]
+ >=x11-libs/startup-notification-0.10_p20110426
+ >=x11-libs/xcb-util-0.3.8
+ x11-libs/xcb-util-cursor
+ >=x11-libs/xcb-util-keysyms-0.3.4
+ >=x11-libs/xcb-util-wm-0.3.8
+ >=x11-libs/xcb-util-xrm-1.0
+ x11-libs/libXcursor
+ x11-libs/libxkbcommon[X]
+ >=x11-libs/libX11-1.3.99.901
+ dbus? ( >=sys-apps/dbus-1 )
+ elibc_FreeBSD? ( || ( dev-libs/libexecinfo >=sys-freebsd/freebsd-lib-10.0 ) )
+"
+
+# graphicsmagick's 'convert -channel' has no Alpha support, bug #352282
+DEPEND="${RDEPEND}
+ >=app-text/asciidoc-8.4.5
+ app-text/xmlto
+ dev-util/gperf
+ virtual/pkgconfig
+ media-gfx/imagemagick[png]
+ >=x11-base/xcb-proto-1.5
+ x11-base/xorg-proto
+ doc? ( dev-lua/ldoc )
+ test? (
+ app-shells/zsh
+ x11-base/xorg-server[xvfb]
+ dev-lua/busted
+ dev-lua/luacheck
+ )
+"
+
+# Skip installation of README.md by einstalldocs, which leads to broken symlink
+DOCS=()
+PATCHES=(
+ "${FILESDIR}/${PN}-4.0-convert-path.patch" # bug #408025
+ "${FILESDIR}/${PN}-xsession.patch" # bug #408025
+ "${FILESDIR}/${PN}-4.0-cflag-cleanup.patch" # bug #509658
+)
+
+src_configure() {
+ # Compression of manpages is handled by portage
+ local mycmakeargs=(
+ -DSYSCONFDIR="${EPREFIX}"/etc
+ -DCOMPRESS_MANPAGES=OFF
+ -DWITH_DBUS=$(usex dbus)
+ -DGENERATE_DOC=$(usex doc)
+ -DAWESOME_DOC_PATH="${EPREFIX}"/usr/share/doc/${PF}
+ )
+ if use luajit; then
+ mycmakeargs+=("-DLUA_INCLUDE_DIR=${EPREFIX}/usr/include/luajit-2.0")
+ mycmakeargs+=("-DLUA_LIBRARY=${EPREFIX}/usr/$(get_libdir)/libluajit-5.1.so")
+ fi
+ cmake-utils_src_configure
+}
+
+src_test() {
+ # awesome's test suite starts Xvfb by itself, no need for virtualx eclass
+ HEADLESS=1 cmake-utils_src_make check -j1
+}
+
+src_install() {
+ cmake-utils_src_install
+ rm "${ED}"/usr/share/doc/${PF}/LICENSE || die
+
+ pax-mark m "${ED%/}"/usr/bin/awesome
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/${PN}-session ${PN}
+
+ # GNOME-based awesome
+ if use gnome; then
+ # GNOME session
+ insinto /usr/share/gnome-session/sessions
+ newins "${FILESDIR}"/${PN}-gnome-3.session ${PN}-gnome.session
+
+ # Application launcher
+ domenu "${FILESDIR}"/${PN}-gnome.desktop
+
+ # X Session
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/${PN}-gnome-xsession.desktop
+ fi
+
+ # This directory contains SVG images which we don't want to compress
+ use doc && touch "${ED}"/usr/share/doc/${PF}/doc/images.ecompress.skip
+}
+
+pkg_postinst() {
+ # bug #447308
+ if use gnome; then
+ elog "You have enabled the gnome USE flag."
+ elog "Please note that quitting awesome won't kill your gnome session."
+ elog "To really quit the session, you should bind your quit key"
+ elog "to the following command:"
+ elog " gnome-session-quit --logout"
+ elog "For more info visit"
+ elog " https://bugs.gentoo.org/show_bug.cgi?id=447308"
+ fi
+
+ # bug #440724
+ elog "If you are having issues with Java application windows being"
+ elog "completely blank, try installing"
+ elog " x11-misc/wmname"
+ elog "and setting the WM name to LG3D."
+ elog "For more info visit"
+ elog " https://bugs.gentoo.org/show_bug.cgi?id=440724"
+}