summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jordan <immoloism@gmail.com>2024-04-06 15:46:19 +0100
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-09 20:19:24 +0300
commit3a572182c5e89880b422d9fc0d075602e0f6cd71 (patch)
tree8585295269b6f8808fec9312978b2419f54a2577 /x11-themes
parentx11-themes/mate-icon-theme: drop 1.27.0 (diff)
downloadgentoo-3a572182c5e89880b422d9fc0d075602e0f6cd71.tar.gz
gentoo-3a572182c5e89880b422d9fc0d075602e0f6cd71.tar.bz2
gentoo-3a572182c5e89880b422d9fc0d075602e0f6cd71.zip
x11-themes/mate-icon-theme: add 1.28.0
Signed-off-by: Ian Jordan <immoloism@gmail.com> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/mate-icon-theme/Manifest1
-rw-r--r--x11-themes/mate-icon-theme/mate-icon-theme-1.28.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/x11-themes/mate-icon-theme/Manifest b/x11-themes/mate-icon-theme/Manifest
index a4f0014777fa..5a1c4e57b4ac 100644
--- a/x11-themes/mate-icon-theme/Manifest
+++ b/x11-themes/mate-icon-theme/Manifest
@@ -1 +1,2 @@
DIST mate-icon-theme-1.26.0.tar.xz 21872216 BLAKE2B 9acccace3483a7e8d4a2958bc14119a42f76dcdad2c455d0f3f10653cc689ed3a4cca7d122474b2bff0b5100e586ea5fabf137a1d9b11545eeaa84745d9d576b SHA512 937d65710c1b7cc79ba0b71cd1a480597f20035380ffd5f0528c45c86bc8963189116d2c02332352170b7cd12fba5dd91f94cee9626104ab55c576d58f0636b8
+DIST mate-icon-theme-1.28.0.tar.xz 22206532 BLAKE2B 18b7f43c5a1a0c8f9a45feb0d4941d659d67d98918227615d12acd176cc3cf96a8eb48c9d9bfebe4710417b3fffabc89d433d51c44b42df16bf62332a743b6ae SHA512 392da9625008bec72b6017c13c409aa2dceda19f6093f0e5fbbdb9a1fb3944711092690ecf4158016578f5231f0aae036b1ef04ac843036ec588b9125a483902
diff --git a/x11-themes/mate-icon-theme/mate-icon-theme-1.28.0.ebuild b/x11-themes/mate-icon-theme/mate-icon-theme-1.28.0.ebuild
new file mode 100644
index 000000000000..ff55f66764e3
--- /dev/null
+++ b/x11-themes/mate-icon-theme/mate-icon-theme-1.28.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit mate
+
+MINOR=$(($(ver_cut 2) % 2))
+if [[ ${MINOR} -eq 0 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="MATE default icon themes"
+LICENSE="GPL-2"
+SLOT="0"
+
+COMMON_DEPEND=">=x11-themes/hicolor-icon-theme-0.10"
+
+RDEPEND="${COMMON_DEPEND}"
+
+BDEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40
+ >=x11-misc/icon-naming-utils-0.8.7:0
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+RESTRICT="binchecks strip"
+
+src_configure() {
+ mate_src_configure --enable-icon-mapping
+}