summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2025-01-16 00:10:19 -0500
committerIonen Wolkens <ionen@gentoo.org>2025-01-16 00:18:30 -0500
commit70e9b2ea317d8a24a946d46019b5654f981254bb (patch)
tree47e82588c5d7c27a5b0c1fd85bd8faf72d038c70 /x11-terms/kitty-terminfo
parentx11-terms/kitty-shell-integration: add 0.39.0 (diff)
downloadgentoo-70e9b2ea317d8a24a946d46019b5654f981254bb.tar.gz
gentoo-70e9b2ea317d8a24a946d46019b5654f981254bb.tar.bz2
gentoo-70e9b2ea317d8a24a946d46019b5654f981254bb.zip
x11-terms/kitty-terminfo: add 0.39.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms/kitty-terminfo')
-rw-r--r--x11-terms/kitty-terminfo/Manifest1
-rw-r--r--x11-terms/kitty-terminfo/kitty-terminfo-0.39.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/x11-terms/kitty-terminfo/Manifest b/x11-terms/kitty-terminfo/Manifest
index fa7bd9f794e3..ee4064e1be1f 100644
--- a/x11-terms/kitty-terminfo/Manifest
+++ b/x11-terms/kitty-terminfo/Manifest
@@ -1,2 +1,3 @@
DIST kitty-0.35.2.tar.xz 8220608 BLAKE2B 277803c7036890af34f2e0497ab1d33cb578cba4bfba425d6699e02e2106cde4e10f7dcc6859ce7eea1b4f34795a2f5180328665450ccb49d8a6da4183fa4f50 SHA512 edc78046f942965c823a1202a6d7c85cc2d2acb376824a0f5224d4ba6f48ed0978a00eb7a3e1e6053622a7d5fdcf80009ecfb61a63272cf407dd30f828f47b56
DIST kitty-0.38.1.tar.xz 8935276 BLAKE2B 3cb8cdd8ecdefcbc0317c0ab343df8a71d257f34e0fd961bf9a5991a0a259545cc87adbc4931330eb7ec380608a67a68690f704c35469a57cc82c119bde5d3cb SHA512 273a9fc959973ad73105f5d589e420df9360bb20818165b05e14981c42f7146cec6cbb17539a91089a5af9b94dbb3f416421671bbe20cdb0b876cde5043b784c
+DIST kitty-0.39.0.tar.xz 8938592 BLAKE2B bd9bc47e58824e18c9dd61ab83f8322abcd7b296902dde3e4bb66516b7d83991fce45d3f4580cd9cfb26f7f51f427e0f2a47dfbf695e2236b5f7042643c672fc SHA512 765f1c4bd6aa8fe751c4e0d4a44b924858ed1eb97b37beaa60e5a90b16df353e9b7db32990aa93bc960e8f01ae3de88381fe4cbc1a4dc69c0bdf655077fdf3ab
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-0.39.0.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-0.39.0.ebuild
new file mode 100644
index 000000000000..f8b7fac6a2f0
--- /dev/null
+++ b/x11-terms/kitty-terminfo/kitty-terminfo-0.39.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Terminfo for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+BDEPEND="sys-libs/ncurses"
+
+src_compile() { :; }
+
+src_install() {
+ dodir /usr/share/terminfo
+ tic -xo "${ED}"/usr/share/terminfo terminfo/kitty.terminfo || die
+}