summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2022-09-25 10:21:55 +0200
committerMatt Turner <mattst88@gentoo.org>2022-09-26 10:48:32 -0400
commit899f365ee844d5cb2a0e53e4c106361052de7384 (patch)
tree81d020e9f296bba5a9afe4748f1eeeb455d0f20e /x11-terms/gnome-terminal
parentx11-libs/vte: version bump to 0.70.0 (diff)
downloadgentoo-899f365ee844d5cb2a0e53e4c106361052de7384.tar.gz
gentoo-899f365ee844d5cb2a0e53e4c106361052de7384.tar.bz2
gentoo-899f365ee844d5cb2a0e53e4c106361052de7384.zip
x11-terms/gnome-terminal: version bump to 3.46.1
Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-terms/gnome-terminal')
-rw-r--r--x11-terms/gnome-terminal/Manifest2
-rw-r--r--x11-terms/gnome-terminal/gnome-terminal-3.46.1.ebuild96
2 files changed, 98 insertions, 0 deletions
diff --git a/x11-terms/gnome-terminal/Manifest b/x11-terms/gnome-terminal/Manifest
index e14e2a8469bf..b9ccdbe28519 100644
--- a/x11-terms/gnome-terminal/Manifest
+++ b/x11-terms/gnome-terminal/Manifest
@@ -1,2 +1,4 @@
DIST gnome-terminal-3.44.0-cntr-ntfy-autottl-ts.patch.xz 37248 BLAKE2B b3599386e7272fc5b742c11663f09bbfafa84cc855bd13fd602d679601fbb4126f36cdb157db37db335bf9edfe7d2b85e534baf837c5817984ec17baa4cdbb6c SHA512 6422a774abfee18b2681115344f508b72ead1bb9f27b5b1596b419a9ce5a137d41e2d749b6d784170225e7f21f15c109f7eb74cc3164371d53dee7790bf99187
DIST gnome-terminal-3.44.1.tar.xz 1813032 BLAKE2B 3e001139aa0516bd27f7215c692c048393d6ad41737b8817f212529d3c530f6417d05601f63e6265e3fb84e788322341c25784a0a26ee7434f1d4bccd31c1eea SHA512 afaa9a1b4fa86fea853a242f167d1ba3438efe4e049336bae138cb800d43c3325f624849463f16c9d4e34360916377c4edbfd2f3977212b51e35a41cca88b283
+DIST gnome-terminal-3.46.1-cntr-ntfy-autottl-ts.patch.xz 35024 BLAKE2B 84ca3bb1aa3a6fbf2da72cbd880a4c7fefc32617071dccc3806cd033b67a75b4da01a482bbc47bede74004184851733dd719414037c93c71215d1cdd616a6b06 SHA512 4ad6f374053f974b22d4d274d1b61a80c370ceb85d9870e75c63bb18f1af6aebb18c65bb5bed6f10a8177b0b37d91511a1a627fa2fa1663f66daee36918341d3
+DIST gnome-terminal-3.46.1.tar.gz 2869379 BLAKE2B ec7a7922c7b1d15fe220fd4fbffe18a72143dc4d9acdc12b3b8f5cceddd51ca4ae408a394396483e789c98fc9b9750918156ca4016cc00c5909f509520824616 SHA512 0786c8eda0c1c38b845377f57113c0ea40e58d2e64c4abb8d59a66bbc3adfaf3c3b2c34d1558b9a9165ec69168e2ad8f47afde4d63e7cf26f57764e4759177ea
diff --git a/x11-terms/gnome-terminal/gnome-terminal-3.46.1.ebuild b/x11-terms/gnome-terminal/gnome-terminal-3.46.1.ebuild
new file mode 100644
index 000000000000..c6c5d16c6f46
--- /dev/null
+++ b/x11-terms/gnome-terminal/gnome-terminal-3.46.1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+inherit gnome.org gnome2-utils meson python-any-r1 readme.gentoo-r1 xdg
+
+DESCRIPTION="A terminal emulator for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Terminal/ https://gitlab.gnome.org/GNOME/gnome-terminal"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="debug +gnome-shell +nautilus vanilla"
+
+# Upstream is hostile and refuses to upload tarballs.
+SRC_URI="https://gitlab.gnome.org/GNOME/${PN}/-/archive/${PV}/${P}.tar.gz"
+SRC_URI+=" !vanilla? ( https://dev.gentoo.org/~mattst88/distfiles/${PN}-3.46.1-cntr-ntfy-autottl-ts.patch.xz )"
+
+KEYWORDS="~amd64"
+
+# FIXME: automagic dependency on gtk+[X], just transitive but needs proper control, bug 624960
+RDEPEND="
+ >=dev-libs/glib-2.52:2
+ >=x11-libs/gtk+-3.22.27:3
+ >=x11-libs/vte-0.70.0:2.91[!vanilla?]
+ >=dev-libs/libpcre2-10
+ >=gnome-base/gsettings-desktop-schemas-0.1.0
+ sys-apps/util-linux
+ gnome-shell? ( gnome-base/gnome-shell )
+ nautilus? ( >=gnome-base/nautilus-43.0 )
+"
+DEPEND="${RDEPEND}"
+# itstool required for help/* with non-en LINGUAS, see bug #549358
+# xmllint required for glib-compile-resources, see bug #549304
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DOC_CONTENTS="To get previous working directory inherited in new opened tab, or
+ notifications of long-running commands finishing, you will need
+ to add the following line to your ~/.bashrc:\n
+ . /etc/profile.d/vte-2.91.sh"
+
+src_prepare() {
+ eapply "${FILESDIR}"/${PN}-3.44.1-fix-missing-wexitcode.patch
+ if ! use vanilla; then
+ # https://bugzilla.gnome.org/show_bug.cgi?id=695371
+ # Fedora patches:
+ # Restore transparency support (with compositing WMs only)
+ # OSC 777 desktop notification support (notifications on tabs for long-running commands completing)
+ # Restore "Set title" support
+ # Automatic title updating based on currently running foreground process
+ # https://src.fedoraproject.org/rpms/gnome-terminal/raw/f31/f/gnome-terminal-cntr-ntfy-autottl-ts.patch
+ # Depends on vte[-vanilla] for OSC 777 and the preexec/precmd/etc patches in VTE
+ eapply "${WORKDIR}"/${PN}-3.46.1-cntr-ntfy-autottl-ts.patch
+ fi
+ default
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use debug dbg)
+ -Ddocs=false
+ $(meson_use nautilus nautilus_extension)
+ $(meson_use gnome-shell search_provider)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if ! use vanilla; then
+ # Separate "New Window/Tab" menu entries by default, instead of unified "New Terminal"
+ insinto /usr/share/glib-2.0/schemas
+ newins "${FILESDIR}"/separate-new-tab-window.gschema.override org.gnome.Terminal.gschema.override
+ fi
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}