summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmnet
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmnet')
-rw-r--r--x11-plugins/wmnet/Manifest2
-rw-r--r--x11-plugins/wmnet/metadata.xml14
-rw-r--r--x11-plugins/wmnet/wmnet-1.06-r1.ebuild40
3 files changed, 56 insertions, 0 deletions
diff --git a/x11-plugins/wmnet/Manifest b/x11-plugins/wmnet/Manifest
new file mode 100644
index 000000000000..f2183482700a
--- /dev/null
+++ b/x11-plugins/wmnet/Manifest
@@ -0,0 +1,2 @@
+DIST wmnet-1.06-misc.patch.bz2 11327 RMD160 e889730b0ab79f80d68870094e38d4623ec194b2 SHA1 8a08f8fc8f9fe70bd63c4f314cae4d9b24599a05 SHA256 d1faab4600efa1d6a6973dfc05d451fb0fabf417a58f32bc1d4f21a0d7d7cbc9
+DIST wmnet-1.06.tar.gz 27506 RMD160 a6ac89507370acecc9673f52fd26ae896cc5da5c SHA1 978364e0ab45c71730c196334e8fced4ac0a7853 SHA256 79c6ef93126d2a4928818391c0aa20638d47cd9dca12d999e774591f9b2d365d
diff --git a/x11-plugins/wmnet/metadata.xml b/x11-plugins/wmnet/metadata.xml
new file mode 100644
index 000000000000..df079f4162b4
--- /dev/null
+++ b/x11-plugins/wmnet/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+<longdescription>
+wmnet polls network statistics and does a few things with the data it gets. It
+has small blinking lights for the rx and tx of ip packets, a digital
+speedometer of your tcp/ip stack's current speed and neatest of all, a bar
+graph like xload et. al which has a tx speed graph from bottom-up and rx speed
+graph from the top-down. The speedometer keeps track of the current speed per
+second and shows it in a color corresponding to which of rx or tx that has the
+highest speed at the moment.
+</longdescription>
+</pkgmetadata>
diff --git a/x11-plugins/wmnet/wmnet-1.06-r1.ebuild b/x11-plugins/wmnet/wmnet-1.06-r1.ebuild
new file mode 100644
index 000000000000..31eaaa35b1c2
--- /dev/null
+++ b/x11-plugins/wmnet/wmnet-1.06-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+IUSE=""
+DESCRIPTION="WMnet is a dock.app network monitor"
+SRC_URI="http://www.digitalkaos.net/linux/wmnet/download/${P}.tar.gz
+ mirror://gentoo/${P}-misc.patch.bz2"
+HOMEPAGE="http://www.digitalkaos.net/linux/wmnet/"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto
+ x11-misc/imake
+ app-text/rman"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 sparc alpha amd64 ppc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}"/${P}-misc.patch # bug 72818
+}
+
+src_compile() {
+ xmkmf || die "xmkmf failed."
+ emake CDEBUGFLAGS="${CFLAGS}" LDOPTIONS="${LDFLAGS}" || die "emake failed."
+}
+
+src_install() {
+ dobin wmnet
+ newman wmnet.man wmnet.1
+ dodoc README Changelog
+}