summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/fsviewer
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/fsviewer')
-rw-r--r--x11-plugins/fsviewer/Manifest1
-rw-r--r--x11-plugins/fsviewer/files/fsviewer-0.2.6-wmaker-0.95_support.patch36
-rw-r--r--x11-plugins/fsviewer/fsviewer-0.2.6.ebuild45
-rw-r--r--x11-plugins/fsviewer/metadata.xml5
4 files changed, 87 insertions, 0 deletions
diff --git a/x11-plugins/fsviewer/Manifest b/x11-plugins/fsviewer/Manifest
new file mode 100644
index 000000000000..06552d461d51
--- /dev/null
+++ b/x11-plugins/fsviewer/Manifest
@@ -0,0 +1 @@
+DIST fsviewer-app-0.2.6.tar.bz2 785422 SHA256 18f964da350bf617a76ccca6411000862394bca09f7616b5b019d6a760bfa57b SHA512 47c10a049120db8e5b095fdcc82033b66a4413f8f7e88959f0190b568324e85c8362486e0419b9c098e62e19e38dd8f2f56c6f0d1e7829afafd21a4837b4859b WHIRLPOOL b3304d65687dd1444787caadfd31164cd67535adad99e5d8d6c6b221187130d44653276ffb3048961db87d2e877f76adf25b635a9c8fa98b427224ce2e012e76
diff --git a/x11-plugins/fsviewer/files/fsviewer-0.2.6-wmaker-0.95_support.patch b/x11-plugins/fsviewer/files/fsviewer-0.2.6-wmaker-0.95_support.patch
new file mode 100644
index 000000000000..da64f3a0389e
--- /dev/null
+++ b/x11-plugins/fsviewer/files/fsviewer-0.2.6-wmaker-0.95_support.patch
@@ -0,0 +1,36 @@
+diff -Naur fsviewer-app-0.2.6.orig/configure.ac fsviewer-app-0.2.6/configure.ac
+--- fsviewer-app-0.2.6.orig/configure.ac 2012-07-11 17:55:06.448981246 +0200
++++ fsviewer-app-0.2.6/configure.ac 2012-07-11 18:04:15.528940159 +0200
+@@ -81,6 +81,8 @@
+ AC_MSG_ERROR([WMaker library not found]))
+ AC_CHECK_LIB(WINGs, WMAppSetMainMenu,,
+ AC_MSG_ERROR([WINGs library not found]))
++AC_CHECK_LIB(WUtil, WMCreatePLString,,
++ AC_MSG_ERROR([WUtil library not found]))
+
+ dnl Checks for PropList (not necessary since version 0.2.3b)
+ dnl AC_CHECK_HEADERS(proplist.h,, AC_MSG_WARN(Can't find PropList include-file: Please install libPropList (included in WindowMaker)))
+diff -Naur fsviewer-app-0.2.6.orig/defs/chdef.c fsviewer-app-0.2.6/defs/chdef.c
+--- fsviewer-app-0.2.6.orig/defs/chdef.c 2012-07-11 17:55:06.444981361 +0200
++++ fsviewer-app-0.2.6/defs/chdef.c 2012-07-11 17:55:50.387699640 +0200
+@@ -374,7 +374,7 @@
+ SetIntegerForKey(0, "DisplayMCListPixmap");
+
+ WMWritePropListToFile(filesDB,
+- wdefaultspathfordomain("FSViewer"), True);
++ wdefaultspathfordomain("FSViewer"));
+ result = 0;
+ }
+ else
+diff -Naur fsviewer-app-0.2.6.orig/src/extnInspector.c fsviewer-app-0.2.6/src/extnInspector.c
+--- fsviewer-app-0.2.6.orig/src/extnInspector.c 2012-07-11 17:55:06.452981130 +0200
++++ fsviewer-app-0.2.6/src/extnInspector.c 2012-07-11 17:56:02.315351669 +0200
+@@ -229,7 +229,7 @@
+
+ if(numRows > 0)
+ WMWritePropListToFile(filesDB,
+- wdefaultspathfordomain("FSViewer"), True);
++ wdefaultspathfordomain("FSViewer"));
+
+ if(extn)
+ free(extn);
diff --git a/x11-plugins/fsviewer/fsviewer-0.2.6.ebuild b/x11-plugins/fsviewer/fsviewer-0.2.6.ebuild
new file mode 100644
index 000000000000..3ef50fdd08a0
--- /dev/null
+++ b/x11-plugins/fsviewer/fsviewer-0.2.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils multilib
+
+MY_P=${PN}-app-${PV}
+
+DESCRIPTION="A file system viewer for Window Maker"
+HOMEPAGE="http://www.bayernline.de/~gscholz/linux/fsviewer/"
+SRC_URI="http://www.bayernline.de/~gscholz/linux/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="nls"
+
+RDEPEND=">=x11-wm/windowmaker-0.95.2
+ x11-libs/libXft
+ x11-libs/libXpm
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-wmaker-0.95_support.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ --with-appspath=/usr/$(get_libdir)/GNUstep
+}
+
+src_install() {
+ default
+ dosym /usr/$(get_libdir)/GNUstep/FSViewer.app/FSViewer /usr/bin/FSViewer
+}
diff --git a/x11-plugins/fsviewer/metadata.xml b/x11-plugins/fsviewer/metadata.xml
new file mode 100644
index 000000000000..a03f5d8b381b
--- /dev/null
+++ b/x11-plugins/fsviewer/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-dock</herd>
+</pkgmetadata>