summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNRK <nrk@disroot.org>2024-09-20 21:16:54 +0000
committerEli Schwartz <eschwartz@gentoo.org>2024-10-06 23:23:56 -0400
commitdfe1b1aab8e4ac6baf473ef0dc8a38c0ec813b67 (patch)
treefa49a5eaa276618c1afa16a4b38f6a57edec0eaf /x11-misc
parentnet-voip/murmur: fix build on musl (diff)
downloadgentoo-dfe1b1aab8e4ac6baf473ef0dc8a38c0ec813b67.tar.gz
gentoo-dfe1b1aab8e4ac6baf473ef0dc8a38c0ec813b67.tar.bz2
gentoo-dfe1b1aab8e4ac6baf473ef0dc8a38c0ec813b67.zip
x11-misc/slop: fix build failure with newer icu
Closes: https://bugs.gentoo.org/933863 Signed-off-by: NRK <nrk@disroot.org> Closes: https://github.com/gentoo/gentoo/pull/37235 Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/slop/files/icu-75.1-cxx17.patch21
-rw-r--r--x11-misc/slop/slop-7.6-r1.ebuild7
2 files changed, 27 insertions, 1 deletions
diff --git a/x11-misc/slop/files/icu-75.1-cxx17.patch b/x11-misc/slop/files/icu-75.1-cxx17.patch
new file mode 100644
index 000000000000..4852c83fc6e8
--- /dev/null
+++ b/x11-misc/slop/files/icu-75.1-cxx17.patch
@@ -0,0 +1,21 @@
+https://bugs.gentoo.org/933863
+https://github.com/naelstrof/slop/issues/172
+
+--- a/CMakeLists.txt
++++ a/CMakeLists.txt
+@@ -53,13 +53,13 @@ if ( SLOP_OPENGL )
+ endif()
+
+ set_property(TARGET ${LIBRARY_NAME} PROPERTY CXX_STANDARD_REQUIRED ON)
+-set_property(TARGET ${LIBRARY_NAME} PROPERTY CXX_STANDARD 11)
++set_property(TARGET ${LIBRARY_NAME} PROPERTY CXX_STANDARD 17)
+ set_property(TARGET ${LIBRARY_NAME} PROPERTY CXX_EXTENSIONS OFF)
+
+ add_executable(${EXECUTABLE_NAME} src/main.cpp)
+
+ set_property(TARGET ${EXECUTABLE_NAME} PROPERTY CXX_STANDARD_REQUIRED ON)
+-set_property(TARGET ${EXECUTABLE_NAME} PROPERTY CXX_STANDARD 11)
++set_property(TARGET ${EXECUTABLE_NAME} PROPERTY CXX_STANDARD 17)
+ set_property(TARGET ${EXECUTABLE_NAME} PROPERTY CXX_EXTENSIONS OFF)
+
+ set( CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/modules" )
diff --git a/x11-misc/slop/slop-7.6-r1.ebuild b/x11-misc/slop/slop-7.6-r1.ebuild
index c54f3ecfd4d0..c9efba7da996 100644
--- a/x11-misc/slop/slop-7.6-r1.ebuild
+++ b/x11-misc/slop/slop-7.6-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -36,6 +36,11 @@ DEPEND="
PATCHES=( "${FILESDIR}/${PN}"-7.5-missing-header.patch )
+src_prepare() {
+ use icu && eapply "${FILESDIR}/"icu-75.1-cxx17.patch
+ cmake_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
-DSLOP_OPENGL=$(usex opengl)