summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2022-10-07 13:47:05 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2022-10-07 13:49:27 +0200
commitc9e0ab01d71239079774e0e3b0085791bdeb1731 (patch)
tree7368b23b7de61a25d8ba27982d78ae61e2438d2a /x11-misc/zim
parentsys-kernel/gentoo-sources: add 5.4.217 (diff)
downloadgentoo-c9e0ab01d71239079774e0e3b0085791bdeb1731.tar.gz
gentoo-c9e0ab01d71239079774e0e3b0085791bdeb1731.tar.bz2
gentoo-c9e0ab01d71239079774e0e3b0085791bdeb1731.zip
x11-misc/zim: add 0.75.0
EAPI and python versions bump Switch to PEP 517 distutils Switch to optfeature eclass Enable tests and set virtualx to test-only Closes: https://bugs.gentoo.org/874027 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-misc/zim')
-rw-r--r--x11-misc/zim/Manifest1
-rw-r--r--x11-misc/zim/zim-0.75.0.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/x11-misc/zim/Manifest b/x11-misc/zim/Manifest
index 4ed875a7efd0..b05deb3a3024 100644
--- a/x11-misc/zim/Manifest
+++ b/x11-misc/zim/Manifest
@@ -3,3 +3,4 @@ DIST zim-0.74.0.tar.gz 2917916 BLAKE2B 32b1086395142d07b46425264e3ee6d6782d62f13
DIST zim-0.74.1.tar.gz 2994036 BLAKE2B 9de89ce74bc08ec0b60f34d693ffdb3b8220efe6f03e3d77686c9d3db135713d7eb5e0beed35eb6f979e489f12b9d65b9b66e0e7449c45b955711684154ae6b8 SHA512 f78bf1ee6082488efe2e581984c85ffbddbfb7e5adfdf491232e93a8376580275f329e2d02c482afd70bbc70f62ca6f0b3bce636cff58b0a1d592dd4b8194e3a
DIST zim-0.74.2.tar.gz 3008954 BLAKE2B d0ecf666804931412f6e32aef54193ed96c67049e0fd3e7a373973d4826f16a9483eaa0940cc953573c104c704115905b036e5d0355961c0be86bebc6189bd9a SHA512 112c1e9d28a10643711f665e03c8a37259637b3471338aaca0a834afcc96c658ca5bf863e63bd5f01ce1fcdfb3eef3f2dcf1d10f8113d2158af2e91234b023b9
DIST zim-0.74.3.tar.gz 3108228 BLAKE2B fbaaddbd5522ccffcba87da2f4080e93e46dfcdc22771a414daa813cdbc2982738c2bf6f068f4bddf788965b4cf45594f2720a697c04d71194f513d1d9b43875 SHA512 9f885571800e3aba327a46b3bc8677ca596fb2d0a58e2f65190d9e2bc90f013655947d86c1fc869e2d79a5c0ba8a7a4d907a00f8d7563116291df47d8c2c677d
+DIST zim-0.75.0.tar.gz 3178872 BLAKE2B 71fcd9363fc238be6ca48f44e826d0ca1ac62fdb609f2397f2dbd6acf3601980b861bc1424e1834728179f1a9c29332bf4709010643b77c8daec6299688cbb0c SHA512 9b8c5be64b2d45de2b02770e91f1950928d8f2214fc0c6099cd57bf61e3749911f46c4ec7815c9e322559ce155db2475e3b1347a81d2b76a82cd848dd4af3864
diff --git a/x11-misc/zim/zim-0.75.0.ebuild b/x11-misc/zim/zim-0.75.0.ebuild
new file mode 100644
index 000000000000..c1c46330e03f
--- /dev/null
+++ b/x11-misc/zim/zim-0.75.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_SINGLE_IMPL=1
+VIRTUALX_REQUIRED=test
+inherit distutils-r1 optfeature virtualx xdg
+
+DESCRIPTION="A desktop wiki"
+HOMEPAGE="
+ https://zim-wiki.org/
+ https://github.com/zim-desktop-wiki/zim-desktop-wiki
+"
+SRC_URI="https://github.com/${PN}-desktop-wiki/${PN}-desktop-wiki/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ ')
+ x11-libs/gtk+:3[introspection]
+ x11-misc/xdg-utils
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md PLUGIN_WRITING.md README.md )
+PATCHES=( "${FILESDIR}"/${PN}-0.60-remove-ubuntu-theme.patch )
+S=${WORKDIR}/${PN}-desktop-wiki-${PV/_/-}
+
+python_prepare_all() {
+ if [[ ${LINGUAS} ]]; then
+ local lingua
+ for lingua in translations/*.po; do
+ lingua=${lingua/.po}
+ lingua=${lingua/translations\/}
+ has ${lingua} ${LINGUAS} || \
+ { rm translations/${lingua}.po || die; }
+ done
+ fi
+
+ distutils-r1_python_prepare_all
+ export XDG_RUNTIME_DIR=fakethis
+}
+
+python_test() {
+ if has_version dev-vcs/git; then
+ git config --global user.email "git@example.com" || die
+ git config --global user.name "GitExample" || die
+ fi
+
+ virtx ./test.py
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "GNU R Plot Editor" dev-lang/R
+ optfeature "Spell checker" dev-python/gtkspell-python
+ optfeature "Version control Bazaar support" dev-vcs/bzr
+ optfeature "Diagram Editor" media-gfx/graphviz
+ optfeature "Insert Screenshot" "media-gfx/imagemagick media-gfx/scrot"
+ optfeature "Score Editor" media-sound/lilypond
+ optfeature "Gnuplot Editor" sci-visualization/gnuplot
+ optfeature "Equation Editor" virtual/latex-base app-text/dvipng
+}