summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-12-30 14:21:45 +0100
committerJeroen Roovers <jer@gentoo.org>2018-12-30 14:30:37 +0100
commit1936449120312ece386ee089d1a818c1d93f8aa7 (patch)
tree11a7b21bb158c9cc92ea9072ad1d9b691bf2bf26 /x11-misc/xpad/xpad-5.3.0.ebuild
parentkde-apps/gwenview: Fix build with exiv2-0.27 (diff)
downloadgentoo-1936449120312ece386ee089d1a818c1d93f8aa7.tar.gz
gentoo-1936449120312ece386ee089d1a818c1d93f8aa7.tar.bz2
gentoo-1936449120312ece386ee089d1a818c1d93f8aa7.zip
x11-misc/xpad: Version 5.3.0
Package-Manager: Portage-2.3.53, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc/xpad/xpad-5.3.0.ebuild')
-rw-r--r--x11-misc/xpad/xpad-5.3.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-misc/xpad/xpad-5.3.0.ebuild b/x11-misc/xpad/xpad-5.3.0.ebuild
new file mode 100644
index 000000000000..683c0124fb09
--- /dev/null
+++ b/x11-misc/xpad/xpad-5.3.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="a sticky note application for jotting down things to remember"
+HOMEPAGE="https://launchpad.net/xpad"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-fbsd"
+
+RDEPEND="
+ >=dev-libs/glib-2.56:2
+ app-accessibility/at-spi2-atk
+ dev-libs/atk
+ sys-devel/gettext
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3[X]
+ x11-libs/gtksourceview:3.0
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/pango
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-util/intltool-0.31
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}