summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-05-14 12:43:16 +0200
committerJeroen Roovers <jer@gentoo.org>2016-05-14 12:47:36 +0200
commit5ed531e50ec8f10a6b8dd096468ac176ffec0ccc (patch)
tree43037e6abcf83b37d0c3a30f67162be6abb1d743 /x11-misc/xlockmore/xlockmore-5.47.ebuild
parentbase/package.use.mask: [QA] Mask sys-devel/gcc[jit], #569608, #583010 (diff)
downloadgentoo-5ed531e50ec8f10a6b8dd096468ac176ffec0ccc.tar.gz
gentoo-5ed531e50ec8f10a6b8dd096468ac176ffec0ccc.tar.bz2
gentoo-5ed531e50ec8f10a6b8dd096468ac176ffec0ccc.zip
x11-misc/xlockmore: Version bump.
Package-Manager: portage-2.2.28
Diffstat (limited to 'x11-misc/xlockmore/xlockmore-5.47.ebuild')
-rw-r--r--x11-misc/xlockmore/xlockmore-5.47.ebuild107
1 files changed, 107 insertions, 0 deletions
diff --git a/x11-misc/xlockmore/xlockmore-5.47.ebuild b/x11-misc/xlockmore/xlockmore-5.47.ebuild
new file mode 100644
index 000000000000..6f246b15debb
--- /dev/null
+++ b/x11-misc/xlockmore/xlockmore-5.47.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils flag-o-matic pam
+
+DESCRIPTION="Just another screensaver application for X"
+HOMEPAGE="http://www.tux.org/~bagleyd/xlockmore.html"
+SRC_URI="http://www.tux.org/~bagleyd/xlock/${P}.tar.xz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="crypt debug gtk imagemagick motif nas opengl pam truetype xinerama xlockrc vtlock"
+
+REQUIRED_USE="
+ || ( crypt pam )
+ pam? ( !xlockrc )
+ xlockrc? ( !pam )
+"
+RDEPEND="
+ gtk? ( x11-libs/gtk+:2 )
+ imagemagick? ( media-gfx/imagemagick:= )
+ motif? ( >=x11-libs/motif-2.3:0 )
+ nas? ( media-libs/nas )
+ opengl? (
+ virtual/opengl
+ virtual/glu
+ truetype? ( >=media-libs/ftgl-2.1.3_rc5 )
+ )
+ pam? ( virtual/pam )
+ truetype? ( media-libs/freetype:2 )
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/libXt
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xineramaproto
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.46-freetype261.patch
+ "${FILESDIR}"/${PN}-5.47-_BSD_SOURCE.patch
+ "${FILESDIR}"/${PN}-5.47-CXX.patch
+ "${FILESDIR}"/${PN}-5.47-strip.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=()
+
+ if use opengl && use truetype; then
+ myconf=( --with-ftgl )
+ append-flags -DFTGL213
+ else
+ myconf=( --without-ftgl )
+ fi
+
+ econf \
+ $(use_enable pam) \
+ $(use_enable xlockrc) \
+ $(use_enable vtlock) \
+ $(use_with crypt) \
+ $(use_with debug editres) \
+ $(use_with gtk gtk2) \
+ $(use_with imagemagick magick) \
+ $(use_with motif) \
+ $(use_with nas) \
+ $(use_with opengl mesa) \
+ $(use_with opengl) \
+ $(use_with truetype freetype) \
+ $(use_with truetype ttf) \
+ $(use_with xinerama) \
+ --disable-mb \
+ --enable-appdefaultdir=/usr/share/X11/app-defaults \
+ --enable-syslog \
+ --enable-vtlock \
+ --without-esound \
+ --without-gtk \
+ ${myconf[@]}
+}
+
+src_install() {
+ default
+
+ pamd_mimic_system xlock auth
+
+ if use pam; then
+ fperms 755 /usr/bin/xlock
+ else
+ fperms 4755 /usr/bin/xlock
+ fi
+
+ dodoc README docs/{3d.howto,cell_automata,HACKERS.GUIDE,Purify,Revisions,TODO}
+ docinto html
+ dodoc docs/xlock.html
+}