summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/xdock
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/xdock')
-rw-r--r--x11-misc/xdock/Manifest1
-rw-r--r--x11-misc/xdock/files/xdock-0.2.0-ldconfig.patch8
-rw-r--r--x11-misc/xdock/metadata.xml8
-rw-r--r--x11-misc/xdock/xdock-0.3.0.ebuild26
4 files changed, 43 insertions, 0 deletions
diff --git a/x11-misc/xdock/Manifest b/x11-misc/xdock/Manifest
new file mode 100644
index 000000000000..dd50f44bde0d
--- /dev/null
+++ b/x11-misc/xdock/Manifest
@@ -0,0 +1 @@
+DIST xdock-0.3.0.tar.gz 345753 SHA256 eaa70e0890cde23d2dd6821ad4825a0b096d2def4a437ad01d2b6bfbf77f3d75 SHA512 72fcfa4ae643a054c2ea1a4a4bc2772cb961dedfbb8d85acfaa997bea574cb6b2df3f88bc6bb9dae3a2a27a7a0136887c79e2508ff2e69998c4c985d34080e88 WHIRLPOOL 77b839b3eca278a6fe602de92c92a54d76c928c2cc17ffe3ee892a98a55d5d4560935b77c9f53a052e94b778cc11e86e4677c92cecf2fc0e4df72785698b98b2
diff --git a/x11-misc/xdock/files/xdock-0.2.0-ldconfig.patch b/x11-misc/xdock/files/xdock-0.2.0-ldconfig.patch
new file mode 100644
index 000000000000..31956ccd8362
--- /dev/null
+++ b/x11-misc/xdock/files/xdock-0.2.0-ldconfig.patch
@@ -0,0 +1,8 @@
+--- a/src/lib/Makefile.am
++++ b/src/lib/Makefile.am
+@@ -8,5 +8,3 @@
+
+ include_HEADERS = xdock.h
+
+-install-exec-hook:
+- ldconfig
diff --git a/x11-misc/xdock/metadata.xml b/x11-misc/xdock/metadata.xml
new file mode 100644
index 000000000000..0e065732328d
--- /dev/null
+++ b/x11-misc/xdock/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-dock</herd>
+ <upstream>
+ <remote-id type="sourceforge">xdock</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/xdock/xdock-0.3.0.ebuild b/x11-misc/xdock/xdock-0.3.0.ebuild
new file mode 100644
index 000000000000..4427a3bf6cb5
--- /dev/null
+++ b/x11-misc/xdock/xdock-0.3.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="emulates Window Maker docks (runs in any window manager)"
+HOMEPAGE="http://xdock.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}"
+
+DOCS=( API AUTHORS ChangeLog README TODO )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.2.0-ldconfig.patch
+ sed -i -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' configure.ac || die
+ eautoreconf
+}