summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2022-07-17 18:47:28 +0200
committerPiotr Karbowski <slashbeast@gentoo.org>2022-07-17 18:49:20 +0200
commitd3745c83f2885d2f0705c2a807ec984eb12265c9 (patch)
treee620ca187036148f48f64e731e4f84eb715eb072 /x11-misc/sunflower
parentmedia-libs/gmmlib: add 22.1.6 (diff)
downloadgentoo-d3745c83f2885d2f0705c2a807ec984eb12265c9.tar.gz
gentoo-d3745c83f2885d2f0705c2a807ec984eb12265c9.tar.bz2
gentoo-d3745c83f2885d2f0705c2a807ec984eb12265c9.zip
x11-misc/sunflower: 0.5 version bump.
Closes: https://bugs.gentoo.org/853850 Closes: https://bugs.gentoo.org/835410 Closes: https://bugs.gentoo.org/746176 Closes: https://bugs.gentoo.org/737830 Closes: https://github.com/gentoo/gentoo/pull/26075 Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'x11-misc/sunflower')
-rw-r--r--x11-misc/sunflower/Manifest2
-rw-r--r--x11-misc/sunflower/sunflower-0.5.ebuild (renamed from x11-misc/sunflower/sunflower-0.4_p20200716-r2.ebuild)16
2 files changed, 15 insertions, 3 deletions
diff --git a/x11-misc/sunflower/Manifest b/x11-misc/sunflower/Manifest
index ecbe1e0c9ccc..515eda905f39 100644
--- a/x11-misc/sunflower/Manifest
+++ b/x11-misc/sunflower/Manifest
@@ -1 +1 @@
-DIST sunflower-0.4_p20200716.tar.xz 830248 BLAKE2B 673b320bf08c0e0600fae06a531f75403b0e76bd8a267918986da84537a5213f0a1d99c9de74820f15652b80959e9029566f4611138893f08919f389a66a8032 SHA512 0e30bbadb3d60a64e2a2b629104c2a3ad88d997d581c1c76ef593afa1d3c48aafd185b4cd36da25bed5c3e9b9d1389f0709aaa40e796e883dccfe71b214620ed
+DIST 0.5-63.tar.gz 784093 BLAKE2B eef6fe3749137ac44cddb730549ca4eeed240d17bd7c4d0ac5b70f95e16f5eb57590a22a87150fabac31051219837aeeef32869f07d5def37784526181a3dd32 SHA512 ddf303dc873d38c4e5f8b2026f70088d40cb82ea2a10c91bd9c21938467fb797dd6bae3211b82cb2328fa212f880d878f2a799c2688da725ac5a448a11c3244d
diff --git a/x11-misc/sunflower/sunflower-0.4_p20200716-r2.ebuild b/x11-misc/sunflower/sunflower-0.5.ebuild
index 40f32e2ea597..e4571e23d968 100644
--- a/x11-misc/sunflower/sunflower-0.4_p20200716-r2.ebuild
+++ b/x11-misc/sunflower/sunflower-0.5.ebuild
@@ -1,16 +1,19 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="sqlite"
inherit distutils-r1 xdg
+MY_PN="Sunflower"
+MY_PV="${PV}-63"
+
DESCRIPTION="Small and highly customizable twin-panel file manager with plugin-support"
HOMEPAGE="https://github.com/MeanEYE/Sunflower
https://sunflower-fm.org/"
-SRC_URI="https://dev.gentoo.org/~slashbeast/distfiles/${PN}/${P}.tar.xz"
+SRC_URI="https://github.com/MeanEYE/${MY_PN}/archive/refs/tags/${MY_PV}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
@@ -25,3 +28,12 @@ DEPEND="
RDEPEND="${DEPEND}
dev-python/pycairo[${PYTHON_USEDEP}]
"
+
+S="${WORKDIR}/${MY_PN}-${MY_PV}"
+
+src_prepare() {
+ default
+
+ # Upstream's get_version requires a lot of BDEPENDS we do not want.
+ sed 's%version=get_version()%version="0.5"%g' -i setup.py
+}